[Guide] How to flash a modded AMI UEFI BIOS

Only flash option I can try is Afudos with usb key or Afuwin / GAN

Hi MeatWar.
I followed the instructions created by the oldguy user with the same H87 mobo but stopped at those last instructions. I can’t run afuwin64.exe in the command line windows 10.could you show me where and how to insert exactly please?

Successfully done.Last question.
Where I can find the the right bios settings for NVMe ssd with pcie adapter installed .

To read and learn: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS - NVMe Support for old Systems - Win-Raid Forum

A post was merged into an existing topic: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Hi, I was trying to use your guide, but the link to re creating the CAP file seems to be broken, and I seem to need that step to proceed?:

Only for ASUS BIOSes, whose capsule had been removed by extracting the “Body”, but shall be flashed by using the ASUS USB Flashback feature:
Don’t forget to re-insert the original capsule and to save the modded BIOS as *.CAP file!

Can you either point me to the correct place ,or just explain what needs doing, thanks in advance.

Edit by Fernando: Broken and misleading link within the quoted text removed

You… who…??? Use @username and that user will be notified.

Using the UEFI tool to extract (UEFItoolNA version) and replace (UEFI tool regular version) the bios region, by the mod one.

LongSoft/UEFITool: UEFI firmware image viewer and editor (github.com)

That’s Correct Fernando, just what I was trying to do.
This is a different link to that previously pointed to, but suggests an answer.
Seems I just rename the .rom file as specific name .cap file, and put it onto a USB stick…
so I can use USB flashback…
So far it fails… but there we go.

So, to be clearer. I downloaded the file for my motherboard, P8Z77-V-PRO-ASUS-2104.CAP
and the NvmExpressDxe_5.ffs file to add the NVMe capability.

downloaded UEFITool.exe and extracted the body, to get a rom file.

Downloaded and used the MMTool to put the NVM into the rom file.

renamed the rom file Z77VP.CAP as per the document DE103_Z77_H77_Series_BIOS_Renaming.pdf

Dropped it onto a recently formatted small size USB stick, and put it into the flashback usb port.
Shutdown the computer, pressed the usb flashback, and waited? 4 maybe 5 flashes, then with a light on? for 10 mins or so, and nothing seemed to happen, so something failed.
Tried with a few usb sticks… no change…

No…after inserted the NVMe dxe driver, the mod rom is to replace the previous bios region you extracted with the UEFItool, again on the CAP file, then the file is renamed and USB BFB will work.

EDIT: Where did i mentioned MMtool for the bios region swapping operation on the CAP???.. i said UEFI tool, MMtool is only for the insertion of NVMe DXE


REPLACE with the mod file already with NVMe inserted:

Saving will now ask to rebuild and view the new file.

EDIT: “Within the CAP file, so the newly created file, is presumably the file to rename and then flash to the bios…”
Yes, now rename the CAP according Asus BFB and use it with it, thats it if the NVMe was correctly inserted upon the guide, follow the OS nstallation instructed also in the guide.

Oh OK…
so, after MMTool used to put NVM into the rom file…
How do you then replace the bios region in the cap file with this version?

Or, do you just edit the CAP file with the MMTool to put the Nvm driver directly into it?
In which case why use the UEFITool at all?

Thought I was following the instructions Ok before, now not sure at all.

OK, so use UEFItool to extract the Bios region only.

Your images do not show the AMI Aptio capsule level… again, maybe relevant.

edit the exported rgn file to add the NVMe driver.

and then you have an option to replace the bios region with this file? its greyed out for me, as per your first image?

I note you seem to be using 2 different version of UEFITool, is that relevant?
The version I have is NE alpha 60

I also note your file is a .BIN file not .CAP?

OK, downloaded another version, following your version numbers, the latest is 0.26.0 and this does let me replace the bios, as you said…
Within the CAP file, so the newly created file, is presumably the file to rename and then flash to the bios…

EDIT 3: Yep… That worked, I now have NVMe support in the Bios…
Now to setup the OS on device.
Thanks Very much for your help on this, much appreciated.

If you address your post to a certain Forum member, you should do it by using the @ feature of the Forum. Only this way the related person will get instantly notified about your post.

OK - thanks - didn’t know that one.

Just adding a thankyou to you Fernando, for making this possible!


Hi I read all the guide, I tried to use ezflash but it doesn’t work, I tried with Flashrom v1.2 Utilities but I got this error:

and with ami aptio i don’t understand if i should use afudos or afuefi

You can use either the tool AFUDOS or AFUWin, both should be designed by AMI for Aptio IV BIOSes.
If you want to use AFUDOS, you have to boot off an USB stick running MSDOS or FreeDOS.
If you want to use AFUWIN or AFUWINx64, you can flash the BIOS from within the related 32/64bit Windows OS.
In both cases you should use the older version 3.05.04 of the tool (links are within the start post), because the newer ones do not support the " /GAN" command suffix.
You will have to flash the BIOS twice:

  1. The original BIOS as *.CAP file (with the capsule header) and
  2. the modded BIOS as *.ROM file (after having removed the capsule header).

For details please read >this< guide written by OldGuy (the link has been fixed by me within the star post).
Good luck!

Hello and thanks again for the reply, then with afudos I was able to write the bios in .cap without problems but when I go ahead and try to use the .rom file the /GAN command I get the error unknown command

I try the previous windows version using the /GAN command, I’ll let you know how it goes

I used the windows version and I succeeded windows started without problems thank you very much have a nice day

1 Like

Thanks for your feedback and the report, that the " /GAN" command suffix doesn’t work with the currently latest AFUDOS version v3.07.01. The version 3.05.04.ones seem to be the latest AFUDOS and AFUWIN tools, which do support the " /GAN" option. As a consequence I will customize the related guides.
It is fine, that you finally succeeded and now can boot off the NVMe SSD with your old ASUS mainboard.
Enjoy it!


of nothing is a duty, I also come from years of forums and guides made by me, I understand and know well the commitment that must be dedicated and rightly so, anyway thank you again it was 2 days that I could not understand why this nvme it didn’t work you don’t know how much it helped me

Hi All! I try to write modified bios with Flashrom tool to ASRock H310M-STX from freedos.
But receive some errors. Can somebody help? Is any other way to flash it?
Dump log Write log

Whats your doubts here, cant you read the log?
Only bios_region can be written.
The Intel FPT tool can write this region, the correct tool for your ME FW version

Full backup: fpt -d spi_full.bin
Bios region dump: fpt -bios -bios -d bios_reg_bak.bin
Bios region write: fpt -bios -f bios_reg_mod.bin


[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

1 Like