[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Yes read the guide again related to the pad file verification and methods used. File name can be simply renamed as this is no relevant issue, the pad IS.

EDIT: Try open your eyes a bit more…

Step 2 - BIOS modification (2 alternative Methods):
c) Verification of the successful insertion

Could you provide me the guide related to the pad files? this guide only says to report the issue here.

i might be blind (probably i am) but i dont see any solutions than just the cause (wrong bios configuration). If my bios config is wrong or something what am i supposed to do ???

Thats why theres 2 methods to do the mod… AMI MMtool and UEFI tool (This is one also to compare)

3 tools to use AMI MMtool 4.x, UEFI tool 0.25 or 0.28, one of then will work and preserve the original pad-file in the mod file.

11 posts were split to a new topic: [Offer] MSI B85M-G43 NVME Mod BIOS

3 posts were merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

Hello, another blind guy here! :slight_smile:
I was trying to mod my Gigabyte H81M-S2H. And I stumbled upon something odd, so I just want to confirm it’s alright.
I modded latest bios from Gigabyte website.
When I used the MMTool, it said the “big” version exceeds the volume size (for both “as is” and “compressed” FFS options). The small version went through though. But when I verified it using UEFItool, I found one pad-file missing.

Then I tried modding the file using UEFItool, followed the instruction, inserted the small version, verified again - the pad-file was missing again. Tried both UEFItool 0.28 and 0.25.1, same results.

The odd thing is… I also tried to insert the “big” version using both UEFItool versions and it didn’t say any warnings about size (like the MMtool did). And when I verified the final files, the pad-files seems to be in correct places.

Could this last “variant” be actually ok?

You’re excused from this “blind” group…for now, still…

Ok do it again with MMTool 4.x and the small variant, but first remove some DXE


I have an MSI x79a GD65 8D main, latest BIOS version 4.8, I am trying to add NVMe support.

At the Step 2: BIOS modification, after inserting “NvmExpressDxe_5.ffs” file into the original BIOS, it shows the “NvmExpressDxe_5.ffs” is the last module in the list. (CORRECT)

But after saving the moded BIOS, I reopen it to check, and it shows that the “NvmExpressDxe_5.ffs” module is not the last one, in fact, it swaps position with the empty named module just above it (the one with “00010018” bytes size and GUID “05CA01…”).

As the guide, 2c step (verification) says the inserted module “NvmExpressDxe_5.ffs” MUST be the LAST ONE (ULTERMOST), so I don’t know how to move on?

Repeating the modification steps still results in the same issue.

I try to use UEFITool, open the original bios:

One pad file exists before the module with GUID “05CA01…”.

After inserting NVMe module (insert after), I have this:

Note that the pad file before the module with GUID “05CA01…” does not exist anymore.

But opening the output from UEFITool by using MMTool, it looks okay: (the NVMe module is the last one in “01” volume)

I have check that the file size if OK.

I believe that I fall into this red warning:

Pls help.

Please attach or post links to your modded and the original BIOS file.
Then we can try to solve the problem.

1 Like

Hi Fernando,

The original bios is downloaded from MSI site.

Both output files have issues described in my previous post.

Pls help. Thank you!

Hi Fernando,
I don’t know anything about BIOS, but looking at the source and output files, I think the “NvmExpressDxe_5.ffs” file should be inserted at offset “006E0000”, the start of Volume free space, is it correct?

This is my calculation, based on the report from MMTool and from UEFItool user interface:

So I try to create the file myself here, by copying “NvmExpressDxe_5.ffs” file to the start of volume free space. File size remains the same, and volume free space size down an amount equal to the nvme file size.
e7760ims.480.self.fd - Google Drive

Both MMTool and UEFItool shows Okay, but as I dont know anything about BIOS, so I am not sure. Pls help me to validate it.


Thank you!

Thanks for the links to the BIOS variants. Meanwhile I have checked them.
Here is my evaluation: You can flash the BIOS, which was modded by the AMI Aptio MMTool.
The NVMe module has been correctly inserted by the AMI Aptio MMTool as undermost “DXE Driver” without moving/deleting/inserting any Pad-file.
Good luck for the flashing procedure!
Please read the start post of >this< thread before you start doing that. You have to rename the BIOS file.

1 Like

Fernando, do you mean that the output from MMTools is good?

But the nvme is not the last module, i am still confused.

And from UEFItool, it shows that the pad file was resized from B1458 to ACE18h bytes.

Pls explain, thank you!

15 posts were split to a new topic: [Problem] Apple SSD doesn’t work with Windows


It is the undermost “DXE Driver module”. A Pad-file doesn’t count.

All modules of the compressed DXE Volume have been resized, because you have inserted an additional module. Since the total size of the BIOS must not be changed, the BIOS Tool enhances the compression of the DXE Volume and its components.

1 Like

Sorry, but is the one with GUID “05CA01…” a pad file?

The post #1 says: the undermost module of the related volume, but you says “undermost DXE driver module”. So which is correct? I am still confused.

  • The last (undermost) module of the related Volume Number should now be new and named either “NvmExpressDxe_5” or “NvmExpressDxe_small” (depending on the module variant you had previously inserted.

No, it is a “Raw” module (neither a “DXE Driver” nor a “Freeform” module.
You can verify it yourself by opening the BIOS with the UEFITool.
The AMI MMTools don’t show Pad-files.

You are right - my guide was not exact enough regarding your quoted sentence. To avoid any future confusion I have now replaced the words “undermost module” by the words “undermost DXE Driver module”.
I hope, that all your questions have been answered by me and you can now flash the modded BIOS.
Good luck!

1 Like

I was lucky enough to find an experimental/incomplete uefi bios and this great thread for my old msi p45 motherboard. I know have revived an old pc, added a nvme boot drive with uefi windows thanks to this guide . I wonder if i could increase ssd speeds (my pcie adaptor supports 4 lanes i could use 8 lanes on this board’s pciex 16lane). Thanks, and happy new year!

PCIe lanes are the physical link between the PCIe supported device and the processor/chipset.
Assuming a common NVme 3.0 x4 disk:
You’re NVMe disk will only uses x4 lane bandwidth, regardless the adaptador mechanical design or PCIe slot mechanical design higher than x4.
Even so, as on your motherboard the PCIe generation is not 3.0 (8.0G/Ts), it will only use 2.0 (5G/Ts) x4 maximum speed.
You cant “squeeze” more from a old P45 chipset PCIe2.0
What you have now is the NVMe possible miracle on this motherboards generations and cant never
achieve the performance provided on the technology used in latest chipsets.

All Types Of PCIe Slots Explained & Compared (cgdirector.com)

Guide to PCIe Lanes: How many do you need for your workload? (cgdirector.com)