[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

I’m just asking which is better, the NvmExpressDxe_5 driver or the driver taken from Z97/Z170

You may not realize a difference, but I recommend to insert one of the NVMe modules, whose download links can be found within my Guide (= the first post of this thread).
They are newer, perfectly optimized and 100% matching all AMI UEFI BIOSes without native NVMe support.

I have modded the bios of MSI Z77MA-G45, the result is like the sc image. I downloaded the latest official bios, opened it, inserted mod NvmExpressDxe_5 in CMSCORE and then saved (using MMTool I have checked all the original files, there are no changes, only the addition of the nvme driver, no red notif. Have I done it right?

According to the pictures: Yes, everything seems to be fine!
Good luck for the flashing of the modded BIOS!

Hello, can I get some help on modding a BIOS file. This is the second BIOS that I am trying to MOD - with the previous one I didn’t have any problems, but with this one I do. The problem is that after doing everything right, verifying the inserted module is present in the modded BIOS file, I cannot flash it. BIOS gives me an error “Secure flash check fail”. Can anyone give an advice what could of I done wrong, or what I need to do to get it right. Could it be some kind of a checksum error or something like that?
The motherboard is Asrock FM2A75M-DGS R2.0, the latest BIOS is v. 1.60. I flashed this file and the operation completed successfully, since the one I was cooking didn’t work…

[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

I found it and did it using the UBU tool, thank you. It worked

Hi, can anyone check my NVMe module? At left side the BIOS backup and right the modBIOS NVMe.

Edit by Fernando: Since the originally attached big sized picture was not appropriate for a check, I have removed it.
As MeatWar already has mentioned, the complete BIOS files (original + modded) should be attached as *.ZIP file(s).

Not even a motherboard model identification…nice indeed.
This not the proper way to check it and not according the guide.
And this capture screen is also not correct way, share the original and mod files here or in a sharing service of your preference.

Would someone please give me a hand with this Acer B75H2-AM (M4620GH) BIOS? I tried several NVMe modules, but MMTool complains about all of them exceeding the size.

I don’t mind if the filesize increases to be honest, even if that means soldering in a larger capacity BIOS chip.

BIOS Download:
m4620gh.zip (2.0 MB)


You can safe remove all network-related drivers from DpcDxe to Udp6Dxe if you don’t use UEFI network boot, in order to get some space on the bios volume.

Thanks, that worked.

Thank you very much for all your effort.
I followed your guide, using UEFITool: I loaded the (ASUS) BIOS, extracted the body removing the capsule, inserted the EFI NVMe module and saved the modded BIOS file (.rom).

I have a question about when you say:
"**Only for ASUS BIOSes, whose capsule had been removed by extracting the “Body”, but shall be flashed by using the ASUS USB Flashback feature:
*Don’t forget to re-insert the original capsule and to save the modded BIOS as .CAP file!"

How is that last operation done? I cannot find any instruction about how to re-insert the original capsule.

Thank you for your attention and help.

Welcome to the Win-RAID Forum!
>Here< you can find a guide about how to re-insert the capsule of an ASUS BIOS before going to flash the modded BIOS by using the ASUS “BIOS Flashback” feature.
Good luck!
Dieter (alias Fernando)

Thank you very much for your indication! The guide you pointed at was very helpful.
Hopefully, I succeded in obtaining a modded BIOS wich includes NvmExpressDxe_5.
As a new user, I am not allowed to upload attachments. How can I submit the modded BIOS for checking by forum experts?
Thanks again

If you cannot directly attach the *.zip or *.rar compressed BIOS files (original + modded), you should upload them to any file hoster and give us the link.

…here is the link to the .zip file ‘P9X79-ASUS-4701.zip’:

The insertion of the NVMe module seems to be well done. According to what I see the modded *.CAB BIOS is ready for being flashed via USB Flashback (after having customized the name according to the ASUS USB Flashback rules).
By the way - why did you add the original BIOS file twice?

Thank you for your prompt feedback.
I didn’t notice I had added the original BIOS twice, until you highlighted that. Sorry, it was unintentional.

Hello and thanks for that huge topic and the whole support for all the people here. Really great.

I read and tried a lot but I can’t get it done to get my get my ASUS M5A99X EVO R2.0 modded.
In this forum is also a thread where someone got a request for that MB. Unfortunately the link inside this thread https://winraid.level1techs.com/t/request-nvme-for-asus-m5a99x-evo-r2-0/36216/2 to download the modded BIOS is not accessible.

Let me first explain what I have done so far, following steps at the beginning of this thread:
Donwloaded MMTool (Ver and UEFITool (Ver 0.28.0) and the NvmExpressDxe_5.ffs.
Downloaded the latest BIOS Version 2501 for my MB from ASUS.
Created two folders.
Opened my BIOS with UEFITool and extracted the partition/part where the CSMCORE is located.
Opened this part with MMTool and inserted the NvmExpressDxe_5.ffs.
Saved the image.
In UEFITool I replaced the partition/part with the one from my step 5.
Saved it as a .CAP file.
Renamed the file with Brenamerl from ASUS.
Opende this new file to look if the NvmExpressDxe_5.ffs is in place. And it is, take a look at the pictures.
Put this file onto a Transcend Jetflash 8GB USB-Stick which is formatted in FAT32.
Rebooted my system into BIOS and startet the EZ Flashback.
After successfully installation the system was rebooted.
Unfortunately my Samsung 970 EVO will not show up.

I tried different “Save As” and “Extract As” and so on. Even different PCI to NVME adapter cards.
My Samsung will not show up during BIOS boot.

But I’m wondering, after inserting the file and saving, the file size is the same as before. How could that be? UEFITool shows here more details than MMTool.

Currently I’m using the Clover Boot with an USB-Stick. It is going but it’s not what I wanted and what I might can have. So, my ssd and my adapter card is working and are not broken.

Does anyone got an idea what I might doing wrong or have forgotten?
Please feel free to aks me questions when I have forgotten to tell some important details or steps.

Thanks in advice and kind regards

Michael Jost