[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Continuing the discussion from [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS:

Hi @Fernando

I checked with uefi tool if I had a module named “nvme” and I didn’t have one.
So I added the “NvmExpressDxe_5” module with MMtool following your guide to the letter and I compared the 2 bios with uefi tool.
Everything is the same except the addition of “NvmExpressDxe_5”.
So so far so good.
On the other hand, in your tutorial you explain to save the modified bios generally with the same name, are the capital letters important or not? (stupid question perhaps, I apologize).
And save the modified bios with the same extension as the original bios.
My problem is that my original bios has a .280 extension and when I save with MMtool it only suggests that it is in .fd
I haven’t tried with uefi tool.
Do I leave the modified bios in .fd and use msi m-flash to flash my bios or does the modified bios have to be in .280 to flash it with msi m-flash?
I thank you in advance for your help.

It is no problem to rename the modded BIOS file (inclusive its extension) by using capital or small letters from within the Windows Explorer.

P.S.: Since your question and my answer don’t need an extra thread, I have merged them with >this< already existing thread.

hi, I apologize for opening a new thread but this was the only way for me to be able to write a new message, because I was limited in messages posted in this thread.

When I look at your tutorial regarding the modified bios flash it is always marked that the modified bios must have the same extension as the original bios.

Original bios = .280
Modified bios = .fd with mmtool

Hence my question, can I flash the .fd bios placed alone on my usb key and passing through the bios of my motherboard to do it?

Or exactly the same thing except that the modified bios must be in .280 extension?

If yes for the second question, how do I change the extension of the modified bios from .fd to .280?

Sorry for constantly bothering you with my questions.
As it is not clear in my head regarding the modified bios flash despite the tutorial that you provided.

@ Dragons
You have to rename the modded BIOS and give it the complete name (inclusive extension) of the original BiOS.
Provided, that you have Admin rights, you can easily do it from within the Windows Explorer by right-clicking onto the related file and choosing the options „Show additional Options“ > „Rename“.

P.S.: The question “How to rename a BIOS file?” has nothing to do with the topic of this thread.

Aaaah ok.
As the file is a bios, I thought it would be necessary to use software to change its extension without altering the file.
I changed my modified bios to .280 and thank you for your response.

I apologize if my question how to rename a bios file had nothing to do with the topic of this thread.
In any case I thank everyone who helped me.
I just have to flash my bios with the modified bios file .280

Thanks again

A post was split to a new topic: [Request] NVMe mod BIOS for GA-H87M-D3H

6 posts were split to a new topic: [Request] NVme Support for Phoenix UEFI BIOS

I’m trying to modify the BIOS of an old Intel board DP55WB. The file cannot be decompressed by either MMtool or UEFITool.
Any idea why?

This is AMI bios based but specific for Intel, not a regular AMI Aptio IV Core bios file so several tools can’t handle it. Can be also an Insyde core based, as seen here.
What you may be looking for, is a more well-known structured bios image with all regions available, using a dump from the system should be what you’re looking for…

Anyway…most Intel mod files are impossible to flash with known methods, a SPI programmer is needed… you can confirm this on the forum, performing a deep search for several Intel mods attempts…

Thank You.

Hi Thank you for this helpful guide , I modded my ASUS P9X79LE BIOS successfully, but I have a problem .
The bios mod result is .ROM file and when I’m trying to update through UEFI ez flash I need a .CAP file … Does anyone know how to convert the file? I tried ASUS utility but same result .

Welcome to the Win-Raid Forum!
This is the thread about how to get full NVMe support, but not about how to get a modded ASUS BIOS properly flashed. The related thread can be found >here<.
Please read and follow the advices given within the ASUS related chapter of the first post.
Good luck!
Dieter (alias Fernando)

Thank you Fernando

I’ve been attempting to add NVMe support for a X10SLL-F board I’m using for a home server. I ran into the issue with padding described in this guide while trying to patch the DXE module in. The discrepancy I found looks like this, with the modded bios on the left. The pad entries under the highlighted entry seem to be missing.

I’m a new user, so it looks like I can’t upload attachments, otherwise I’d provide the bios files too.

Also, its worth noting that I tried just using the modded file form this post:

but the AFUDOS command seems to be hanging. I’ve left the system running for now, but I will probably go interrupt it and flash the unmodded bios for now so I can reboot.

Welcome to the Win-Raid Forum!
You are right - due to the big amount of pad-files it is not easy to get any NVMe module properly inserted into the BIOS file named X10SLL1.308.
Nevertheless I finally succeeded by using
a) the AMI Aptio MMTool for the BIOS modding and
b) the uncompressed “NvmExpressDxe_Small.ffs” module for the insertion.
As far as I could see all natively present Pad-files stayed untouched after the insertion of the NVMe module.
Tip: You will find the working MMTool v5.0.0.7 by doing a Google search for “MMTool Aptio 5.00.0007”.
Good luck!
Dieter (alias Fernando)

Thanks Fernando!
It actually looks like the BIOS from the other post I referenced did end up flashing correctly even though the flashing tool hung at the end of the process. But this is kind of an unsatisfying answer I think, so I’ll take a look at the MMTool you mentioned and see if I can get that to work.

7 posts were split to a new topic: [Request] NVMe mod GA-Z87 D3HP BIOS


Sorry I am having issues with my Supermicro board (X10DRU-i+). I got to the part of the instructions to show the volumes of DXE. But my BIOS doesn’t have a CSMCORE listed. And the note placed in the instructions doesn’t make sense to me.

Note: In the very rare case, that no module named CSMCORE is listed, you have to search for the upmost Volume, which contains modules with the letters “DXE” within their name.

I’ve also tried to insert the EFI NVMe module. And all my “Insert after…” options are greyed out and I can’t actually put it into the BIOS. I’m quite stuck, and any help would be greatly appreciated.

EDIT: Well I didn’t get it figured out. But I did find this post SuperMicro X10DRU-I+ BIOS 427 mod for NVMe boot. Where someone already modded the BIOS for my mobo so I just used this and it worked great. So for anyone looking for it go to that post.

Welcome to the Win-Raid Forum! It is fine, that you finally succeeded and now can boot off your NVMe SSD.

The sense of this additional note was to help users, whose mainboard BIOS doesn’t contain a module named CSMCORE, to find within the voluminous BIOS the target “DXE Driver Volume”, where the NVMe EFI module has to be inserted. Note: There are a lot of BIOSes, which contain more than 1 DXE Driver Volume and it is very important to find the matching one, because otherwise the BIOS modification would have no effect.
Please explain why this part of my guide doesn’t make sense to you. I would be grateful for a better understandable wording.

Thank you very much for this guide. Unfortunately, I am unable to patch my Gigabyte GA-H87-HD3 bios without either getting pad files added or removed. I’ve tried with both MMTool version and 5.0007. I have tried all 3 bios versions that are available (F10, F9, F8). Compressed NvmExpressDxe_Small is the only option that isn’t too big.

Any help would be greatly appreciated!