HP 250 G4 ME firmware update gone wrong

Thanks.Ok tomorrow i look into fptw utility the command to dump bios is this “fptw.exe -d bios.bin”, right?

Yes, right.

I use other names to have it more clear what I get but that’s just names
fptw.exe -d spi.bin

In case you don’t have read access for all firmware regions:
fptw.exe -bios -d biosreg.bin
fptw.exe -ME -d ME.bin
fptw.exe -DESC -d FD.bin

Be careful, only warning fpt* gives is about the size! Otherwise it writes without checking proper content.

ACPI errors are normal on these HP laptops, the RMRR error also is.

Do you think so? For me its okay as long it works but i cant enroll mok key after this update. Certainly i could disable secure boot and then i dont need mok anymore. I dont now is there any good to leave secure boot enabled on linux?

Hi lfb6. So i did what you asked me with fpt. Couldnt do a full dump of bios because of Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.
Same thing with fptw64 -ME -d ME.bin - same error as above. Other two commands were ok. Here are files
biosreg.zip (3.5 MB)
FD.zip (341 Bytes)
And i didnt understand how to run fpt from efi it starts but it gives me an Error 200: Invalid parameter value specified by user. Use -? option to see help.

1 Like

Looked into your bios-region, static parts are identical to stock bios, NVRAM has OK structure and enough space left.

One thing you could try would be:

  • Extracting ME region from stock firmware

  • Extract EfiSystemNcDataFvGuid from stock firmware

  • Put together a ‘new’ firmware image: FD - ME region (stock) - your bios region

  • Replace EfiSystemNcDataFvGuid in your bios with the one you extracted from stock bios

That would give you a freshly initiailized ME and an empty NVRam. But I doubt, that this will solve your acpi errors or the other errors…

Result should look like:
080C1_u_eNV.zip (4.5 MB)

Another thing you could try to flash a complete stock firmware

Both procedures would either require a service jumper or a CH341 programmer and could cause more errors than the ones you’re experiencing!

Hi lfb6. Thank you very much for your reply. What is service jumper . Is it some contacts that you have to solder on board. If it is. I didnt find any boardview for this model only schemes. So i dont know where is service jumper. So i think i’ll disable secure boot for the time being.

A jumper or a switch that’d allow you for reflashing ME (and maybe bios region, too)

OK. Thank you. I think i will buy programmer in future. For now i’ll opt for disabling secure boot.

Hi lfb6. Is this one good CH341 24 25 Serie EEPROM Flash BIOS Programmatore USB Modulo + SOIC8 SOP8 Clip di Prova Per La EEPROM 93CXX / 25CXX / 24CXX - AliExpress. Or its better to order ch341a version?

Those are cheap devices, descriptions are accordingly unprecise. There’s no warranty that you get a better CH341 if you buy more, most probably it’s just a higher sellers margin…

Most of the devices do work, some are doa or die quickly, so according to Murphys law the first CH341 will work completely fine if you buy two, and if you buy one it might be a doa device and you spend hours until you find out…

Biggest problem though is positioning of the clip, that requires quite an amount of training.

Thanks Ok but what about version CH341 or CH341A do you know what is better? As for the clip i am capable to desolder bios chip if there are problems with connecting it via clip.

Hi lfb6. What do you think. Could this two contacts be a service jumper.

Most probably not, looks like unequipped soldering pads for a capacitor. But there’s something labelled JME1 on the pic, I’d go for that.

But: It night work for ME region, for the complete firmware or not at all.

Thank you. So how i have to proceed. And what tools i have to use to flash that file that you created for me.

I’d recommend using the flasher- if you really want to proceed, it might be difficult to bridge the ME pads and the result is doubtful.

Read the chip, you need at least two dumps which are 100% identical and have a proper firmware structure in UEFIToolNE. Attach the dumps to your next post.

Thanks. Now I have to wait from 2 weeks to a month before the flasher arrives. In the meantime I read some guides. Then i post files here.

Hi lfb6. I ordered ch341 programmer. After a month its arrived and its was broken so i ordered another finally its here and i did two backups with diferent programs on windows and also on linux. Another problem when i tried to reinstall windows last time it dint retrive win key from inside the bios. So i think some part of bios is corrupted could you please look inside files. Thanks. https://www.dropbox.com/scl/fi/jyl4htnm18mdnlansj6m5/bios_dump.zip?rlkey=af001nu1as9s07ghhllbsamlz&dl=0
Also as i looked from linux, there is no msdm acpi table

That’s 4 month ago, I deleted the related stuff. But if I remember right the file from #13 ist the most clean image one could think of, so if you’re eager to proceed you might try it.

But I don’t think that will solve your problem, I assume Kuri0 is right here.

Good luck!

Thanks. Now i have a programmer with complete bios dump so i could try to flash without fear.