HP Bios battery notification

I own a HP Probook 6550b laptop. Each time I start the laptop, I get a Warning from bios about the battery. Please see the attached picture. Since it is an old machine, i am not planing to change the battery. It still works fine for about an hour. I tried to find any option on the Bios to disable that Warning/Notification but there is no way to do that. It shows for a long time, until you press ENTER. Tried the internet for any solution but could not find anything. There are some tips for the same problem on HP websites but they don’t really help. It is so frustrating to get that Warning each time you start the machine.
Bios ROMs attached too. Bios reference from HP: F.60 rev A
The warning states “internal battery”, but in fact it is the Main, external battery which is concerned. The CMOS battery is new. When I take off the Main external battery, the warning doesn’t show at all. When I plug it in again, the warning comes back.

Is it possible to mod the bios to disable that notification once and for all?

Thank you for replying


Rom_HP.rar (4.82 MB)

Mod is possible only if someone has already detected in the HP BIOSes a procedure for checking the status of the battery and reported about it.
From my point of view the big problem is that the error message is stored in a string array and there is no easy way to identify the module and place in the code from where this message comes out

Thanks for replying.
It sounds really complicated to achieve that. I was hoping it could be done with less efforts than what I read from your post.

Replacement battery is cheap on ebay, only $12.

I will look at BIOS tonight, but if Mox AX, 0xDEAD says it’s probably too difficult I’m sure I wont figure it out either.

Thank you for willing to do that.

It is not a matter of price, especially that cheap, but just to be able to disable that warning and control it as we wish. I have replaced 2-3 times (don’t really remember) the battery of this machine. I have seen that Alert/Notification hundreds of times until now. Really have had enough of it…
Thanks again for helping.

I know what you mean, I’ve seen it on Dell plenty and theirs is worse sometimes with "Not Dell power adapter"

Which BIOS do you use in the package you posted above? There is 3 BIOS files.
Please give me a link to the BIOS download pages, thanks!

When you have replaced the battery, with a generic hopefully, do you get invalid serial number warning?
I see this for serial numbers of the batteries, but I’ve never seen a battery w/ serial, and since this is BIOS updates from HP and not a dump from your laptop SPI with flash programmer, I assume this is irrelevant, leaving here for my notes and to discuss maybe.
Primary battery serial number----- 03 0B 10 00 2C 00 2D 00 00 00 00
Secondary Battery Serial Number— 03 0B 10 00 2E 00 2F 00 00 00 00

This might take a while anyway Do you have a flash programmer? If not, pick one up while we plan to play around with your BIOS, just in case!
CH341A flash programmer, they’re cheap usually only $2.50-$4
https://www.ebay.com/itm/263458010112 - Choose “Blue” model, and if $$ is no issue, get black one below too, it’s cheaper than ordering same one from this seller. Or get both from same seller, add blue to cart, go back and add black from same seller, then checkout.

I suggest both types, because often people have issue with one or the other in various situations, and they’re so cheap everyone might as well get both.
If your BIOS is soldered to the board (Of course!), grab one of these too

Maybe the CMOS battery is shorted, or it’s container is not soldered in good? I ask because all references I see to main battery are 602, there is even a fast charge setting in the BIOS for this as main battery (Secondary battery fast charge).

The warning would not be there as you mentioned with main battery removed, ie plugged into wall, for the CMOS battery error due to full power. Same would apply for either battery I assume.
Remove the CMOS batter and test, do you get this same error with main battery connected? Any error then with batter removed, power connected, if yes what error (601 or 602, or both?)

It is so encouraging to see your post above. Thank you for all your efforts.
I replaced recently the CMOS battery as it was dead. It needs dismounting the laptop to be replaced. I have been getting that Warning through the years, and it disappeared each and every time I replaced the main external battery. That is a well known issue with the HP products. I have found/read many many threads and articles about this through the years. Eg relatively new:

Here is the link to the bios download page:

Last time I replaced the battery was 2-3 years ago (sorry I don’t really remember)
There is/was no invalid serial number warning.

I really appreciate your willingness to assist. THANK YOU

You’re welcome! I believe you about the battery and how it acts, no need to pull CMOS then and do the battery dance, that only means HP has coded the BIOS wrong then as you probably suspected.

Thanks for the download link. You don’t already have a flash programmer by chance do you? If not, please go ahead and order one, the blue/green one is more user friendly/compatible, and you’ll need that clip too unless you’re good at soldering/desoldering.
To me, this is a must, otherwise I really wouldn’t feel comfortable sending you BIOS files to try, since any edits I make on this will likely be in the dark stabs First thing I thought to try with a quick glance in the BIOS, there is a separate battery module in the BIOS, I thought maybe blanking that entire file might help
But, I will of course dig deeper into the BIOS and see if I can find a setting to change first, such as detect all the way down to 0% battery is OK and does not equal this warning. Or test setting null to that and see etc.
There is many ways to try and fix this, but being able to recover from a failed test BIOS is really important and flash programmers are very cheap so there’s no need to not have one in advance.
This will also allow you to program any modified BIOS, no matter what HP software tries to say, sometimes software wont flash modified BIOS this alleviates that possible issue as well.
You can get them from a local seller too on ebay, if you don’t want to wait on long shipment from China (Blue/green guy ships fast, only 12 days to me last I ordered)

So I am sure I’m looking at modifying the correct files, since the download covers a few models, can you please do the following - To determine the ROM family and ROM date, press F10 on the notebook during startup to run the Setup Utility, and then view File/System Information
Or if you can specific which of these are your system ID that will do (146E / 1472 / 146D / 1471). If you can’t find this info, run hpqRun.exe and let it sit there, then check the hpqRun.log and you should find ID it detects I think, it logs failed to find key ID on my system so I bet it shows your ID once found.

Are you now currently using the BIOS F.60 Rev.A from 2015 linked on that page? If not, please update to that and see if the issue persists, and be sure to apply optimal defaults in the BIOS after the update.
Then see if there is any new option in the BIOS to turn this message off.

I’ll keep looking in the BIOS, there is many battery references and settings, I just have to find how and where to best adjust/disable/remove etc. if possible.

@ Lost_N_BIOS I really cannot believe someone is trying to help/assist getting rid of that warning. I will never say enough Thanks to you, getting it fixed or not.
Now, I am so sorry, I was mistaken when I wrote about Bios F.20. In fact I am using the latest Bios available since day one it was released: F.60 rev.A of 2015.
The System ID: 146E
Bios 68CDF F.60 Rev.A

About the flash programmer: I don’t have any. Unfortunately I am abroad for the rest of the summer, in the Balkans. Shipping to here it is not an easy task even if I order one. I could have one delivered at my place only when I’ll be back home by the second half of September.

You’re welcome! I can’t believe no one has fixed it for someone else already. That may be a bad sign though, it’s either not possible, or maybe someone did for other models but not this one. Have you looked around and found anyone disable/fix this warning for other HP models?

Thanks for the BIOS version you are using, that’s good you are on latest. And thanks for System ID, that tells me which BIOS I need to edit if I can figure out. Maybe it’s best since you are away from home, to not flash anything to this system until you are at home and can recover if needed.
That way you don’t end up with bricked laptop while away from home!

Can you see a setting called fast boot in the BIOS anywhere? If yes, right above that is what setting?

There is no Fast Boot setting in Bios, but I found something about the battery. See picture attached please

I enabled that option, but nothing changed. The warning showed again.
If it helps for the above question, in the picture there is an option, the first one: Startup menu delay (sec).



Yes, great, I thought you would see that but wasn’t sure since you didn’t mention before. That means this is a business class laptop, which I assumed when I found the business/corporate Intel ME.
Test putting checkmark there on the battery setting, then test without it.
Probably not much change, I think I read someone say it only takes away a URL link on the warning, which you can’t even click a URL to go anywhere in a warning like that anyway.

just edited my last post:)

Any news about that warning? Are you having a hard time with the HP bios?

Sorry, I have not moved forward with anything, because it only makes sense to make changes once you are home and have a flash programmer. That way you can test BIOS as I change, recover from bricked BIOS flash, test again new changes etc.
So, I was waiting until you got home to try anything more with this issue, since I can’t test anything on my end, any changes large or small would have unknown outcome until you can test each change.
No, HP BIOS is not a problem

Hey there!, sorry for bringing this one up… yet again.

I have a HP G42-285LA, that has the same error, and I want to try to fix it, just for fun I’d say. I could buy the products you mentioned years ago, but can’t seem to find one of them bc the product link is broken (yeah, the link is very old, that’s totally fine).

I’m just tired as well of that damn error and I’m willing to sacrifice some time in order to get rid of it once and for all (because there’s no solution at all online).

Thanks and sorry for the inconvenience.