Hp elitebook 2170p bios failure


I appreciate any thoughts on below issue.

I had an old HP elite book 2170p with bios password. One of YouTube video suggested to attempt updating the software with usb with HP bios update using win /b combination keys.

I tried it, nothing happened at all.

However, now when I press power button, the nout book does not turn on. the power button has no light, the screen is dark.

What’s possible to do in such situation?

Youtube… why not HP documentation?
HP Notebook PCs - Recovering the BIOS (Basic Input Output System) | HP® Customer Support

If no sign life… SPI Programmer (A backup of the current content of the SPI should be kept, for original system board data, before any write/flash).
need bios dump EliteBook 2170p - Badcaps Forums

Bios Elitebook2170p - Badcaps Forums

[Guide] Using CH341A-based programmer to flash SPI EEPROM - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[GUIDE] Flash BIOS with CH341A programmer - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

1 Like

Thanks for the links. I read HP docs before attempting this stupid USB thing, nothing worked.

Could you suggest what programming tool I need to flash bios?

Looked at Amazon with miriad available cheap no name made brands, but can’t get my head around what I need.

Which file did you use for the ‘update’?

Official bios update file from HP website, put it on USB stick as was suggested in their instructions.

What does ‘put it on USB stick’ mean here? Did you use the HP installation program to prepare the stick?

Yes, of course

Anyway, it’s the programmer, dumping the existing content of the chip and have a look what happened and what might be repaired.

Is it normal with bios failure problem, that there is no power light on a notebook at all? Never seen such thing before…

No, that’s a bad sign, often meaning that EC firmware is affected, too. That’s the controller that first stage powers up the machine when pressing the on- button.

But there are some machines which automatically load EC firmware from a defined area in the firmware, so it would be interesting to see how the corrupted bios did look.