HP Elitebook 840 G1 - Shutdown after 30 min

Hi everyone,

My laptop shutdown after 30 minutes despite the fact I am on Windows, Linux or on the bios menu. I think the problem appear after a bios update but not quite sure. After some research, I ended on your forum and your incredible post on intel ME. I also found some post with the same problem but the solution was not applicable.

Here is my laptop specification:

Here is the steps I tried during reading your pinned posts:

There no error on the last command but no result either. As you can see, the ME seems no to be enable and I cannot interract with it. I alse have installer the MEI driver v11.7.0.1069 and here is the end of the installation log file:

Is someone have a idea of what is going on?

@filovitch - When ME is corrupt or disabled, none of the commands you ran will work properly, so this is to be expected. Check your board over closely, and see if you find a 2pin header labeled FD/FDO/ME/Service etc. If you can find one of those, then we can fix this easily without a flash programmer.
If you do not have a 2pin header like that on the board, you will need to order flash programmer like CH341A or other, and SOIC8 test clip cable if your BIOS is 8pin and soldered to the board.

If you do have this 2pin header, put a jumper on it, and from windows run this command from Flash Programming Tools/Win folder (Read notice below first) >> FPTw.exe -d bios.bin
Then upload that file for me to fix for you. If you want to do it yourself, I would be using this ME cleanup guide and latest intel ME from the repo thread

* Note * Your ME FW version would be 9.5 something, or 9.1 etc if you had not updated it properly and previous was not 9.5 (Guessing), because I see on your download page ME FW 9.5 update package, so onboard ME could be 9.1.xx or 9.5.xx
So you need to be using V9.1 or V9.5 Intel ME System Tools for all these apps

Thanks for your response and your help proposal!

Unfortunately, there is no service/FDO pin. I have ordered a programmer and test clip. I came back when I have a dump of the bios.

You’re welcome @filovitch - When programmer arrives then we can fix this!

I have received the programmer. I am trying to backup the bios but have some interrogation.

There is 2 chips on this laptop wich can be the bios chip.
Position U365 → W25Q128FVSQ
Position U366 → W25Q16DVSIG

I think the bios is in U365. I use this guide and the v1.29 programmer as the W25Q128FV is not in the v1.18. But everytime I read this chip, I have different values. Here is 3 dumps of this chip taken in a row witouth touching anything. The 1 and 3 dump can be read by ME Analyzer (you will find the screenshot below). The 2nd one make it crash.

If i try the W25Q16DVSIG chip, I have constant reading.




EDIT: I have tried other programmer and I have the same problem. The W25Q128FVSQ is not correctly detected, I need to set it up manually. The W25Q16DVSIG is automatically recognized

@filovitch - For W25Q128FV or W25Q128BV, use ASProgrammer 1.4

What is the backup1-3? All those files differ, is that ones you tried to dump from W25Q128? If yes, OK, that explains that
Dump again with program above, it works properly for W25Q128, none of the CH341A software do (even 1.3 or 1.34)

unfortunately, I already have tried this program (and all of the programm you post on another topic) with no more luck. I also have tried flashrom on Linux. Same result: works perfectly for the W25Q16 but not for the W25Q128.

Do you have another idea?

@filovitch - I have those exact chips, and have tested W25Q128FV directly several times with ASProgrammer, are you sure you have it connected correctly, and are choosing the correct options before executing actions in ASProgrammer?
Make sure SPI mode is set, and SPI 25xx selected in the SPI command dropout under stop sign, then go to IC, then SPI, then find your chip, then select it’s ID.

I found something strange during my test. When i set the clip on the chip, the first read seems to be correct. Even the chip auto detection find the right chip. But on the second read, I only have zero and the chip cannot be found by the auto detection. So, I have set the clip, read the chip, remove the clip, reset the clip, verify IC and it is correct.

You can find the dump and a screenshot of ME Analyser on this url: https://1drv.ms/f/s!AnC1kYQSO_T6gdA7SAccF0w6eFJpsw

Do you think the dump is correct? Do you think there migh be problem when I will write the chip? Are these ME Analyser’s alerts a problem?

Thanks again for your help

Interesting quirk with the program!? Maybe close program and reopen would be better, if it worked, instead of remove clip. That, or disconnect USB side of programmer and then reconnect, that way you aren’t stressing the BIOS legs by keeping adding/removing the clip.

Wow, that is really messed up BIOS, did you make multiple dumps and all match same as this one in hex editor? If not, please take a few more dumps so we can compare before we do anything, and put them in zip or 7zip package please.

Are you sure your BIOS chip is not N25Q128A (Micron)? I downloaded a few dumps to compare with yours, and two of them are named this. If you are unsure, or can’t see it on the chip, try choosing that in ASProgrammer and see if it makes any difference.