HP Elitebook 8440p BIOS / Help :


I am a user of the CH341A programmer with ME_Cleaner for which I have successfully cleaned so far…

I received a HP in my hands for which I had to use the Mazzif Tool successfully…

So far the system works perfectly and its use is no longer locked,

So I successfully undertake an extraction of the BIOS with AsProgrammer

Things go wrong when I leave or I decide to patch with ME_Cleaner I get an error:"checking the FTPR RSA signature…INVALID !"

I dedicate to do a second extraction again the CRC of dump is different and in addition I have the same error ("checking…)

I tested an extraction with “CH341A programmer” the chip is detected but the reading impossible…well

…I decide to stop there and reassemble the machine and start :

Incredible but true I have an alert that the CRC of BIOS is not correct at start-up !

As a reminder I’m just reading the chip, and as far as I know, nothing else.

Actually the pc doesn’t boot any further, BUT I can access the bios and I can still change the settings.

I tried a factory reset, nothing to do : despite a reinitiliasitation all diagnostics ok no more boot possible in usb, on hard disk nothing !

The system is in a bastard state as you will have understood it works but is unusable.

If anyone has an idea, it will be welcome, thank !

Some news about it :

The idea is to start over on a blank basis with this computer.

I found another BIOS with which I was able to restore the system (spi flash).

Now I can boot on USB…

Was able to regenerate the UUID and co with DMI Tools…

But the startup screen displays persist in red : ’ WARNING!! - Machine is not in committed state! ’ but the AMTOOLS (brand.bat) is inoperable (errors…) for fix it !

and the flash descriptor is locked (ftp -d bios.bin = nok)

Unlocked the flash descriptor is maybe possible, if someone goes through there…

@Kjose - You should restored with your own backup BIOS before you wrote anything to BIOS. Since you have programmer, you can unlock the FD easily (Section B, see second spoiler images) >> [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
While you do that, follow this guide to fix your ME region and stop using ME clean tools, do it yourself so it’s correct >> [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Thank you @Lost_N_BIOS for your reply, but things have… My positive feedback (and deadly end ?)

On this model it was possible for me to unlock the Intel Flash Descriptor by pressing with holding power + Windows and LeftArrow and Right Arrow (first release bin) :

-When the Intel Flash Decriptor is disabled, the boot screen displays “Asserted Hard GPIO-33”.

-Mestate tool indicates in (section) ModeOfOperation : Unsecured mode by H/W Jumper

When the Intel Flash Descriptor is disabled it is possible to use AMTOOL Brand.bat (Vpro) and delete the commited state on the screen of boot.

The Intel Flash Descriptor is not useful with DMI Tools.

Well, however with the origine bios that took a shotgun with the Mazzif tool it was not possible to modify the data or reset give them DMI Tools/AMTool (no memorization by the system) : I was forced to use a different but original raw BIOS…

EEUPDATE Tool allows you to retrieve the Intel GbE card…

About me_cleaner :

The firmware modify with me_cleaner -S (HALP me Disable + strip) ended on 3 shutdown and reboot successive then then an abnormally long boot time, I specify that this occurs at the moment when the power supply cable is plugged back into the device and as long as it is not disconnected the x3 reboot shutdown does not occur but the boot remains long, I had to try with the command me_cleaner -s but here we go :

About deadly end :

I don’t know if the game definitely stops here because it is related to a lack of luck and therefore to a defective element in the material level or cyber-protection but:

In order to perform many tests I have installed the latest firmware dated November 10, 2014 F.60 (sp73930.exe) W64 machine without problem, to extract it via spi patch it with the me_cleaner -s tool then reflash it to spi flash but here is the boot is impossible :

-the battery LED alternates an orange/blue blinking, the system no longer boots.

The installation of an old bios via spi allows the boot but the screen glitters as if the graphics card was dead and not of possible boot (it reminds me of the exploitation of efuse technology…)

-Either I fried something ?
-The F60 firmware makes a significant change to an embedded controller ?


In short, the PC is inoperate and I’m I haven’t find for a solution yet and I don’t know if I have reached the limits of the flash spi.