HP Elitebook 8470p Corrupt ME firmware

I recently replaced the motherboard in my 8470p with a used one from ebay, and it seems like the ME firmware is corrupt. It actually looks like they’ve re-soldered a new bios chip on this board, as the chip is a bit crooked (a Winbond 25Q128BVFG).

The ME device doesn’t show up in Windows device manager or lspci, so the ME firmware updater from HP doesn’t work. Ctrl-P does nothing at boot. The flash descriptor override key combo (Win Left Right) at boot doesn’t work on this machine - power lights blink for a split second and the machine powers off (the same key combo does work on my girlfriends Probook 6460b). Has the key combo has changed for the 7-series?

Anyway, I’m unable to use FPT to dump the full contents of the flash chip or flash any replacement. I’ve got a dump of the bios and flash descriptor, but of course the descriptor is read only. I’d love to try the hda pinmod, but this board has a different audio chip than the examples I’ve seen (IDT 92HD80B1X5), which I can’t seem to find a datasheet for.

What are my options at this point? I could try and return the motherboard, but it was half the price of any other. I don’t have a Raspberry Pi to use for flashing, but I do have an Arduino Uno and a Teensy kicking around here if one of those could be used. I don’t mind soldering on this board if necessary, but I’m not very programmer-centric (did a little C in school, but that was way back). I could try and remove the bios chip from the old motherboard and put it on this one, but I don’t know if that’d cause any problems, especially since that board has ATI graphics and the new one has Intel. I can pick up a busted 8470p tomorrow that might help me a bit, but I dunno.

So I ended up swapping the bios chip from the old motherboard to the new one, and the MEI still doesn’t show up, where I know it worked in the old board. Same bios version each time. I’m really at a loss for what to do at this point. Since I’ve swapped with a known good chip, is there any point in getting an SPI flasher going?

Incidentally I did end up grabbing the broken 8470p on Sunday, and now that I’ve replaced the SATA connector on it’s motherboard it works great.

When it comes to HP laptops with 5MB firmware, you need to dump the full SPI image (which includes the ME region), follow the cleanup guide on your dump, flash with programmer or FPT/flashrom (if the Flash Descriptor is unlocked for the latter) and then provision both the HP BIOS (DMI info, serial numbers etc) and the ME region (vPro enabled etc) which are both performed by HP tools. I suggest you read these threads [a,b]. Note that at the latter thread, the second to last post has a clean/configured/updated 8470p ME region if you don’t want to follow the cleanup guide yourself, in which case you can replace it at your own dump via UEFITool or manually before flashing back and provisioning the HP BIOS & ME.