Hp envy 17 j122na sata driver


I am trying to install XP home x86 on a HDD on my HP laptop, I have downloaded the ‘Universal 32 bit Intel RST AHCI & RAID modded driver’ and had to change some of the ‘txtsetup.oem’ file to get anything to be displayed when I hit f6 and then S.

I also removed the un-needed drivers from the file as I was not sure which one to use, I left the 7 files for the ‘8 series/ICH8 chipset’ in.

I selected the chipset after hitting f6 names “Intel(R) 8 Series Chipset Family Mobile SATA AHCI Controller DEV_8C03” this is the correct one for my computer.

It did not BSOD this time - however when I get to where the setup says ‘press enter to set up windows now or press R to repair windows’, the system freezes for a few seconds then shuts down.

I don’t know what else to do now. the HDD is in slot 2 of the two slots on the laptop however I don’t want to open up the laptop, I have an SSD in slot 1 running windows 10.

@ snipe:
Welcome at Win-RAID Forum!

Please attach the zipped driverpack you have modified and used.

Maybe it would have been better to follow >this< guide instead of simply loading the textmode driver via F6.

Dieter (alias Fernando)


I skimmed through the guide earlier however
I do not have the option to change the mode to IDE/SATA/AHCI in my bios
I’m skeptical about using CD’s as Iv’e had loads of problems with them as well as USB installation of windows. It is windows 10’s fault
I dont know if the drive is connected to the main board and don’t want to take it apart as I’m not experienced enough to, the laptop was gifted to me

Here is the file I modified:


just click the download button on the page.

That doesn’t matter, because you obviously were able to verify from within Win10, that the on-board Intel SATA Controller is running in AHCI mode.

The integration of the driver is safer than the F6 procedure.
Furthermore it gives you the opportunity to hit F5 or F7, when you are prompted to hit F6.
The ACPI compatibility seems to be the biggest problem for users, who want to install XP onto an Intel 8- or 9-Series Chipset system.

If you boot into Win10 and run the Disk Management, you can see all drives, which are connected to the mainboard.

Thanks for the upload. Although I cannot really see any advantage you got by deleting a lot of HardwareIDs from the TXTSETUP.OEM file, I am wondering, why you didn’t delete the ICH8R/ICH8/ICH8M entries as well.

Ok it must be connected to the main board so all I have to do is insert a DVD, run Nlite, select the windows ISO file, select the DVD, import the driver file using nlite and burn to the DVD ?

@ snipe:
>Here< is the guide about how to integrate the universally modded 32bit Intel AHCI driver v11.2.0.1006 into a Windows XP image.
When you are ready and booting off the XP media (CD or USB Flash Drive), don’t forget to hit F5 or F7, when prompted to hit F6, and choose the best matching ACPI setting.

I mounted the ISO to a virtual drive and copied the contents to the desktop I then pointed nlite to the 1386 folder , I selected to load single driver and to make a bootable ISO, I selected the driver that I need (PCI\VEN_8086&DEV_8C03) out of the list that came up, I then made the ISO file and saved it to the desktop, I then burned it to a blank DVD, all using nlite , at x6 speed and checking ‘verify’

I selected the type of PC by hitting F5 in the windows setup however a second later I get:


I hit enter to continue but then the system shuts down again.

Which driver did you integrate? I suspect, that you took the driver with the TXTSETUP.OEM, which has been modified by yourself. You had deleted all RAID entries and a lot of AHCI ones, but now the "Default" SCSI file for the RAID part "iaStor_Express_M" is missing within the TXTSETUP.OEM.
Here is the related excerpt from your modded TXTSETUP.OEM file:

faulty txtsetupoem file.png

Hi, I used the driver I didn’t modify and the error went away, however after it says ‘setup is starting windows’ I get a blank blue screen that stays for around 6 seconds then the computer shuts off again…

Ok, this verifies my speculation regarding the reason of the error message.

You should try another ACPI setting option via F5/F7.

Ok I got it to work by selecting the compaq systempro option in f5/f7 however when I tell it to install on disk1 it says the disk does not contain a compatible windows XP partition, in disk management it lists one partition and its NTFS I did install debian before onto disk1 but I used diskpart clean and the format utility on the disk.

I initialized it and selected ‘MBR’ in diskmgmt too and ran bootrec /fixmbr and /fixboot.

So you got XP installed at least?

No, this error appears when you have to select the disk in windows setup

Which error?
Has the disk drive, which was running in AHCI mode, been detected by the XP Setup?
Why haven’t you cleaned the disk drive before starting the XP installation?

I did delete the partition before installing, it was formatted

The error is:

To install Windows XP on the partition you selected, Setup must write some startup files to the following disk:


However, this disk does not contain a Windows XP-compatible partition.

To continue installing Windows XP, return to the partition selection screen and create a Windows XP-compatible partition on the disk above. If there is no free space on the disk, delete an existing partition, and then create a new one.

@ snipe:
This indicates, that the XP installation onto the second drive of your system would have been successful, if the current boot drive would allow the required entries for a dual-boot system.
I suspect, that you had installed Windows 10 in UEFI mode, with the consequence, that the EFI boot sector was not able to support Windows XP.
If I am right, you have to do a fresh install of Win10 in LEGACY mode (creating a Master Boot Record) onto the first disk drive as first step before you are going to restart the XP installation onto the other drive.

Oh god
I’ve got loads of documents in windows 10

It should not be a problem to save the documents on an USB Flash Drive.
Another possibility would be to open your laptop, to unplug the Win10 drive, to install XP onto the second drive in LEGACY mode and at least to reconnect the Win10 drive.
This way you would have an UEFI boot sector on the Win10 drive and an MBR boot sector on the second drive.

ill try removing it then


I got XP installed fine, thanks a lot for the driver, another issue though is even from the Bios menu I cannot seem to find anything that boots into XP, it always defaults to either the CD drive or windows 10
Any ideas?