HP G6 2000 CPU Upgrade - ME Patching

I have problem with laptop HP G6-2323ew it won’t boot with new processor. Laptop turns on fan and stuck.
I already inserted to BIOS clean ME region (1.5MB v8).
BIOS after inserting clean ME won’t booting i7-3630QM but booting normally i3-3120M.
1. Is there any possibility to set reserved bit to No in Flash Image Tool?
2. Only one difference between CPUs is the i7 has 45W TDP, and i3 has 35W. Is it maybe problem?

Retail stepping of i3 (L1) is different than retail stepping of i7 (E1), so you may need updated microcodes (2012 version in BIOS 77532/ F.27 now)

1. Yes, that is possible, but I do not think it’s necessary here, nor applies, nor would be helpful
2. See my thoughts above, it could be ME related, but I’m leaning towards microcode needs updated.

I checked your BIOS settings, and there is non hidden limiting TDP allowed, that I can see.

Where is there repository of microcodes, and which microcode i should insert?
I found that cpuid and other parameters are identical (as you mentioned only difference is stepping).

i3 http://www.cpu-world.com/sspec/SR/SR0TX.html
i7 http://www.cpu-world.com/CPUs/Core_i7/In…0processor.html

Is there any program to insert microcodes for Insyde H2O?
Is it possible to insert by phonextool?

I flashed F.27 bios.

I have 2 microcodes for 306A9 (maybe for i5 and i3, and for i7 is missing).


I don’t know answer to your questions about insert microcode for H2O or phoenixtool, possibly, but only way I can say for sure is if I try to mod the BIOS for you.

Microcode repository is here, I have linked for you a few times now I think - https://github.com/platomav/CPUMicrocodes/tree/master/Intel

Is your CPU ES/QC (Confidential, engineer sample, ect?) Look on CPU Cover if you are unsure, which stepping do you see QCF5 or SR0UX

Do you want me to update this BIOS for you? I can update all microcodes, and put in new clean updated Intel ME.

Do you have flash programmer?

My CPU is SR0MJ. This is retali CPU.

If you can you can try to update BIOS, because when i try to insert new microcode with Hex Editor that the file is bigger than chip size (4MB)…

I’ll tried this method:

Yes I have a flash programmer.
In attachment dump of BIOS from CH341A programmer (newest BIOS F.27).

f27.zip (2.83 MB)

OK, will do tonight, thanks for the dump and it’s good you have programmer so we have nothing to worry about!

@cooltronic - here is updated and fixed dump, change log in zip


Right click download button, save as, or right click download button and open in new tab. This site has ads/pop-ups and often confuses people, no credit card or join any site needed, straight download file only.

I flashed this BIOS (M33) and it won’t run i3 or i7.

I tried with 2 CPUs without cooling and CPU are working because both are hot (without cooling).
Fan is working with i3 or i7, but BIOS is stucking in early stage (no dispaly on VGA port or bulit-in display).

I checked difference between F27.bin and F27M33.bin bios files in MEAnalyzer (in attachment)…
In F27 FOVD nad MDES partition aren’t empty. In F27M33 these partitions are empty.

BIOS recovery procedure only running on i3.

I think the i7 CPU may be broken… I don’t know maybe bent pins or another problem.

I checked motherboard with cooling on i7 on M33 bios, the transistors around CPU are heating (not too much).
I think the main problem is the power consumption of i7… The motherboard can’t turn on the system on higher TDP processor.

I found other HP G6 2000 with i7 3630QM CPU but it has main board with 2GB DDR3 in AMD GPU (my has 1GB with the same GPU, and the bios is identical ie F27).
On second attachment in the left i3 and on right not working i7…
Can slightly bent pins of the processor stop BIOS startup?




What are those partitions you mentioned, is it ME related? Have you cleared CMOS?
For new ME, always try to drain power completely for 1= Minute too (Remove main and CMOS batter, remove power brick from connecting to laptop or PSU from wall, press and hold power on for 10+ seconds, then wait 1+ minute before putting it all back together

I cannot tell from images if any bent pins, you should be able to see in person, look down pin rows from each side and from many angles, you’ll see it any. Really, if any are bent bad enough it wont fit into socket anyway, so main thing to look for is broken/missing pin as long as it’s currently fitting into socket.
Slightly bent pin will be OK, since once it goes into hole socket will connect to it when lockdown switch is closed.

Could be TDP issue, could be some lockout CPU list in BIOS, or could be those partitions you mentioned, not sure what that is?

On that other system BIOS, did you compare the actual BIOS rom/bin etc (Not exe) in hex and see if it’s exactly the same?
If it is exact same, then stock BIOS should work on your system with that CPU, unless CPU is faulty. Unless maybe motherboards different in some small way, extra resistor here or there, removed resistor here or there etc.

They are the ME firmware partitions (MEA -dfpt). The FOVD and MDES are temporary/initialization partitions so they get cleaned when the CleanUp Guide is followed. It is thus normal for them to not exist at the new image.

Great, thank you for that info plutomaniac! I tried to find in google before looking silly, but no luck so there I was…

The model with i7 (45W, but i found it was other model of i7 in specification) has F.27 rev A BIOS (identical like mine, the same exe file).

On this motherboard there are two BIOS chips one MAIN (I already send to you dump), and second chip with EC. Is the EC chip is needed to be flashed?

Send me other "Identical EXE" file and I will check to see if BIOS same or not. EC may need to be flashed, EC usually is fan control and stuff like that though.

There were 2 models of G6 with i7 45W TDP:
g6-2321ss (only with Intel GPU)
Bios link:
g6-2236TX (with AMD discreete but motherboard is different with 2GB of VRAM)
Bios link:

Third is on listing on auction portal with my motherboard and only I know it is g6 with i7 3630QM (with 1GB VRAM 7670 AMD).

I’m trying to read EC bios chip, I’ll post dump to you when I finish.
I’m sorry there was small differnce in specifitation of i7… I’ll try to install Core i7-3820QM http://www.cpu-world.com/sspec/SR/SR0MJ.html

Same CPUID on that CPU should be OK. On EC, you’ll know as much as I do, open with hex or notepad, that is all I can do with EC FW, browse through it and look at what it appears to be related to. Sometimes second BIOS chip on HP is partial of the main, meant for recovery purposes.
Those systems may have totally different motherboards, chipsets etc, you’d have to have them in hand and running to check all that to compare. I checked BIOS inside, they are identical, but your BIOS contains a second almost same size and name image as main BIOS bin file, but it’s not referenced in the flash bat file so not sure how/when/if it’s used.
Both links above take me to HP Pavilion g6-2321ss download page only, even if I open the second in another browser

306A9 CPUID is in BIOS by default, so there is either some block/allow list, or some other modification is needed for your specific CPU. I doubt TDP is locked to certain amount, but I guess that is possible, you can edit the TDP values in BIOS settings that’s why I doubt it’s locked to certain TDP only.

I believe the problem is RSA checking (Signature at startup), mod BIOS cannot be used with certain HP systems, only ones with SP5xxx or SP6xxx exe files. See discussions below

I flashed your modded bios and on i3 bios recovery runs.
On i7 bios recovery not starting.

I’ll try to flash F.25 BIOS (last without RSA), and I’ll try to set ME disable bit by ME cleaner script.

But the BIOS with ver. F.26 or F.27 runs smoothly with me cleaner with -s option (but only on i3)…
I think RSA checks only validity of description region.

I’ll try to flash F.25 BIOS without RSA, but my CPU is higher model than i7 used in this board (same TDP).

But info from HP site gives info that CPU (i7-3820QM) was used only in HP EliteBook 8770w (it has another BIOS with 5MB ME region).

I flashed bios with MeAltDisable (by me_cleaner without any -s and -S, the full me cleaning) results:
i3 working normally, boots system (MEInfo not working on Windows)
i7 not working, stucking in early BIOS stage, powering on USB

I think this CPU is too strong to this board… And this problem isn’t ME related

If it only checks FD, that is lame application of the product, but I guess it could be that limited. Put FD back to original in my edited files then, this is easy edit at line 60 in hex on full file.

5MB ME is not required for the CPU, so that’s not the reason they would use the 5MB ME, but it could be related There could be some TDP limit/lock in there, but I bet some kind of CPU allow/disallow list
Often CPU compatibility has to do with ME and microcodes, that’s why I started there, but this is not always the only things. The BIOS you linked above have microcode we have not tried yet, we could try those next instead (leaving ME as it is)

What should I do?
ME is disabled (MeAltDisable bit), I think there were not ME problem.
How to check CPU blacklist by BIOS?
I can’t find any info on Google :wink:
I read donovan6000 blog many years ago and I have IDA Pro, i cracked oldest BIOS Advanced TAB, but I don’t know what should I search, and in which module :wink:

There was first BIOS without RSA signing for my laptop:

Microcodes were updated and on your BIOS with i7 recovery procedure not starting, starts only with i3.
I think it may be to strong CPU.

I figured there was difference of cache size between i7-3610QM (6MB). It works with G6 2323sw, I saw that in auction portal archive listing, originally this model has i3 like mine.
The cache of i7-3820QM is 8MB.
Do you think it may be source of incompatibility?

CPU is not too strong, it’s just locked out, either by CPU allow/disallow list or some other list like that in BIOS, or by a TDP lock limit. Don’t disable ME, it will be required and may need to be a certain version as mentioned
the only thing I can think of left to try is the other microcodes as I mentioned.

I can make two BIOS from your link above on non-RSA signed BIOS. One w/ latest microcode and other with ones from BIOS on post #13, leaving ME as it is or update to 8.1 at least (No need to disable)
But the link does not work, so please relink that file, or download it and send me the exe

No, I don’t think cache matters. In this case, I believe only ME and microcode matter, if there is not a lock list of CPU’s by name/series, or a TDP lock.

I see a CPU “Energy Read” Setting in BIOS enabled, in thermal config page, maybe disable this would help. You may need to flash mod BIOS with Advanced menu enabled, it’s set standard now but full access, may need advanced + Full
I also see all these settings for TDP


The CPU has broken iGPU… It runs perfectly on motherboard which won’t run iGPU (HP 8470p with AMD discrete). I’m waiting for board in good price and I will attach image after buying of MB in good price :wink: