HP MicroTower 400 G2 BIOS - Protected Range Registers - Any Help Appreciated

Hi all,

First off - I’m completely new to this so apologise for any faux pas.

I’d like to unlock some additional settings in my HP PC’s BIOS. I want to be able to set specific memory frequencies/ CAS latency etc. Some CPU setting control would be nice too; but is not essential.

I thought I’d give this a go myself, but I am completely stuck.

So far I have managed to dump the BIOS (I think), but I cannot flash it back using FPT.

Steps so far:
1. I have used Intel Flash Programmer Tool v9.1 r7 to dump the bios, this was successful.


I then tried to flash this back and it didn’t work, stating the BIOS was protected.

2. I have tried to identify the BIOS Lock variable using a combination of UEFI Tool to search for ‘Bios Lock’, IFR Extractor and the Grub method to set the value to 0x0; I don’t think this worked. Please see below:


IFR Extractor.png

3. I then tried to flash the same BIOS back and obtain the following error about Protected Range Registers. I have tried to read up this, but it seems there are many methods to remove this which vary BIOS to BIOS/system to system.
I have also tried this using FREEDOS to boot and flash using FPT.exe - I get the same error - I dont have a screenshot of this.

The main question I have is how to remote the Protected Range Register(s), is this even possible with this mobo/BIOS? - Does anyone know?

4. FYI - I have had a look in AMIBCP and the options I want to unlock seem to be there.


Any help is much appreciated. I am happy to forward information.