HP Pavilion 11-E10SG shuts down during XP installation

Hello there.

I really didn’t want to do this, but I’m at my wit’s end.
I really want Windows XP on my HP Pavilion netbook… partly because of nostalgia and also because the netbook’s performance is really terrible.

It came with Windows 8.0 pre-installed and it was such a slog that I couldn’t even update to Windows 8.1.
So far, I was successfully able to install Windows 7 (both 32 and 64 bit) and Windows 10 with no issues.

I tried everything to get Windows XP on it… tried to install it using Easy2Boot, tried to install it using Fernando’s guide to integrate AMD’s AHCI/RAID Drivers, tried to put the installation files on the hard drive on a different partition… everything has failed, and I am starting to believe that this is a hardware issue.

I am able to get into the “experience a new look”-part of the Windows installation. After that, the netbook reboots and it starts with the “Press F6 to load drivers etc.”-screen. Then it goes to the “Setup is starting Windows”-screen. Then I see this screen for 2 seconds:

P1020035.JPG



Then it shuts down. Every single time. At this exact spot. It’s not even a blue-screen. It just… shuts down. As if I pressed the power off-button. Except I didn’t. It shuts down by itself. It’s a regular shutdown as well, I can hear the slight clicking noise of the hard drive, which is the cue for it to shut down. It’s like a regular shutdown. And all I want to know is: WHY! I tried four different ISO’s of Windows XP (one is untouched). They all have the same issue, and they all shut down at this spot.

I could also choose if I want to choose a partition during the installation (from that “experience a new look”-part of the installation from earlier). Enabling that allows me to choose a partition, but here it also shuts down after like 2 seconds. It’s always at that spot where my netbook performs a regular shutdown.

Any help is appreciated. Maybe it’s simply impossible to install Windows XP on this hardware…

@IWantWindowsXPOnMyNe

I think, that this is a problem with the AHCI driver.
Can you write the exact model, grafik and cpu of your HP Pavilion netbook.
Have you tried the XP from Ramsey

https://www.zone94.com/

Dietmar

@IWantWindowsXPOnMyNe

It’s very strange that it would shutdown at that point in setup, are you able to press ENTER to continue setup?

@diderius6

Perhaps this is an ACPI issue? maybe the ACPI table programmer told the system to shutdown if XP is the OS reported?
I’ve never heard of that being done before though.

@IWantWindowsXPOnMyNe Have you tried XP2ESD? Here is some testing ISO

Create bootable USB using Rufus and install. This should work

1
 
https://www.mediafire.com/file/rbkvc10beuil34p/WinXP_AIO_ESD_v1.6_b5_w8_based.iso/file
 


I can build another testing ISO in any language from my still unreleased XP2ESD v1.6 in +-12 hours.

@George_King

I am happy, when you can make an XP SP3 , German version.
This I would test intensive
Dietmar

@diderius6
Oh sorry, yeah, should have posted the information from the beginning…

AMD Dual-Core A4-1250 APU (with Radeon HD 8210 graphics card, 1 GHz, 1 MB Cache)
4GB DDR3L RAM
500GB Hard Drive

Screenshot of the BIOS if anyone’s interested:

P1020037.JPG


BIOS is set to LEGACY. No “advanced” configuration available though.

@George_King
Thanks, I’ll try that out!

EDIT:
@infuscomus
Sorry, I forgot about your reply… yes, I can move the cursor with the arrow keys, but hitting ENTER does nothing.

@IWantWindowsXPOnMyNe

Try an external keyboard maybe? does that accept input?

@George_King
I have installed Windows XP with your ISO, but when I choose it, I just get a black screen. :frowning:
The netbook is still running in this state and the lights are still on, but nothing happens.

EDIT:
Starting it in Safe Mode gets me this screen and it also gets stuck:

P1020039.JPG

So you saw this screen with bootoptions?



And what was your choice?

@George_King
Yup, when I boot the netbook now, it shows me these boot options.
And… well… my choice was Windows XP… I guess this wasn’t correct?

@IWantWindowsXPOnMyNe Yes, you should keep it as is without touch. But we use Longhorn beta NTLDR to choose correct HAL and Kernel. But it should fail of course as it’s from abadonded beta before development reset. Have you tried another options? Most modern PCs should work good with option 4. as this means to install halmacpi.dll and ntkrnlmp.exe to boot

@George_King
Choosing Windows XP, Standard PC or ACPI PC gives me a black screen.
ACPI Uniprocessor / Uniprocessor with MPS gives me a message that hal.dll is missing or corrupt.
ACPI Multiprocessor / Multiprocessor with MPS gives me a message that ntoskrnl.exe is missing or corrupt.

Btw. I installed your ISO on a different partition; there was one with Windows 7 on it. Could this cause these issues?

@IWantWindowsXPOnMyNe These messages can appear as booting failed and incorrect HAL and Kernel are installed, this can be a problem please try to install it again and choose option 4 before it fails. I recommend to install it on clean HDD on first partition and before any other OS. This is only known limitation I know

@George_King
Thanks, I have now removed all partitions during the XP installation and now chose option 4.
Then I could finally see that Windows XP startup screen!! I was ready to celebrate, but…

now I have a black screen again :frowning:
And it seems that the internal fan has stopped spinning. Should I reboot and try another option again?

EDIT: As suspected, the entire netbook was unresponsive and I could not restart using the power button. Holding down the power button to cut off the electricity did the trick though. Hm, not a good sign…

@IWantWindowsXPOnMyNe I’m building another image right now - based on Windows 8.0 installer with English XP SP3+, really similar that I builded for @diderius6 to test posted here. But drivers set is minimized to Generic AHCI, NVMe, USB3.x and UASP. And patched ACPI.sys is included. Image should be uploaded in ± 45min.

We can try more builds to achieve it - add different MassStorage / USB drivers and try different patched ACPI.sys versions. I need to finish XP2ESD v1.6 so you can build your own images on your side :slight_smile:

@George_King
Thank you so much for your effort! :smiley:

I am successfully able to boot into safe mode, but now it’s stuck on that “an exciting new look”-screen. It says “Wait end Plug and Play” and the “please wait…”-bar keeps cycling over and over. It sounds as if the hard drive is working, but no idea if anything will come out of it…

EDIT: I’m in safe mode now (black desktop) and it was updating drivers or something. Now Windows is performing a normal shutdown…
now after reboot, it says that hal.dll is missing or corrupt. The different boot options do not appear anymore. Aww… :frowning:

Update: The same issue happens with the ISO you provided for @diderius6 … Netbook becomes unresponsive during boot using option 4, but is able to get into Windows by using safe mode. Then it automatically updates drivers and performs a restart and upon next start Windows reports that hal.dll is missing or corrupted. :frowning:

Sorry for this double post, but I have finally managed to install Windows XP! I used Win2Boot with the Win7 WINPE installer. It copied the files over to the hard drive. During the F6 prompt I pressed F7 and for some reason my netbook DIDN’T crash and it continue setup! Hooray! I am pretty certain that I did this trick before and that it didn’t work before…

However, actually getting Windows XP to understand this netbook’s hardware is a whole different thing. I was able to install Audio Devices, Bluetooth, WiFi and LAN without any problems, but I struggled to get the AMD Chipset Drivers (the most important thing!) installed. The crappy AMD Catalyst software would always hang at “detecting graphics hardware” and the installation would be aborted. I added most drivers myself, by going into the Device Manager and loading the drivers that got extracted from the AMD installation file (C:/AMD).

This system is far from perfect though. I noticed that I can copy files over from USB sticks just fine, but putting files on them doesn’t work on any ports. Like, it shows the file got copied to the stick but when I disconnect the stick and connect it to another computer, the files that I supposedly successfully copied over are just gone!! So something is definitely wrong with the drivers that manage USB devices?

I also have an unknown device that is listed as a “Standard floppy disk controller” (ROOT*PNP0700\1_0_13_0_0_0). My guess is that this is the device that tells my netbook that there’s a battery. And right now, Windows thinks it’s on a desktop. Any advice on how to get a driver for this installed? Oddly enough, I cannot use Standby and I have to turn the netbook off manually (“It is now safe to turn off your computer”).

Another problem that I have: Windows uses a pagefile instead of RAM. I disabled the pagefile but Windows just ignores me and still uses the pagefile instead of RAM. I think 2.98GB (4 in total, but Windows XP 32 bit doesn’t recognize the full amount) of RAM should be plenty enough… or does Windows not even recognize that there’s RAM?

Here’s two screenshots that I made on my netbook. I had to upload these on an image hosting service and download these on my PC since copying stuff to USB devices apparently doesn’t work.

mapc5nkg9.png


floppyeakon.png



Thank you so much for your help so far! I’d really appreciate it if you’d help me out just a little further! :slight_smile: