HP Probook 640 G2 - Bios or ME failure and Recovery

OK nevermind, easier to find the connector for CMOS battery. Going to flash now and see what happens.

No flashing, use programmer, unless that’s what you meant If you’re not using FPTw, remove all power (Both batteries, and power block from wall, press and hold the power on button for 10-15 seconds, then let it sit powerless for 1+ minute, after you program in the new BIOS)

FPTw needs to be ran from command prompt, not power shell.

ok i unplugged the cmos battery but FORGOT to discharge by holding power…I’ll repeat that part of the process but at present running pcmark and watching temps now. fan speed not readable by any applications I’ve tried. i’ve got hwmon logging so we will see if it gets into danger zone but so far, no change in fan speed. I appreciate your work man, and I hate to have you do more. if you think there is a chance of resolving it though, please do OR let me know what to do and I will do it.

Please do as mentioned with the power drain (No CMOS, no main battery, no wall box or cable etc and press/hold power button for 10+ seconds then wait 1+ minute with no power at all), or FPTw -greset, one or the other, this will reset ME State. Without that done, this does not happen, so we can’t rule that out as the issue with the fans.
If after that still no changes, then we will have to find working dump, I’ll look for this time. You aren’t missing Fan setting in BIOS are you, set to something new now due to defaults, where you had set different before?

OK, full run of pcmark, temps rose to 84C. max for this CPU is 100 BUT of course we would expect some fan adjustment along the way and I don’t hear any. what do you think is best next move? Oh I still need to completely clear BIOS, I’ll report back in a bit.

OK I found a utility to both monitor and control fan speed on this laptop and…it is modulating fan speed, just nowhere near as dramatically as before. I truly appreciate your help LiB. If you need anything in the world in which I work in please let me know, I owe you.


Yes, I would expect fans to kick in at 45-55 higher than idle, and again near max at 70c at least. I will look at BIOS, sometimes they change fan profiles between BIOS versions, maybe that is what happened this time, or fan/BIOS bug.
I checked ME and didn’t notice anything fan related, so provided ME is working (Can get meinfowin), I don’t think it’s the issue anymore.

As a test, will it let you flash back to previous version, don’t program just flash (Because if you program it wont have ME and will overwrite current ME with blank)
Platform.ini may need edited, from the extracted exe file before it will let you back flash. If you try to do that as test, also edit the batch file to remove ME flashing, same for INI set to not flash ME.
If you can’t get that figured out, we’ll do it as a last resort test, I’ll help you on that once we get there. Tonight I will check BIOS fan settings in this version vs the previous version, do you know previous BIOS version number?

In mean time, no more benchmarking until we can figure out

Do you see this in BIOS - Built In Device Options - Fan Always on while on AC Power (Two settings above Backlight keyboard timeout)

OK I’ll check all that out tomorrow, headed to bed momentarily. Monday approaches…yeah Im’ thinking same. Undocumented fan profile modification (everyone complains about the fan in these and admittedly it did get loud at lower temps before) in latest. While I appreciate the adjustment, I’d appreciate the notification so I know my fan / motherboard isn’t screwed up when it suddenly behaves like a Dell instead of an HP!

Previous BIOS was 1.21 I believe.

Yes, I have this enabled.

Thank you very much again. I learned a lot along the way, and realize how little low level hardware experience my career has included :0 Major components, RAID controllers, backplanes, RACs, motherboard, FC controllers, L2 and L3 switches, fw , SCSI to iSCSI but programming EEPROMs? NADA until now :slight_smile:

That may be only option, using older BIOS I mean, to fix the fan stuff. Especially if this is a “New and improved” fan profile. When you did check the fan speeds, as you benchmarked how often and how much did it adjust as temps rose (Automatically I mean, not if you adjusted manually)
What was fan speed and temp at idle before and after benchmarking did fan speed stay up some until it cooled, then drop back down? If it is going up and down itself, just not as much or as loud as before, that may be due to how they adjusted the fan profiles in this BIOS due to complaints.

Was there a specific reason you updated BIOS? I’m unable to find proper tools to open this BIOS to see the settings I was thinking of, have tools to find a view plenty of other settings, but none are showing anything fan or temp related except that one I mentioned above. Which also means I can’t compare new/old in this regard either :frowning:

There is Intel BIOS experts over at BIOS-mods forum, maybe you could have someone there compare this latest BIOS version vs the old one, and see if the fan profile and settings have changed or not.
And see if they can enable these settings in the BIOS for you, @DeathBringer is a member here, I believe he is the owner of that forum, he will be able to tell you who is the Intel expert there to ask about these fan settings.

If the software does block you from flashing backwards, likely due to ME, I can help you get a working BIOS on older version to put on using your programmer.
Now that you’ve started programming BIOS, one day you will have to start reading and reading so you can modify BIOS too! [smoking]

And, almost forgot! You’re very welcome, sorry I can’t help quickly and easily with this fan thing, some BIOS are much harder to dig into for me and this happens to be one of those types

Hi Badgenes & LOST_N_BIOS,

I have just had a good read through all of your posts regarding the Probook 640 G2 - the reason for this is that i’m in exactly the same situation regarding the exact same laptop (although not sure if mobo version is the same as there are 2)
The reason i came across this is that i have done most things in my power to get this laptop going and still having some issues. I have access and competency with Rpi flashrom, soldering etc but a little less useful when it comes to the software side so i’m coming to you guys for a little help.

The laptop i have was bitlocked which i thought might just be the harddrive, but it looks like that might also add protection on the bios also. Currently the bios is locked to boot only from the HD so i have no OS (bitlocked) however the bios should be intact which i can provide. The problem that i might have is that flashrom might not be able to read the ‘one time memory’ portions of the bios (which i think are currently necessary to boot the device).

Any pointers are very welcomed, here is a list of what i have tried and not tried.

Bought a HP Probook 640 G2, boots and can enter bios (although password protected)
OS is bitlocked and can’t change boot settings to load OS from USB/Optical
Removed the original bios chip (Macronix MX25L12873F)
Read the original bios boot file in case i needed it. (using a raspberry pi & Flashrom).
Then ordered the IC & Bios - the IC arrived was the Winbond W25Q128FV.
Installed this and when pressing the power switch, I got nothing but a blinking orange light.
So i removed the W25Q128FV and tried to read the bios.bin using flashrom but the chip was not recognised.
I dug through the two datasheets and the W25Q128FV supplied has a ‘/HOLD’ on pin7, This must be held high to activate the chip.
Added the additional jumper and i was able to read the bios using flashrom first time.
So i re-installed this into the probook (with a jumper for pin7) and this time the pressing the power switch turns on the laptop (and off) however…
I did not get any display on the screen (backlight comes on), no audible sounds and the fan does start to spin (this winds up to maximum and stays there).
Replaced the original bios without pin 7 and got the same black screen and spinning fan. (so pin 7 looks necessary)
Connected up pin 7 and was able to boot once again (so the original bios boots every time, indicating hardware is all still working etc)

Ordered a new Macronix MX25L12873F to see if i can replicate the same results from the existing bios chips. (I dont want to overwrite the existing MXIC)
I programmed the new MXIC with the original bios i read - and got the black screen & fan spin (so i’m guessing this didn’t read all the data)
I programmed the new MXIC with the bios read from the W25Q128FV and still got the black screen & fan spin (so i’m guessing that this is now a bios issue and no longer a hardware problem)
Finally replaced with the original untouched MXIC, and boots no problem. (I have kept this chip because it seems this is the only one that works and if written to i could loose whatever data is allowing this system to boot.)

When reading the data, the MXIC (both) flashrom reads two chip names and also comes up with a warning about ‘one time programmable’ data which sounds like this might be the issue.
If this section of the chip can’t be programmed, then i might have to use the existing chip i have and test that with a new bios. I’m worried about overwriting information that i might not be able to retrieve again so this is currently a last resort.

I do have the bitlocked HD (again untouched for the same reason) which i can try to recover the bios using ‘Windows key & B’ on start up - to see if this is possible. Then i can try overwriting this IC instead (this is my next step)

Hopefully i have explained all the steps i’ve taken - and i’m sure that you can see they have been methodical and i really would like to try and solve this and hoping that you might be able to help.
If you still have the working Bios from Badgenes would you be able to compare with what i have to see if i have managed to read all the data correctly because doing a straight read and write using flashrom has not worked.
I can still obtain bios info but using the old chip - I have the serial number, SKU, UUID, Asset Number etc.

Please let me know what you think and if i’m at a dead end and need to replace the mobo.

Oh and i also have an SMC.BIN from HP however this didn’t work for me and has pass a week (expiry) If i load an OS onto another harddrive will i be able to change the time to be able to retry this with the new MXIC?

Any comments and suggestions very welcome and thanks for taking the time to rad this if nothing else!


I have now actually solved the issue, but unfortunately i’m not going to be able to give a great answer for how i achieved it - perhaps you might know.

I installed windows using an older laptop and swapped the HDD into the Probook, this booted windows (32 bit). (a success in my eyes, so that i didn’t have to pay the £416 HP wanted for a new mobo).

I needed 64bit installed, but had no other 64bit laptop. Installed 64bit vai a desktop machine, this blue screened after the windows logo (most likely a processor driver compatibility for instance?)

So i cloned the windows install partition on the the HDD, leaving an additional partition for the windows install (upon install got a warning about partitions being in the incorrect order)

Booted the laptop and installed windows (no blue screen). All good up until this point.

This next bit is a little hazy, but after a few reboots? the laptop booted in 'Manufacturing Program Mode’
I’m not sure how or why, it might have been down to a hardware change? But this obviously allowed me to change both the bios password and the boot order.

I must add at this point i have no idea of the relation, but the solder joint to pin 6 which i believe to be the clock on this IC dislodged itself. (this actually prevents the laptop from booting, so i don’t think it had relevance to the PMMode, and when replaced the PMMode was still there)

Manufacturing Program Mode counted down from 30 to 0, and I was also able to install fresh windows from the hp cloud backup service.

So a 100% success, however if i were asked to replicate the process i’m not sure if i could.

Is there a way to enable the Manufacturing Program Mode?


Hi. I recently updated my laptop bios. The system was working fine but suddenly after installing new bios the system booted and it was to laggy ( like I click any of icon or file it opens after 15 minutes). Too laggy and slow.
So I installed a fresh windows 10 pro 64bit after installing it I rebooted it started lagging again. Then I reset my windows it took 15 to 16 minutes but now system is just fine not that fast as it was factory default. I tried to recover bios or Tried downgrading but it’s not working… please help…

Dang this has been a long time sitting. Sorry I admit I only spent much time here working on my issue :confused:

Are you still working with this? Reply and we can discuss if I can help I will.