HP Z240 Tower Workstation - Intel ME / AMT not being detected - Unable to Update FW

Hi folks,
I was hoping you could help me out, I’ve got 2 HP Z240 workstations - after BIOS upgrades I’ve run into issues on 1 of them.
I first noticed the error at POST see image below…


ERROR: SOFT TEMPORARY DISABLE: To enable ME, check Active Management (AMT) option in Setup (F10)

I’ve tried disabling and re-enabling this in the BIOS, as well as re-flashing the BIOS with the same version using the Windows Flash tool and also from a Flash drive using the menu in the BIOS - they seem to complete successfully but don’t make any difference. I also noticed the options available when pressing Escape to access boot menu when I boot up. Here’s an example of the GOOD WORKING SYSTEM below


As you can see in the image below this is from the good working system - however in the problem system it skips options: F4 and F6 (Intel ME)

When I also try to run the HP Firmware update for Intel ME I get the following error:


Here is the option clearly enabled in the BIOS.


So I stumbled across this forum which has great information and tools - one of them I noticed was Intel ME Info - it said if the device was working OK I’d be able to get some information running this tool.
I downloaded Intel ME System Tools v.8 r3 - I took it supported the i7-6700 in the PC and I run the tools from command prompt as administrator

Intel ME System Tools v8 r3\MEInfo\Windows64\MEInfoWin64.exe

It gave me this error:
Error 9460: Unknown or unsupported hardware platform

I tried this command:

Intel ME System Tools v8 r3\MEManuf\Windows64\MEManufWin64.exe

I got this output:

Error 9276: Fail to read FW Status Register Value 0x0

Error 9321: MEManuf Operation Failed


I also then tried a newer version Intel ME System Tools v10 r7 but I got all the same errors as the previous version.

I also noticed there is no entries in my Device Manager in Windows for Intel ME or AMT and all drivers are installed OK. I also run the Driver Pack for my machine and the HP Support Assistant to see if it picked anything up. the UEFI hardware diagnostics don’t seem to pickup on anything either and passes all tests. I’ve tried removing the CMOS battery for 5 minutes and re-inserting - this cleared the time - no difference. I saved the BIOS config from the good working system and restored it on the faulty system, it worked OK but no difference to my Intel ME issue.

The system details are as follows.

HP Z240 Elite Tower Workstation
Intel i7-6700
BIOS: N51 ver. 01.78 — latest available on the HP Support website
Windows 10 64bit (Fresh install)
HP E93839
Atayal rev.1.0

These 2 systems are identical so I can see from the other system what it should look like if working correctly.
Can someone please shed some light on this issue or point me in the direction I should be headed? I was thinking of trying to reflash/force flash the Intel ME platform, should I look into it using the tools in the ME System Tools I downloaded? Please any help would be greatly appreciated. Thank you for taking the time to read my post. If you need any further information or clarity please let me know.

Thanks in advance

Can anyone shed any light on this at all ?

Thank you

you are in wrong side.
update correct version. my z240 work station . ME 11.78.3630

follow the official update Tool HP https://ftp.hp.com/pub/caps-softpaq/cmit/HP_SSM.html
after install check update ME section. and update INTEL MANAGEMENT ENGINE

Hi Sahafdeen, thank you for taking the time to read my post and posting to help, its appreciated!
So I’ve read up on using SSM - do you think this method should force the update of the INTEL ME ? When I’m trying to use the HP Updates from their website listed for this base unit it’s just not detecting it at all so do you think this method should get different results?

Thank you

(i) run as administrator ME update[sp00xxxxx] , <<<<downloaded intel management update in ssm tool.
if not success, Extract with 7zip, and run as admin the setup, share result !

If fail;
download old updates via ssm tool, have option <<<show previous updates.
update correspond version, V9.0 to v10.0 [sp00XXX] , search next update v 11.00 [sp000XXXX}.

Try all, follow instruction (i)…

Thank You - I’ll go give that a try now. Thanks again!

Hi sahafdeen,
So I install SSM and created file store, enabled show progress on client computer and create log file also. I placed the Intel ME Update and ran the update process. It didn’t detect any updates to be installed. Please see log file of the command below:

Log file generated on 04/14/20 04:34:31 PM for DESKTOP-HJCHFGN
• SSM Version: (
• User Name: Qualcom
• Parameters: /TEMP:“C:\Users\User\AppData\Local\Temp\SSM1F4A.tmp” /SSMFS:"\Desktop-hjchfgn\fs"
/SSMPATH:“C:\Windows\system32” \Desktop-hjchfgn\fs /accept
Possible Updates
Updates Performed
Client Information
• System Manufacturer: HP
• System Product: HP Z240 Tower Workstation
• System Version:
• Base Board Manufacturer: HP
• Base Board Product: 802F
• Base Board Version:
• Machine ID: 0x802F
• BIOS Release Date: 10/28/2019
• BIOS Version: N51 Ver. 01.78
• System Serial Number: REDACTED
• Asset Tag:
• OS: WT64_1909 - OEM
• WMI Provider: Firmware Interface
Detected Devices
• Device 0: “ACPI\ACPI000C\2&DABA3FF&0”,“ACPI Processor Aggregator”
• Device 1: “ACPI\FIXEDBUTTON\2&DABA3FF&0”,“ACPI Fixed Feature Button”
@3.40GHZ_1",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_2",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_3",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_4",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_5",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_6",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_7",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
@3.40GHZ_8",“Intel(R) Core™ i7-6700 CPU @ 3.40GHz”
• Device 10: “ACPI\HPQ8001\4&15D6DB75&0”,“Standard PS/2 Keyboard”
• Device 11: “ACPI\IFX0102\2&DABA3FF&0”,“Trusted Platform Module 1.2”
• Device 12: “ACPI\INT0800\4&15D6DB75&0”,“Legacy device”
• Device 13: “ACPI\INT3394\2&DABA3FF&0”,“Motherboard resources”
• Device 14: “ACPI\INT33A1\1”,“Intel(R) Power Engine Plug-in”
• Device 15: “ACPI\INT340E\2&DABA3FF&0”,“Motherboard resources”
• Device 16: “ACPI\INT3F0D\4&15D6DB75&0”,“Motherboard resources”
• Device 17: “ACPI\PNP0000\4&15D6DB75&0”,“Programmable interrupt controller”
• Device 18: “ACPI\PNP0100\4&15D6DB75&0”,“System timer”
• Device 19: “ACPI\PNP0103\0”,“High precision event timer”
• Device 20: “ACPI\PNP0A06\0”,“Extended IO Bus”
• Device 21: “ACPI\PNP0A08\0”,“PCI Express Root Complex”
• Device 22: “ACPI\PNP0B00\4&15D6DB75&0”,“System CMOS/real time clock”
• Device 23: “ACPI\PNP0C02\1”,“Motherboard resources”• Device 24: “ACPI\PNP0C02\1000”,“Motherboard resources”
• Device 25: “ACPI\PNP0C02\2”,“Motherboard resources”
• Device 26: “ACPI\PNP0C02\5”,“Motherboard resources”
• Device 27: “ACPI\PNP0C02\PCHRESV”,“Motherboard resources”
• Device 28: “ACPI\PNP0C04\4&15D6DB75&0”,“Numeric data processor”
• Device 29: “ACPI\PNP0C09\1”,“Microsoft ACPI-Compliant Embedded Controller”
• Device 30: “ACPI\PNP0C0C\2&DABA3FF&0”,“ACPI Power Button”
• Device 31: “ACPI\PNP0C0E\2&DABA3FF&0”,“ACPI Sleep Button”
• Device 32: “ACPI\PNP0C14\1”,“Microsoft Windows Management Interface for ACPI”
• Device 33: “ACPI\PNP0C14\2”,“Microsoft Windows Management Interface for ACPI”
• Device 34: “ACPI\PNP0C14\3”,“Microsoft Windows Management Interface for ACPI”
• Device 35: “ACPI\PNP0F13\4&15D6DB75&0”,“PS/2 Compatible Mouse”
• Device 36: “ACPI_HAL\PNP0C08\0”,“Microsoft ACPI-Compliant System”
• Device 37: “ACPI_HAL\UEFI\0”,“Microsoft UEFI-Compliant System”
• Device 38: “DISPLAY\HWP26EA\4&104A9C10&0&UID198195”,“Generic PnP Monitor”
• Device 39:
High Definition Audio”
• Device 40:
Display Audio”
• Device 41: “HID\VID_1C4F&PID_0024&MI_00\7&101A6175&0&0000”,“HID Keyboard Device”
• Device 42: “HID\VID_1C4F&PID_0024&MI_01&COL01\7&13BCDC4D&0&0000”,“HID-compliant consumer
control device”
• Device 43: “HID\VID_1C4F&PID_0024&MI_01&COL02\7&13BCDC4D&0&0001”,“HID-compliant system
• Device 44: “HID\VID_413C&PID_3016\6&28F7AF9B&0&0000”,“HID-compliant mouse”
• Device 45: “HTREE\ROOT\0”
• Device 46: “PCI\VEN_8086&DEV_10FB&SUBSYS_17D3103C&REV_01\4&8B134DB&0&00E0”,“HPE Ethernet
10Gb 2-port 560SFP+ Adapter”
• Device 47: “PCI\VEN_8086&DEV_10FB&SUBSYS_17D3103C&REV_01\4&8B134DB&0&01E0”,“HPE Ethernet
10Gb 2-port 560SFP+ Adapter #2
• Device 48: “PCI\VEN_8086&DEV_15B7&SUBSYS_802F103C&REV_31\3&11583659&0&FE”,“Intel(R) Ethernet
Connection (2) I219-LM”
• Device 49: “PCI\VEN_8086&DEV_1912&SUBSYS_802F103C&REV_06\3&11583659&0&10”,“Intel(R) HD
Graphics 530”
• Device 50: “PCI\VEN_8086&DEV_191F&SUBSYS_802F103C&REV_07\3&11583659&0&00”,“PCI standard host
CPU bridge”
• Device 51: “PCI\VEN_8086&DEV_2822&SUBSYS_802F103C&REV_31\3&11583659&0&B8”,“Intel Chipset SATA
RAID Controller”
• Device 52: “PCI\VEN_8086&DEV_A114&SUBSYS_802F103C&REV_F1\3&11583659&0&E0”,“Intel(R) 100
Series/C230 Series Chipset Family PCI Express Root Port #5 - A114”
• Device 53: “PCI\VEN_8086&DEV_A121&SUBSYS_802F103C&REV_31\3&11583659&0&FA”,“Intel(R) 100
Series/C230 Series Chipset Family PMC - A121”
• Device 54: “PCI\VEN_8086&DEV_A123&SUBSYS_802F103C&REV_31\3&11583659&0&FC”,“Intel(R) 100
Series/C230 Series Chipset Family SMBus - A123”
• Device 55: “PCI\VEN_8086&DEV_A12F&SUBSYS_802F103C&REV_31\3&11583659&0&A0”,“Intel(R) USB 3.0
eXtensible Host Controller - 1.0 (Microsoft)”
• Device 56: “PCI\VEN_8086&DEV_A131&SUBSYS_802F103C&REV_31\3&11583659&0&A2”,“Intel(R) 100
Series/C230 Series Chipset Family Thermal subsystem - A131”
• Device 57: “PCI\VEN_8086&DEV_A149&SUBSYS_802F103C&REV_31\3&11583659&0&F8”,“Intel(R) 100
Series/C230 Series Chipset Family LPC Controller (C236) - A149”
• Device 58: “PCI\VEN_8086&DEV_A170&SUBSYS_802F103C&REV_31\3&11583659&0&FB”,“High Definition
Audio Controller”
• Device 59: “ROOT\ACPI_HAL\0000”,“ACPI x64-based PC”
• Device 60: “ROOT\BASICDISPLAY\0000”,“Microsoft Basic Display Driver”
• Device 61: “ROOT\BASICRENDER\0000”,“Microsoft Basic Render Driver”
• Device 62: “ROOT\COMPOSITEBUS\0000”,“Composite Bus Enumerator”
• Device 63: “ROOT\KDNIC\0000”,“Microsoft Kernel Debug Network Adapter”
• Device 64: “ROOT\MSSMBIOS\0000”,“Microsoft System Management BIOS Driver”
• Device 65: “ROOT\NDISVIRTUALBUS\0000”,“NDIS Virtual Network Adapter Enumerator”
• Device 66: “ROOT\RDPBUS\0000”,“Remote Desktop Device Redirector Bus”
• Device 67: “ROOT\SPACEPORT\0000”,“Microsoft Storage Spaces Controller”
• Device 68: “ROOT\SYSTEM\0000”,“Plug and Play Software Device Enumerator”
• Device 69: “ROOT\UMBUS\0000”,“UMBus Root Bus Enumerator”
• Device 70: “ROOT\VDRVROOT\0000”,“Microsoft Virtual Drive Enumerator”
• Device 71: “ROOT\VID\0000”,“Microsoft Hyper-V Virtualization Infrastructure Driver”
• Device 72: “ROOT\VOLMGR\0000”,“Volume Manager”• Device 73: “SCSI\CDROM&VEN_HP_HLDS&PROD_DVDRW__GUD1N\4&2C691D24&0&000200”,“hp HLDS
• Device 74: “SCSI\DISK&VEN_HGST&PROD_HTS545050A7E380\4&2C691D24&0&000000”,“HGST
• Device 75: “STORAGE\VOLUMESNAPSHOT\HARDDISKVOLUMESNAPSHOT1”,“Generic volume shadow copy”
• Device 76: “STORAGE\VOLUME{D47310CE-6BC9-11EA-BC5B-806E6F6E6963}#0000000000100000”,“Volume”
• Device 77: “STORAGE\VOLUME{D47310CE-6BC9-11EA-BC5B-806E6F6E6963}#0000000021200000”,“Volume”
• Device 78: “STORAGE\VOLUME{D47310CE-6BC9-11EA-BC5B-806E6F6E6963}#0000000027600000”,“Volume”
• Device 79: “STORAGE\VOLUME{D47310CE-6BC9-11EA-BC5B-806E6F6E6963}#0000000028600000”,“Volume”
• Device 80: “SWD\MMDEVAPI\MICROSOFTGSWAVETABLESYNTH”,“Microsoft GS Wavetable Synth”
• Device 81: “SWD\MMDEVAPI{}.{2C108A33-6A49-4D40-8D72-35709D2E4814}”,“Speakers
(Realtek High Definition Audio)”
• Device 82: “SWD\MSDAS{CE958E9A-424F-4C88-86F4-11314821E75A}”,“Microsoft Device Association Root
• Device 84: “SWD\MSRRAS\MS_L2TPMINIPORT”,“WAN Miniport (L2TP)”
• Device 85: “SWD\MSRRAS\MS_NDISWANBH”,“WAN Miniport (Network Monitor)”
• Device 86: “SWD\MSRRAS\MS_NDISWANIP”,“WAN Miniport (IP)”
• Device 87: “SWD\MSRRAS\MS_NDISWANIPV6”,“WAN Miniport (IPv6)”
• Device 91: “SWD\MSRRAS{5E259276-BC7E-40E3-B93B-8F89B5F3ABC0}”,“Microsoft RRAS Root Enumerator”
• Device 92: “SWD\PRINTENUM\PRINTQUEUES”,“Root Print Queue”
• Device 93: “SWD\PRINTENUM{2CF7C09E-BB0C-49BB-84C9-C940E3490451}”,“Microsoft Print to PDF”
• Device 94: “SWD\PRINTENUM{4BC45FAD-900E-4368-96F6-F6AB264BEB8E}”,“Fax”
• Device 95: “SWD\PRINTENUM{756D3521-2514-45B8-8FB1-F17DA72029C7}”,“Microsoft XPS Document Writer”
• Device 96: “SWD\PRINTENUM{DD45B4AD-6998-4565-9956-6DFA2EFE0F3F}”,“OneNote”
• Device 97: “SWD\RADIO{3DB5895D-CC28-44B3-AD3D-6F01A782B8D2}”,“Microsoft Radio Device Enumeration
• Device 98: "UEFI\RES
{6ADA8902-98CC-B546-BE2E-53BB3AEDFE83}\0”,“System Firmware”
• Device 99: “USB\ROOT_HUB30\4&6E70886&0&0”,“USB Root Hub (USB 3.0)”
• Device 100: “USB\VID_1C4F&PID_0024&MI_00\6&15CAE9E1&0&0000”,“USB Input Device”
• Device 101: “USB\VID_1C4F&PID_0024&MI_01\6&15CAE9E1&0&0001”,“USB Input Device”
• Device 102: “USB\VID_1C4F&PID_0024\5&38E96659&0&1”,“USB Composite Device”
• Device 103: "USB\VID_413C&PID_3016\5&38E9665

-------------- END OF LOG

I then placed in 2 more update files - HP Diagnostic Software and the latest BIOS Version. I recreated the FS database and re-run the update command and it found the 2 updates and installed HP Diagnostic Software and the BIOS Update. It then rebooted the computer to complete the BIOS update but when the computer rebooted it failed to POST. It remained with a power light on and after a few minutes the fans inside just run at 100%.

I hard powered off - removed power cable, pressed power button for 30seconds. Inserted power cable, powered on PC - it then brought up the updating BIOS to 1.78 - I allowed it to finish - rebooted again and it stayed black screen - no other leds lit only power - after few more minutes internal fans went to 100% speed - I waited another 5 minutes but still nothing.
I hard powered off - removed power cable, pressed power button for 30seconds. Inserted power cable, powered on PC - it powered on and shown the correct BIOS Version at the bottom of the screen (1.78) however it still had the message:
ERROR: SOFT TEMPORARY DISABLE: To enable ME, check Active Management (AMT) option in Setup (F10)

I checked the BIOS and confirmed that AMT is enabled.
I rebooted and tried to install the Intel ME update again but got the same message as before

It leaves trying older versions of software. I cannot get it to detect the Intel ME or AMT device on the system for it to force install update. That’s why I was hoping some of the tools on this forum might be able to help possibly forcing a reflash of the Intel ME Firmware. Can you suggest anything else to try?

Thank you so much for you patience on this matter, I appreciate your time.


1 st understand, your problem about Intel Management Engine. Not bios. Then, why update bios? HP z240 workstation Bios Final verion 1.78

wait until, others help !

check this Intel ME section :Link

Note : use spoiler tool, reduce length of post. [log file]

Hi guys,
Please bare with me I’m a newbie to all this ME/AMT Firmware tweaking and what-not.
I have been reading up on this issue and see others report similar symptoms on different systems. Most look to be resolved via re-flashing the Intel ME Firmware - I’ve located the FDO pins on my motherboard and set them to be unlocked - however when I run the MEINFO I still get
Error 9460: Unknown or unsupported hardware platform

I have also read that you can brick your motherboard by playing around with these tools so I was wondering if any you kind folks on here could help a newbie reflash my ME firmware PLEASE ?
I’ve already downloaded the latest firmware from the manufacturers website. Just some guidance using these tools would be a huge help!

Thanks for you time!

Ull get that error always as u dont have any Intel ME device id active, so ME Tools cant communicate with it…to get info or flash, i looked at ur mainboard techspecs…an extensive one and indeed u have support in bios for Intel AMT and ME…not showing in active device management is the strange parts as it may requires other unknown/specific HW components to be along side in the machine…since this is a Workstation class machine i do suggest u get in touch with HP support and engage a remote assistance with them. How is the ME Flash/Override jumper on the board…i assume u read the same document as i did…

Hi MeatWar - thanks for your reply.
There’s a sticker on the inside of the case when I take it off - see pic




Inside on the motherboard there is and FDO Jumper - its item 34 - ME AMT Flash Override- located at the bottom of the board beside Front audio - see pic




It looks to have 1 pin removed though, when I connect a jumper 2 the 2 remaining pins the PC powers on for a few seconds then powers off.
I’ve inserted another header pin into the jumper enough that when I put it over the 2nd pin the pin inside the jumper connects to the smooth surface where pin 1 would have been.

I’ve since downloaded CSME Tools v 11 which looks to be for this series of CPU (i7-6700) and when I run the command “fptw64.exe -d spi.bin” now I’m getting this error which I’m currently researching.
Error 318: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.
FTP Operation failed.

With regards to contacting HP I’ve posted on the support forums there also, with little response or luck I’m afraid. The system is only out of warranty in February but there is no option to extend the warranty - however my laptop I’m using now run out in January 2020 and I still get pop-ups asking if I’d like to extend. So either way, if this motherboard is done - I might as well take a stab at it - if I break it I’m gonna have to replace it anyway.

MEInfo gives the following error:
Error 86: Communication Error between application and Intel(R) ME module (FWU Client)
Error 81: Internal error (Could not determine FW features information)

I’ve read another post where someone had something very similar…
HP Z820 Unable to detect ME Firmware & Management Mode in Bios

The guy - plutomanic said at the end that after the flashing etc the software should be running fine now… I’m willing to give it a go - its broke either way.

Some guidance would be amazing though if you guys could. I do have the exact same PC running fine with the latest version of ME installed - I wonder should I dump the firmware from that one and use it to flash this one? Can that be done?

Thanks for you help and taking the time to reply to me guys, I really appreciate it and appreciate the patience with me being a NOOB at this too.

OK so I found that the pins that I can see are actually pins 1 and 2 however the system powers on and then turns off again when I’ve a jumper on pins 1 - 2.
Can anyone shed any light on this please?

Dont play with jumpers…learn wot ur doing…or do nothing if u dont have the knowledge. Its ur money…and its only my advice. Look for the correct settings and operations on that jumper features.
I also think plutomaniac is the best person, around this subject to help u with ME issues, and keep in mind that many OEM ME FW r locked regarding some operations that u saw others do it in their hardware.

Thanks MeatWar. There is little to no information online for Intel ME issues like this or FDO jumper info. Most of my searches turn up threads related to this forum so you guys look to be the most knowledgeable on it.
I am being cautious however the board is pretty much scrap anyway. The only way I can get the OS to boot is to remove the power cable - drain residual power. Plug it back in and it’ll boot once. Any reboots or won’t even shutdown and power off, hibernate sleep etc. I’m just desperate to try something. Thanks for your advice and help I do appreciate it. I just hope someone can shed some light or help me out.
I’m reading through the information on here I just don’t know if I’m going in the right direction, there’s a wealth of info. You guys do some great work!
Thanks again

@keefer7 Did you mange to resolve the issue?
I have the exact same problem, the Z240 machine works like a dream after the initial 4 minutes boot time and pulling the plug out when restarting or shutting down.

Hi mate, I didn’t get it resolved unfortunately. We purchased a new motherboard in the end from HP and rebuilt the machine to get it going again. The guy at HP I was talking to said the only other option was to return the motherboard to them for repair but the turn around was too long for our user and we opted for a new one. I’m sure there is a way to fix it with reflashing but I didn’t have anymore time to work on it. Good luck mate.

Many thanks for coming back to me.
It was a machine that was gifted to me but seems a shame to bin.
Not going to waste much more time on it but not afraid of killing the board by adjusting the jumpers in an attempt to flash