HP Z820 Unable to detect ME Firmware & Management Mode in Bios

I want to upgrade from Win 7 (64bit) to Win 10 (64bit).

I tried using MEInfoWin to determine if my current firmware needed updating but all I got were error codes 9458 & 9459. Further investigation in the bios shows ME Firmware Version and ME Management Mode as being Disabled.

How do I re-enable them?

Jumper on the motherboard (PCB Rev 1:03) or is it something else?

Any advice gratefully received.

MEInfo Results.png

You don’t need to update the ME to move from Windows 7 to 10. As for updating in general, without providing helpful system info we can’t do anything. What model? What current ME firmware? Drivers installed?

Hi Plutomaniac,
Thanks for the quick response.
What system info do you specifically need?
The BIOS details are here:
As stated I’m unable to determine the current ME firmware in the BIOS or by using MEInfoWin.

Download and use the latest ME8 System Tools package as provided at the first post to exclude any missing file or related issues. Do you have MEI drivers installed at Device Manager? This is the ME firmware that the latest HP bios you linked has:


Let’s try some things. Obviously make sure you have MEI drivers installed first or use the DOS tool versions. First use Flash Programming Tool with command fptw -greset and test MEInfo and MEManuf again after the system has reset. If that doesn’t work, make sure that you haven’t enabled any motherboard jumpers that are used to Disable the ME, Service or similar. Next, go to BIOS and check if you have enabled any setting that says “ME Reflash”, “Disable ME”, “ME Override”, “HMRFPO” or similar. For the motherboard jumpers and BIOS settings I suggest you check the HP Manual as well. If nothing, I suggest you try reflashing the latest BIOS from HP followed by setting default BIOS settings in order to exclude any BIOS issue or misconfiguration. If the problem persists, you probably have a corrupted ME region and in that case a ME Region reflash is needed. For the latter you need read/write access to the usually locked ME Region so an Unlocked Flash Descriptor. Check if your flash descriptor is unlocked by using Flash Programming Tool with the command fptw -d spi.bin or fptw -d me.bin -me. I expect some sort of answer for all the aforementioned suggestions to be able to help.

Plutomaniac – It’s evident you have some really experienced and knowledgeable members on this forum; unfortunately I’m not one of them!

In fact it’s obvious I need ‘Firmware for Dummies’. So I wondered if you would mind confirming a few points before I do something stupid?

I have just completed a clean install of Windows 10 (64 Bit), it’s running fine with no issues and no exclamation marks in Device Manager. I have the latest system bios J63 V03.88 (27.05.2015).

I would like to upgrade the hard drive in my HP Z820 to the Intel 750 Series PCIe SSD with the NVMe controller interface. Hence, to minimise issues I’d like to upgrade to the latest appropriate firmware.

I’ve looked in Device Manager and can’t see any MEI drivers.

Where would you expect to see them listed?

With regard to jumpers and my bios showing ME Firmware Version & ME Management Mode as being Disabled - I believe this is due to jumpers E1 (Bios ME/AMT Flash Override Header) and E14 (ROM Boot Block Header) being hardware write protections to frustrate future CPU upgrades, via flashing of the BIOS and Boot Block.

I don’t have any info on the procedure for using jumper E1 (Bios ME/AMT Flash Override Header) and wondered if I could simply remove or reposition this jumper (from say pins 2-3 to 1-2) to see if it re-enables the ME Firmware Version in BIOS, without ill effect?

I can confirm there are no settings in the BIOS which mention “ME Reflash”, “Disable ME”, “ME Override”, “HMRFPO” or similar.

AMT is disabled, but I assume that is not relevant?

To run the Flash Programming Tool I will use the Windows version in an Administrator Command Prompt, and type fptw -greset (after switching to the appropriate directory with the required files)?

Thanks for your help, its most appreciated.

For the OS update and new ssd, you don’t need to deal with the ME. The only reason I said the things above is because, despite your upgrade intentions, there seem to be errors when the tools are run. So the steps above are only to hopefully solve the errors and not for the other updates.

For Flash Programming Tool, yes, as you said. Use the Windows version if you like after first navigating to the appropriate files directory.

At Device Manager > System Devices, do you see the device Intel(R) Management Engine Interface? If yes, what driver version does it report?

Based on what you said and the service manual I just briefly read, there is no need to check the BIOS. The E14 jumper is irrelevant. However, the E1/JP1 jumper you mentioned (Bios ME/AMT Flash Override Header) is definitely the one we need to allow Read/Write access to the ME region in case it’s indeed corrupted. That jumper is used to service the ME so if it’s enabled the ME won’t respond properly and thus MEInfo and MEManuf will report errors. At the manual it should (whether it actually does is a different story) say which pins are responsible for enabling the Override and which for disabling. For normal operation and no errors at the tools, the jumper needs to be set to “no override” if you know what I mean. If the manual doesn’t specify what configurations pins 1-2 and 2-3 are then you can safely test yourself at both the BIOS and also by running MEInfo, MEManuf from within Windows or DOS. If the problem is indeed the jumper being enabled, then disabling it should show proper results at MEInfo and MEManuf. Otherwise, at least find out which position (1-2 or 2-3) is the one that disables the ME and thus allows Read/Write access to it’s region as that will be useful later on. To test the latter, as I said at my previous post, use Flash Programming Tool the command fptw -d spi.bin or fptw -d me.bin -me and no Error 26 or “cpu access” errors should be shown to verify that the Flash Descriptor is unlocked.


Generally, the facts that a) that board has a “Disable ME” jumper and b) HP includes the ME Region at their released BIOS (SPI) image, unlike other models, means that we can definitely restore the entire ME region in case it’s corrupted. But if it’s just a missing driver or a BIOS setting then these should be the first to exclude.


I looked in Device Manager > System Devices and can confirm there is no instance of Intel(R) Management Engine Interface, nor indeed anything else that mentions ME.

I changed the jumper E1 (Bios ME/AMT Flash Override Header) from pin position 2-3 to 1-2 and can report the following:

1. There was no change in the BIOS, which still showed ME Firmware Version and ME Management Mode as being disabled.

2. MEInfoWin yielded the same result as before; with the same error codes (for details please see my initial post).

3. MEInfoWin –verbose yielded the following:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

FW Status Register1: 0x1E040182
FW Status Register2: 0x16520100

CurrentState: Recovery
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: Bring Up
InitComplete: Initializing
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Unsecured mode by H/W jumper
ICC: No valid OEM data, ICC not programmed
PhaseStatus: UNKNOWN

HECI device is found to be disabled.

Windows OS Version : 6.2.9200 “”
OS BIOS Support : UEFI

4. fptw –d spi.bin results as per the attachment.

Hopefully these results will give you a better idea of what the issue might be. Please let me know if you would like me to undertake any further tests.

(I never ran the command fptw –greset partially because I wasn’t sure if you still wanted me to run it, but primarily because of its association with the scary word ‘reset’!)

With regards to your comments about the HP Service Manual, I’ve been through it in detail and found no reference to any Jumper Procedure with regards to ME or anything else for that matter.
I’ve also conducted a lengthy online search and again come up with nothing, apart from the understanding that HP Workstations are designed for reliability and not for tinkering by PC enthusiasts!

Having said that, I’ve just had a response to a query I raised about the ME Jumper Procedure on the HP Support Forum:


fptw result.png

MEInfoWin - verbose Results.txt (9.12 KB)

Alright, you covered everything perfectly. The reply from HP was actually surprisingly helpful even though you had already figured the pin combinations yourself. Maybe because it’s a Workstation and thus more knowledgeable people assist compared to consumer support I’m used to seeing. So if I understand properly 1-2 are to Override the ME whereas 2-3 is the normal locked state. The fact that you are able to perform fptw -d spi.bin successfully without errors such as “cpu access” or “26” means that you can replace the ME region and thus hopefully fix the errors. The fptw -greset command is safe and does not delete any settings or similar. It’s very useful to force the ME to reset it’s state and start clean so to speak. It’s also obligatory to perform after reflashing the entire ME region which what we are planning to do.

Since you can unlock the flash descriptor with the jumper and HP provides the ME region at their BIOS/SPI image pre-configured and flash-ready then we can proceed to reflash the ME region with the HP provided one. Where I write FPT I mean Flash Programming Tool.

1. Make sure the jumper is set to “ME Override” mode and the system has booted with that state.
2. Keep a backup of your entire SPI image by using FPT with command fptw -d spi.bin and store spi.bin somewhere.
3. Download the attached ME region which is taken from the latest HP BIOS for your model (Z820, v3.88 RevA, sp71580).
4. Use FPT with the command fptw -rewrite -me -f ME.bin
5. After it’s done (successfully), use FPT again with the command fptw -greset
6. Once the system boots up, go to BIOS and after restoring default settings, shutdown.
7. Set the jumper to normal ME operation, no override.
8. Boot the system and check BIOS, MEInfo, MEManuf.

Be careful with FPT and type the flashing commands carefully. If at any point you see any strange warning about size mismatch or similar, stop and report back to reassess the situation.

ME_sp71580_J63_0388.rar (2.44 MB)

Hi Plutomaniac,
I followed your instructions to the letter and everything worked fine, apart from having to reconfigure the BIOS back to my old settings in Step 8, (to be able to boot back into Win 10).

The default BIOS settings showed ME Firmware Version as and ME Management Mode as AMT. However, as soon as I Disabled AMT in the BIOS , the ME Firmware Version also became Disabled.

I ran MEInfoWin and MEManufWin, but unfortunately they both came up with the same errors as in my original post, regardless of whether AMT is enabled or not!

Oh, well we tried. Time to move on, but not before I thank you for all the time you’ve spent trying to help me with this - it’s much appreciated.


The fact that me version is not shown in BIOS when AMT is disabled is probably the way HP has set it to behave. What I can say for sure is that the ME firmware itself is ok now. As for the tool errors, I am not certain where the problem is. If the driver under Device Manager is still not there then that’s the problem and that’s almost certainly BIOS configuration related at that point. Anyway, as you said, this has nothing to do with your upgrade planning so leave it as it is. You don’t use AMT either way. Thank you and enjoy your 2nd hand system.