HP ZBook - Intel AMT setting (MPM locked)

Hey there,

I do have a problem regarding my HP ZBook 15. I have replaced the motherboard with a new one, set all the information (S/N, SKU, CT Board…) using DMIfit and then locked MPM. As it seems I should have set the AMT/V-Pro setting before locking MPM. Therefor my machine is now in commited state.
Does anybody know how to get it unlocked again OR set AMT directly in the ME region? I’ve read something about “VSS store” modification to unlock it but I have no idea which sections to manipulate.

I’ve uploaded a screen of UEFItool / ME Analyzer and my bios dump. Maybe someone could guide me to the light :slight_smile:

Thank you!


PS: Im a newb to this flashing stuff but willing to learn so please be patient.

Redo DMIFit with your SMC.BIN, or is that not possible now? You can unlock AMT in ME, but how you locked it may have removed that from BIOS options, additionally you will not be able to easily write to the ME region of the BIOS anyway without a pinmod or flash programmer.
Do you have flash programmer? If not, try and see if you can redo DMIFit again

Hey Lost_N_Bios,

thanks for your help (again) :slight_smile:

Yes I do have a CH341A and extracted the bios of the the chip (see attached mega download). I dont have a SMC.bin.
I could flash the chip with a different bios dump but would lose all S/N, SKU, CT, MAC address… I would like to preserve these settings.


If you do not have SMC.bin how did you use DMIFit to close it out previously? Contact HP and give them your UUID and serial, tell them you replaced the board and need SMC.Bin
Additionally tell them you ran DMIFit once and accidentally locked MPM before setting how you wanted, in case they need to give you something else as well.

I only asked about the programmer in case you wanted to try an AMT unlocked ME, you’d need it for that unless you have already unlocked your FD before programming in the BIOS previously.

I will help you with AMT setup ME later when I get back, was just heading out now, or maybe someone else will hop in to help you with that before I get back.

The motherboard was brand new so MPM was unlocked, no SMC.bin needed. I have already contacted HP but they said the board had to be installed by a HP technician so they cant help me. Additional problem was that I dont have the orginal invoice for the ZBook but only for the motherboard. The HP support in Germany is some kind of…lets call it "distressing"… :wink:

Take your time - it is a happy new year. Any help is much appreciated!

Maybe you asked wrong email addy, or said wrong things? @EuroTy can you advise him on best way to contact HP and get a SMC.bin in this situation, thanks!

Meantime, I will make you a AMT enabled BIOS, maybe that alone will work, if not we can change BIOS settings probably to enable if ME change alone does not get it. You did already try to enter MEBx via Control + P?
Edit @ZBooker - AMT is already enabled at ME level, so BIOS setting is all that’s holding it back. Can you enter MEBx, or enable AMT/MEBx from a visible BIOS setting, maybe in management?

I said to them that I am an IT technician and I need to unlock the MPM and no further detalis. But they asked me for some proof of purchase. I contacted HP Australia via online chat

Thanks @EuroTy - did you give them proof of purchase of the board or the device itself? Maybe he could prove he purchased the replacement board, I always think chat is friendlier too.

I did give them proof of purchase from the device itself.

Thanks @EuroTy - I see MPM NVRAM entry (VSS), I can change it’s variable 00 01 01, but I need to see BIOS without MPM locked to see if that should be all 00’s to unlock MPM again. Is either of the BIOS you’ve sent me EuroTy have MPM unlocked, I forget?
I also see CommitStatus and MEStatus

@Zbooker - since it would be brand specific, show me any info you read about enabling via VSS/NVRAM. I can unsuppress in the BIOS setup, but it would be better to just enable in NVRAM so no setup changes are needed.

Thanks for checking my bios. Im able to login to intel MEBx when board is posting. So this feature seems to work.
The proof of purchase is my problem - I dont have one of the previous buyer as I bought it out of a company liquidation. I only have the invoice for the board which doesnt seem to be enough for the german support :frowning:

@ZBooker - Try chat with some other location, or even German chat? Please see above, I was putting in an edit as you replied.

Since you can login to MEBx, seems problem solved, that is AMT enabled since you can get in there… Can you see the AMT settings in BIOS now? Upload a copy of the BIOS you used, before you locked out MPM, maybe I can undo that via what I mentioned above.

I dont have any different copy of my bios before I locked MPM. It was a brand new board with a unlocked bios. I had no idea that I would be in need of the stock bios again. Then Ive started googling to get rid of the committed state stuff and got myself a programmer. You see, Im a full rookie in this BIOS flashing stuff.

Ive took a picture of the ME settings page.

Regarding VSS and unlocking I found this post: https://forums.mydigitallife.net/threads…til-test.56701/

I found a BIOS dump from a pretty similar unit. Could it help if I copy/paste the ME region to my bios dump?

ME setting.jpg

Im a step further: I replaced the BIOS REGION with one from stock HP update which results in a MPM unlock - BUT on first boot I receive the message that "EC mismatch with configuration - going to restore system information"… any ideas?

Problem solved. A good samaritan cleaned my ME region. :slight_smile:

@Zbooker - Vss edit link is for removing passwords, what page do you see something related to this? I was going to say you need to redo the ME differently, using the clean/transfer process.
So you’ve got it now, and all sorted out? Great if yes!

I assumed that the MPM unlock results from the clean VSS section in the bios region. Replacing the complete BIOS region with one from an update did actually unlock MPM but locked itself after autocorrecting the EC MPM mismatch. My intention was to set Intel V-Pro setting when MPM was unlocked but wasnt even necessary. I guess I misinterpreted the relationship between the regions :slight_smile:
Now everything running smoothly. Thanks :slight_smile:

Great all is fixed now! VSS=NVRAM for anyone looking into this this later on, and yes, many of these kinds of settings can be changed in ME via FITc no matter how the ME is set originally.