I can not clean the bios. help me please

Hello forum members. I need your help. I can not clear the BIOS from Dell G3 3779, LA-F611P. I cleaned it myself, but the hard drives do not work SATA.
The original file is attached.

old_31_08_2020.part1.rar (5 MB)

old_31_08_2020.part2.rar (1.85 MB)

@zokir - Not sure what you mean to clean BIOS? Is system bootable? If yes, reflash latest BIOS, then load optimal defaults, save and reboot back to BIOS. Then in Boot area, move your main HDD to top of the list.
If SATA drives are not showing up in BIOS this is a South bridge issue, or fault SATA ports etc (test all ports, shut down between each move)

The chipset is fine. Because everything works with another bios. Only the keyboard and TPM are very slow. Therefore, I want to fix my BIOS.

Sorry if I write something wrong. I write through Google translator.

Then sounds like a BIOS bug with that BIOS version, stick back on the BIOS that works until they release a new one.

With that working bios, the keyboard and TPM are very slow and the battery is not charged. It also gives an error that there is no tag service.

What do you mean tag service? Sorry, I think there is big translation issues here

Do you need cleaned ME FW in BIOS attached to post #1?

Yes, very much needed. I would be very grateful if you could help.

Service Tag is null

@zokir - OK, I will clean ME FW for you tonight. Service tag you can fix later with Dell tools, once other proper functions are working normally.
@zokir - Here, I cleaned and updated ME FW from BIOS in post #1 - https://ufile.io/cdptksv2

Thank you very much. Everything worked as it should. You are an excellent specialist. Thank you again for your help.

@zokir - You’re welcome, and than you too!
Great to hear, thank you for the quick test and report back! I forgot to mention, if there was any issues after starting up, to run this FPT command and let it reboot, it should auto-reboot >> FPTw.exe -greset
That resets the ME FW state, you can do the same by draining ALL power from the board for 1+ minute

No reboot required. Everything worked right away without any problems.

Hi, can you please tell me what Dell Tool can be used to change service tag?

My problem is, I used an old modded bios to a pc with the same configuration.

Flash was successful, but now the service tag of the new pc is the same with the old one.

Now, I have 2 pc with the same service tag…:joy: