I need help moding vbios

Welcome to TechPowerUp Forums, Sat1600! Please check out our forum guidelines for info related to our community.
I need help moding Vbios
Post reply
Thread starterSat1600 Start date49 minutes ago

New Member
49 minutes ago
Add bookmark
I picked up a couple of OEM pcs last week. They are both HP h9 1150t. They came with x79 Express mobos, i7 3820 cpus, 16gb ram, HTC 550ti and bluray players. For $100 each I thought they were a steal.

I had also just purchased a lot of 4 sapphire nitro+ rx 470s for $65 each for various builds. I thought that this would be an easy flip.

Unfortunately HP never bothered to update the bios on these systems after 2012 and there lasted version is 7.15. No uefi support.

The card would not boot. Just black screen. I did manage to get a display doing the following

I got the card to display an image by making a small change using Polaris bios editor. (I change the core clock from 1260 to 1259). This damges the AMD EFI signature and prevents the card from booting up in UEFI mode. However now the drivers do not work properly.

I tried to follow this guide in order to disable the GOP module:

How to disable UEFI for legacy only boot on recent AMD Radeon GPUs

However when I try to load the rom using atiwinflash I get an error that the Vbios is not found.

I am using this vbios to play with

I really don’t know how to use the hex editor so aside from following the exact directions on where to put the last image indicator, I have no idea what ti do. If anyone can help that would be great

@Sat1600 - Disable secure boot in the motherboard BIOS and then you wont need to do any of this. Or, if you can see the setting, set PCI ROM Priority to Legacy. This is at Advanced >> PCI Subsystem Settings >> PCI ROM Priority
Or see end of my reply for how to change if this is not a visible BIOS setting for you - or I can also make you mod BIOS where this is visible if you can’t see it too.

I’m not able to repeat your ATIWinflash error, I used Polaris 1.7.2 and made only the change you mentioned and it opens fine in ATIWinflash 271 - what version did you try, mine may be too old to properly check this BIOS I’m not sure just tested with the version I already had.
Or, did you mean you tried the last image edit from the linked guide, changing first image to 80 instead of last (And setting last to 00 instead of 80)? If yes, I’m also unable to repeat those results, I made the edit and it’s fine
So you’ll have to upload your file for me to check and see what you did wrong that causes it to fail to load properly in ATIWinflash Checksum must be corrected, did you do that? If not, that may be what gave you the issue, not sure (Nope, tested with bad checksum, ATIFlash opens the file without issue).
Anyway, you do need to fix checksum at 21h, you can use SRBPolaris editor to do this for you (to see the corrected value, then manually change in hex yourself)

Try original image again, but update it’s GOP to latest version with GOP Updater (or tell me if you need me to do), then it should be able to boot in UEFI or legacy modes by itself without this issue or having to be edited (possibly)
Actually, to save some time, here try this first and see if same issue still, this is the file you linked with updated GOP only in case the older one wasn’t disabling properly - http://www.filedropper.com/sat1600-vbios-packagex3


Also included in the above is two more vBIOS, one with last image legacy/UEFI swap, and one with UEFI GOP removed totally (Either of those should work)


You could also change this setting mentioned above via grub with setup_var, stopping the BIOS from loading EFI/UEFI mod on the PCI/PCIE slots
Due to your BIOS layout, I can’t tell if BIOS is set to look for Shell.efi or Shellx64.efi from your launch EFI To shell on the exit page (or if you can even see that, if you cannot, then follow this method)
PCI ROM Priority, VarStoreInfo (VarOffset/VarName): 0x1
One Of Option: Legacy ROM, Value (8 bit): 0x0 {09 0E A1 05 00 00 00 00 00 00 00 00 00 00}
One Of Option: EFI Compatible ROM, Value (8 bit): 0x1 (default) {09 0E A2 05 30 00 01 00 00 00 00 00 00 00}

Change above to legacy rom instead of EFI >> setup_var 0x1 0x0

Here’s a guide I wrote on using grub/setup_var if you are not familiar with it, this was written to make a similar change as above, changing a BIOS setting that is not visible to you in BIOS
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Wow, thanks so much for your help. I will try those roms. Later today.

You’re welcome! Let me know how they work out for you

I used the one with the GOP removed and that worked perfectly. I didn’t bother trying the other ones. Thank you so much again. I really appreciate it.

You’re welcome! Happy to hear it worked perfectly for you, and thanks for your quick report back.


I don’t want to abuse your good will, but would you modify this vbios for me?

I have a aurora R3 and I can’t boot with the xfx rx 580 I recently bought used from a miner… :stuck_out_tongue:



VBIOS you linked, but with UEFI/GOP module removed/disabled, link.

Hi Lost n bios! would you be able to delete gop from my bios please. It is gigabyte rx 480 4gb
Please find file attached
If you need it,my mail is nesika@ymail.com
Thank you kindly!

bios.zip (111 KB)

@nesika - Here you go



Thank you forever lost n bios,it worked perfectly as expected. You made my day. Congrats to you!

@nesika - Great to hear it, thanks for quick test and report back too, you’re welcome!