IAStorDataMgrSvc makes error: "Missing localized format string"


I am building for my customer a small server with board Supermicro X10SLM-F in RAID mode. I spent many hours to install all drivers, to have a possibility to see the window of Intel RSTe Technology (GUI application). Up now I still saw empty window (it looks like some graphical error). When I used an original drivers from Supermicro, all worked but EXCEPT mentioned IATA_CD window on desktop. After click to icon on task bar - Only empty window was showed.
I repeated many times all OS instalation (Windows 7 Pro SP1 64 bit Czech version), but unsuccesfuly. I checked, if i have Net Framework 3.5 well installed etc. All worked except that window.

Today morning I tried to install not as normally all drivers from Supermicro website included RSTe drivers, but the last version of Intel RSTe drivers for WIN7 64 bit , e.g. RSTe_Windows_DRV_v4.3.0.1223
https://downloadcenter.intel.com/downloa…ver-for-Windows- …

This works BUT only in Windows Application logs are still exists mentioned messages (“Missing localized format string”), made by IAStorDataMgrSvc.exe.

What with it ?

Thanks in advance for any ideas :slight_smile: It looks like big SW inconsistency between Intel and Microsoft -as normally :slight_smile:

Chipset is :
Intel(R) C600/C224 on both AHCI Capable SATA Controller and SATA/SAS Capable Controller in Intel(R) Rapid Storage Technology Enterprise (RSTe) mode.

We have a X10SRA-F, we found out we need to disable on-board display if we have PCIe display card in order to make that GUI display normally.

For the Intel RSTe, you have to use those SSATA, for non-enterprise one use the IRST will do.

For up to date drivers, try their FTP site under /driver/Intel_INF.

Hope that help…

@hifik :
Welcome at Win-RAID Forum!
I am sorry about my delayed reply and hope, that chung5star’s tip will help you.

@chung5star :
Welcome at Win-RAID Forum and thanks for your contribution!

Dieter (alias Fernando)