ICH10R Issue


Followed the forum for some time, but now stuck myself.

We have several Supermicro X8DT3 Motherboards (5520 Chipset) with ICH10R SATA Controllers which I hope to upgrade to Server 2012 R2, but I cannot get any driver for the ICH10R Controller to work.

Supermicro have told me they don’t think there is a supported 2012 R2 driver for this chipset\ICH10R

Does anyone know if there is a driver that will work or have these boards come to the end of their production lives?

Any help greatly appreciated


Hello Mark,

welcome at Win-RAID Forum!
1. Which SATA mode did you choose or do you want to choose?
2. Did you already try the Intel RST driver v11.2.0.1006 WHQL?


Hi Fernando

Thanks for your reply.

In answer to your questions:

1) I am using it in RAID mode (RAID1)
2) Yes, but I get the following: your PC ran into a problem and needs to restart (and it then reboots)



Since the Intel SATA Controller is running in RAID mode, you should be able to get any Intel RST(e) driver of the v12 and v13 series installed (e.g. v13.1.0.1058 WHQL).

Did you install the driver from within the already running OS or did you load it at the beginning of the OS nstallation?


1) I believe I have tried a v13 driver, but will give your recommendation a go now
2) I am trying to install during O\S installation

Thank again


Had the OS Setup already detected the RAID array before you loaded the Intel RST driver v11.2.0.1006?

No, no controllers\drives are detected



So loading the Intel RST driver v11.2.0.1006 lets the OS Setup detect the RAID device and its volumes, but the system crashes at first reboot?

No, the system crashes once the driver is loaded.

The "Knight Rider" type graphic go across the screen for about 60 seconds and then after that straight into the reboot error page.

Error is displayed momentarily, but seems to be the "IRQ not less or equal"

Tried disabling or removing all other devices, but still no luck.


This indicates, that the issue has not been caused by the special Intel RST driver version.
What about the memory and PSU integrity and which Intel RAID ROM version is within the BIOS?

No issues running Server 2008 R2, so memory\PSU integrity seems fine - also we have multiple servers of this spec to try as well.

Motherboard running latest BIOS, and the Intel ROM version is


With which SATA mode are the Storage Controllers running and which driver do they currently use?

This version matches the Intel RST RAID driver v11.2.0.1006 nearly as good as the v11.2.0.1527 OROM.

I still believe, that the Intel RST RAID driver v11.2.0.1006 WHQL would be the best choice for Intel RAID systems with an ICH10R Soutbridge. The BSOD after trying to load the driver at the beginning of the OS installation does not mean, that it will not work with the system.