ICH10R + Raid-0 + Win 10 17134 = Trouble

Hey guys, I have tried out the newest Windows RS4 Image. A clean install is not possible anymore for me as the installer requests a device driver for the RAID array but does not accept my previously used 13.6 version anymore. As I do not have another one at hand, I am trying out an in-place upgrade now. I wonder if MS and Intel will finally work that issue out until release … it is a serious regression as it was at least possible to work around this issue with the last build but not anymore. :frowning: At least the in-place upgrade seems to work as expected though.

@ms178 :
Your problem seems to be caused by the new Win10 RS4 in-box Intel RST RAID driver v15.44 series, which may not support old Intel SATA RAID Controllers.
The best way to circumvent this compatibility problem is to remove the in-box Intel RAID driver and to insert a better matching driver into the boot.wim and install.wim of the Win10 image.

Strange, the 1733.1 version did also include the Intel RST RAID driver of the v15.44 series which at least installed fine on the same system (but they did not perform that well due to the disabled cache and no corresponding RST software to turn it back on). [I might be mistaken here, I might have installed it with the 13.6 version as a workaround, as I mentioned above this workaround is not possible anymore with 17134]

But yes, I also suspect that the 10.x OROM + 15.x RST driver combination is just not playing nice together. As you remember, I had several other issues with older Insider Preview builds with my RAID array because of that. Maybe I should contact Asus and beg them to provide me with a BIOS file where they update the OROM to a 15.x version. But I doubt that they are willing to do that…

As the in-place-upgrade worked well, I hope that Microsoft will fix this later or just stay on an older driver for that platform.

I’ve already learned a lot through all of this trouble though, the next thing would be to follow your advice modifying the Windows ISO. :wink:

This is an option, which I exclude.
Neither Intel (the maker of the in-box RAID driver) nor Microsoft are interested in supporting old systems like yours.
By the way: It would not be a good idea to update the Intel RAID ROM module of your mainboard BIOS to any version, which belongs to the v14, v15 or v16 platform.

The ASUS P6TWS PRO BIOS doesn’t even support any RAID ROM module above 10.X. :frowning:

At least the X58 platform is important enough that the still meaningful user base justifies some effort from their side. Microsoft even fixed the issues for older AMD platforms which are even less relevant. And as our ICH10R can work with older drivers still fine, the fix would be as easy as keeping the old driver. :wink:

Just to let you and other people reading this thread know, the experience with Redstone 5 Insider Previews has vastly improved. I can even install the official 16.x Intel RST now without causing boot loops anymore.

@ms178 :
Thanks for the info.
By the way: Which version has the Win10 RS5 in-box Intel RAID driver?

The main question is not, whether you can install the latest Intel RST drivers onto old systems, but whether they give them the best possible performance and stabilty.


It is still the same as RS4 (15.44.X from February 2018). But the new Insider Preview (or at least the ISO which I’ve used) behaves differently. Wheras I couldn’t even setup RS 4 without installing an older RST driver before installation, this now works out of the box again (that is with an older 10.x OROM-build RAID array, RS4 also just worked fine with 15.X OROM-build arrays before).

You also needed the following workaround in RS4 to get the latest official RST drivers to work properly: https://communities.intel.com/thread/111811

This is no longer needed with RS5, as it now also works okay with the standard limit of 80 (“MessageNumberLimit”). From my own testing, this feels much smoother, noticeable especially in Games (tested with Battlefield 1). This might be the improved latency from using MSI mode better. The RST driver also optimizes my 4K reads a lot after a couple of days (from around 3.5 MB/sec to 10 - 12 MB/sec on higher qd levels and from around 1.5 MB/sec to 3.5 MB/sec on lower qd levels). Not bad at all for my 2x SSHDs, but I’ve seen even higher levels with a different combination of OROM / RST drivers / Windows versions. Nevertheless I’d ask people to try it out themselves, as for my use case the latency improvement is worth the minor losses in other benchmarks.

One dilemma before was that my 10.x limited BIOSes (P6T Deluxe V2 and P6T WS PRO) were more stable with my CPU but felt not as smooth in Games as the 15.x based P6X58D-E BIOS. With the newest 16.X driver from your forum and the latest Insider Preview, the feeling is now comparable.