IME Update failed


I have a ASRock H97M-Pro4 & I tried to update IME v9.1.2.1010 to v9.1.10.1005 (1.5M)

OS is Windows 8.1.1 Pro 64bit

However, when I tried:

D:\Intel ME System Tools v9.1\FWUpdate\Local-Win64>FWUpdLcl64 -f ME9.1_1.5M_Production.bin

Intel (R) Firmware Update Utility Version:
Copyright (C) 2007 - 2014, Intel Corporation. All rights reserved.

Communication Mode: MEI
Checking firmware parameters…

Warning: Do not exit the process or power off the machine before the firmware up date process ends.

Error 8771: Invalid File

MEInfo shows:

Intel(R) Manageability and Security Application code versions:

BIOS Version: P1.20
MEBx Version:
Gbe Version: 0.1
VendorID: 8086
PCH Version: 0
FW Version: H
LMS Version:
MEI Driver Version:

FW Capabilities: 0x5910194C

Intel(R) Small Business Technology - PRESENT/ENABLED
Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED
Service Advertisement & Discovery - PRESENT/ENABLED

TLS: Disabled
Last ME reset reason: Power up
Local FWUpdate: Enabled
BIOS Config Lock: Enabled
GbE Config Lock: Enabled
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: EF4018
SPI Flash ID VSCC #1: 20252025
SPI Flash BIOS VSCC: 20252025
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Capability Licensing Service: Enabled
OEM Tag: 0x00000000
Slot 1 Board Manufacturer: Unused
Slot 2 System Assembler: Unused
Slot 3 Reserved: Unused
M3 Autotest: Disabled
Localized Language: English
Independent Firmware Recovery: Enabled
OEM Public Key Hash (FPF): 0000000000000000000000000000000000000000000000000000000000000000
OEM Public Key Hash (ME):

— –
Force Boot Guard ACM: Disabled
Protect BIOS Environment: Disabled
CPU Debug Disabled: Disabled
BSP Initialization Disabled: Disabled
Measured Boot: Disabled
Verified Boot: Disabled
Key Manifest ID: 0x0
Enforcement Policy: 0x0

One thing that seems odd to me is that when I ran:

FWUpdLcl64 -save My_IME9.1.2.1010.bin

the output bin file is: 3.88 MB (4,071,424 bytes), which is a lot bigger than 1.5mb but smaller than the 5mb FW D/L.

The ME9.1_1.5M_Production.bin that I D/L’d from here is only: 1.48 MB (1,560,576 bytes)

Any assistance to resolve this issue would be most appreciated.


Your system supports Intel Small Business Advantage 2.0 so it’s using Intel ME 5MB firmware. To make sure I extracted the ME from the latest ASRock BIOS and indeed it has the SKU of a 5MB v9.1 firmware. So, the latest ME firmware for you is actually: v9.1.20.1035 (5MB)

Thanks Plutomaniac. That’s what I initially thought but when the saved IME bin file wasn’t “5mb” I wasn’t sure.

I’ll give it a go.

Thanks muchly. v9.1.20.1035 (5MB) successfully installed.