IMEI driver Windows 7 64 bits H410 chipset Intel G5905 processor

I need a driver for IMEI under Windows 7 64 bits.
The motherboard is a Gigabyte H410M H
Processor Intel G5905 Comet lake LGA 1200
In the Device Manager rest only a yellow mark : PCI sinplified communications controller
Numéros d’identification du matériel
ID compatibles

I’ve tried in manual
MEI Driver v2040.100.0.1029 (Windows 7)
but no driver is found by Windows.

Another driver found in
2040.100.0.1029 (01 oct. 2020)
for Windows Vista, 7, 8, 8.1, 10
give an error
Windows found a driver for your device, but encountered an error while trying to install it.
Code 39.


Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

MEI Drivers and Software v2044.15.0.1951 MSI (Windows 7, 8, 10 <= 1703)

MEI Driver v2040.100.0.1029 (Windows 7) (Driver only)

Thanks for your answer but I have already tested all these drivers. They are for Windows 10 and therefore will not work on Windows 7.
I found a solution for all the other problems that there was but for this last yellow mark I think I need to find a modified driver, if possible, working under Windows 7, hence my question.
I searched in
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
and so I tested
MEI Driver v2040.100.0.1029 (Windows 7)
but it doesn’t work

Are you sure there is no CSME firmware corruption first? It could cause the same error/behavior at Device Manager. Dump your CSME firmware via Flash Programming Tool (fptw64 -me -d csme.bin), compress and attach/link it here to take a look.

I tested but it does not work nor with the installer "This platform is not supported." nor in manual "Windows did not find any driver for your device.", the ID DEV_A3BA is also missing from the .inf file.

Thanks for your answer.

I tested but it does not work nor with the installer "This platform is not supported." nor in manual "Windows did not find any driver for your device.", the ID DEV_A3BA is also missing from the .inf file.

I wanted to dump with
CSME System Tools v15.0 r5 - (2021-02-20)
but it was missing
after implantation, error:
The application failed to start correctly (0xc000007b). Click OK to close the application.
Which CSME System Tools should I use?

You can use the EFI version of FPT, it should work just fine. You need CSME 14.5 tools, not 15.0.

Just add in section [Intel.ntamd64.6.1]:

%TEE_DeviceDesc%=TEE_DDI_x64, PCI\VEN_8086&DEV_A3BA ;ME14.x - CML-V

I noticed that you used CSME 15 tools, that’s wrong. You need 14.5 for your platform.

I missed this before but I now see that you’re using Windows 7. Alright, Intel dropped support for Windows 7 at CSME 12 so there’s nothing for CSME 14.5.

Honestly, unless you are overclocking within Windows (access to ICC via MEI), you don’t really need the MEI driver. And if you want to use any DRM capabilities (Netflix 4K etc) then you would need Windows 10 either way.

So, you can either try driver modifications (Have Disk with the Windows 10 driver - probably won’t work at all, adding the DEV_ID at the Windows 7 driver and using Have Disk - disable driver signature enforcement at x64) or leave the MEI driver as it is. In the latter case, you may be able to make the Device Manager yellow exclamation mark go away by installing the placeholder/dummy MEI driver from the Intel Chipset INF Utility (if it includes that DEV_ID, not sure).

Manual update OK, no more yellow mark.
Thank you very much this is what I was looking for.

I also think the MEI driver is not useful for me.
You showed me the possibility of removing the yellow mark in Device Manager by using a dummy entry from the .inf Intel Chipset INF Utility. Even if the ID is absent it must be possible to add it or create a special .inf to manage this ID in a dummy way.
For the rest of what you recommended to do a dump in efi, if I am not mistaken it would have been necessary then that I prepare a support formatted in gpt to welcome fpt.efi there, reactivate the efi in the bios and start on this support (indeed my configurations in Windows 7 are on MBR partitions and the EFI is disabled in the BIOS since I use Grub4DOS as launcher)?

Having the MEI INF driver only with DeathBriger’s mod is ok really as it won’t affect anything else at the system and it should allow getting CSME platform info via MEInfo, HWiNFO etc monitoring tools so I suggest to leave it as it is now.

Now, your CSME firmware is probably healthy (can’t know for sure without checking) but I would still be interested in a dump, if you are able to get one, for ME Analyzer research purposes. I’m looking for a dump from H410 or B460 boards. All you have to do is enable EFI booting in BIOS, copy the contents of the attached archive into a usb drive (an EFI shell folder + FPT v14.5), boot from that usb drive, press ESC at the EFI shell, type “fs0:” and then “fpt -me -d csme.bin”. If it completes successfully, attach me the csme.bin file.

fpt_145_efi.rar (459 KB)

Just change import section to run it in Windows 7:
api-ms-win-power-base-l1-1-0.dll -> PowrProf.dll
api-ms-win-devices-config-l1-1-1.dll -> CfgMgr32.dll

You are right now HWiNFO sends me information about Intel ME which was not the case before installing the driver.
The motherboard is brand new it is a PC that I have just assembled.
For the dump it’s done but I do not see where we attach an attachment (maybe it’s because I just signed up on the forum?)

What do you mean about "import section" ?…debug/pe-format

Yes, I meant officially. Such RE modifications are above my current level of knowledge so I suggested the other methods instead.

You have been granted regular member rights already so you should be able to attach. You should see this:


Compress the file first because there is a 6MB limit. The CSME firmware should fit just fine when compressed.

For example, try my simple mod. (406 KB)

I tested but no dump file is written. Actually no error but the executable comes out almost instantly.
In the binary comparison I saw the differences between the two executables.
Thank you.

Show a screenshot of results in the command line with administrative rights.