Insignia Flex 11.6 Hard drive missing

Hard drive disappeared during Windows Update Recovery power failure. Am hoping a Firmware update might get it going. I think I need Firmware file for:
Model: NS-P11W6100, American Megatrends 2.16.1242, Intel(R) GOP Driver [7.2.1010], Sec RC 00.05.00.00, TXE FW 01.01.00.115, EFI Shell version 2.31 [5.8], mode 1.1.2

@Brick
Welcome to the Win-RAID Forum!
I doubt, that your problem has anything to do with the topic "Intel AHCI/RAID Drivers", but to be able to help you, we need some additional information:
1. Who is the chipset manufacturer of your Insignia Tablet and which chipset model is it?
2. Which OS are you running?
3. What did you do or tried to do before the HDD/SSD disappeared and what exactly happened?
4. If possible, run the Device Manager of the OS and tell us the Controller names, which are listed within the "IDE ATA/ATAPI Controllers" and "Storage Controllers" sections.
Regards
Dieter (alias Fernando)

  1. The BIOS is American Megatrends and the Intel(R) GOP Driver [7.2.1010] is the main chipset.
    2. Windows 10 32bit
    3. The a/c adapter had failed without my knowledge. The battery failed during Windows Update Restart but I didn’t realize what happened so I restarted and Windows Update went into Recovery and the battery failed again. After replacing the a/c adapter and recharging the battery the hard drive was missing from the BIOS and EFI Shell Map.
    4. There is no hard drive to boot from or to install to, no way to tell what the controllers were named.

@Brick
If you are not able to repair the failed Windows Update, I recommend to do a fresh install of the OS.
By the way - a GOPDriver is a BIOS/Firmware EFI module for the graphics adapter, but not a chipset.

The title of this thread is "Hard drive missing". As there is no hard drive in the BIOS a Windows install just says No Device found.
Without the OS I can not determine chipset. Here is All the info that I can get from the device:

Insignia Flex 11.6
BC FCC ID: 2AAP6ZM1100B1
IC: 8257A-NSP11W6100
Model: NS-P11W6100
Input Rating: 5.2V 2.0Amax

BIOS Vendor American Megatrends
Version 2.16.1242
Core Version 5.008
Compliancy UEFI 2.3; PI 1.2
BIOS Version T1CW16Zowee_M1100
Build Date and Time 09/22/2015 14:59:19
Microcode Patch 821
Intel(R) GOP Driver [7.2.1010]
Sec RC Version 00.05.00.00
TXE FW Version 01.01.00.115

EFI Shell version 2.31 [5.8]
Current running mode 1.1.2

@Brick

If the HDD/SSD with the OS on it disappeared during a Windows Update or Recovery, it worked before this situation and should be still physically present.
You have now to find out, what happened. Is it bricked or just not been detected anymore due to another reason.

This is not true. You can check the most important hardware components (incl. chipset) by a bootable USB stick with a tool like HWinfo on it (>LINK<).
After having gotten knowledge about the hardware of your Insignia device, you should find out the reason for your issue (is it hardware/disk drive or software/driver related?).

HWiNFO32 requires a running OS. I do not know of any tool that I can boot and run.
I am sure the issue is software, most likely just the MBR corrupt. That is why I think I need the Firmware file.

@Brick

All you need is a properly working device (PC/Notebook) with any Windows OS running on it to be able to create a bootable USB Flash Drive. The free tool named Rufus can do it:

Creation of a bootable USB Flash Drive by using Rufus.png


Once the bootable USB Flash Drive is created, copy the DOS variant of HWinfo onto it. Then boot off the USB Flash Drive with your Insignia device and run the HWinfo tool.

What for? You cannot create/remove/repair the Master Boot Record or any other boot sector by using/modifying any BIOS/Firmware.
If the MBR should be corrupt and the Windows own Recovery option cannot repair the issue, you should try to do a fresh OS installation by using an up-to-date ISO file.

The Free DOS option in Rufus did not create EFI\BOOT\BOOTIA32.efi and did not Boot on the Insignia. Legacy BIOS mode is not available on the Insignia.
I would gladly do a fresh install if there was a hard drive, but my Hard Drive is missing.

@Brick

What lets you think that? Which BIOS option do you have within the "BOOT" section? Is there a "CSM" setting option? If yes, choose the option "ENABLED".

If you haven’t removed the HDD/SSD of your Insignia, it should be still present.
Who says, that the HDD/SSD is “missing” (which means “not detected”)? Do you see it listed within the BIOS? If yes, you should try to do a fresh OS installation.

There is a Secure Boot, I have tried both Enabled and Disabled.
It is SD and it is NOT listed any where in the BIOS.

@Brick

Since you obviously know nothing about the chipset of your Insignia and the sort/connection of the SSD, it is better to disable the "Secure Boot" and "Fast Boot" options.
My advice: Let your device being checked by an expert or by the merchant where you bought it.

Using WinPE I was able to execute HWiNFO32. Can\

Using WinPE I was able to execute HWiNFO32. Can’t figure out how to paste image, so here is text conversion:
Under Motherboard the Chipset box is Blank.
Under CPU - Intel Atom Z3735F, Stepping C0, Codename Bay Trail-T, SSPEC SR1UB, Platform UTFCBGA592
Under Motherboard - AMI Corporation APTIO CRB, Chipset is Blank, BIOS Date 09/22/2015, Version T1CW16Zowee_M11 UEFI
Under GPU - Intel Valleyview SoC - Integrated Graphics [Intel], Intel HD Graphics Gen7 4EU, Valleyview, Integrated
Under Drives - (S)ATA/ATAPI Drives, JetFlash Transcend 8GB USB Device the WinPE jump drive
At the bottom of the BIOS screen - Intel(R) GOP Driver [7.2.1010]

I think the Chipset would be something like Bay Trail-T Intel HD Graphics Gen7 4EU maybe.