Inspiron N5110 AMI Bios Bricked

I need help recovering the bios on my Dell Inspiron 15r N5110. I was trying to enable some additional options and clean out the duplicate menus in AMIBCP when the issue started. Wasn’t worried about anything because I already had my recovery usb ready. Unfortunately, the usual recovery method doesn’t work this time. I have dumped the corrupted bios using a ch341a programmer and test clip I ordered. I’ve tried flashing the stock Dell N5110A11 as well as what I thought was my fixed dump. My issue seems to be completely erasing all data on the bios chip. None of the programmers I’ve used have been able to completely erase and “blank” the chip while still on the motherboard. Which program should I be using? It’s a Winbond W25Q32BV or W25Q32FV chip. AsProgrammer_1.4.1 said it was W25Q32FV when I made the dump. All of the software I’ve tried sees it as W25Q32BV when I tried to flash anything. Will someone please help or at least direct me in the right direction? Dump and the working rom are attached (4.37 MB)

Still nothing?

There are lots of different tips already in this forum and a complete thread about how to use a CH341 programmer. Might be aimply a badly seated clamp, a baf chip, a voltage drop because of other compnents on the board drawing from SPIs lines? How do the lights on the programmer behave? Tried with or without CMOS battery?

Make a close and sharp picture of the SPI chip and attach it here!

Otherwise is your dump a perfectly fine copy of an A06 bios, just with bios region start shifted 2 dwords ‘early’ and 2 FF ‘too much’ at the end. (78 16 should be start of the next line at 180000)


Machine info in padding from 1A0000. Attached your corrected dump, ME region replaced with stock ME region. (2.02 MB)

I think I tried about every combination of the laptop being assembled. I just pulled everything back out to work on it. It’s just a bare motherboard right now with the CMOS battery removed. The zip I uploaded had 2 files in it, one of them being the corrupt bios I dumped using the ch341a. N5110_UEFI_spec.rom is actually a modded version of N5110A11 bios to enable UEFI. That is what I was hoping I’d be able to go back to using the ch341a. I flashed N5110_UEFI_spec over top of the original Dell N5110A11. I don’t remember why, but I flashed another rom I found online over top of N5110_UEFI_spec. It duplicated the screens shown in the UI. Then I bricked it trying to correct the issue.

I’m getting a good connection now that I ordered another clamp. Unfortunately, Dell removed all version of the bios from their website and uploaded some new version of the A3 bios. Think I should try flashing the rom or hdr file from that bios?