Install Windows XP-SP4 on Asus Z170-A (Skylake Motherboard)

Hi, I am new in this forum.
I am success install Windows XP on Asus Z170-A (Skylake Motherboard).
Using FiraDisk, RMPrepUSB and nLite.

My XP already upgrate to Windows XP SP4 Unofficial (https://ryanvm.net/forum/viewtopic.php?t…ht=windows++sp4)
Thank you Harkaz to your effort make Unofficial XP SP4 for all of us.

nLite use only to remove some component not needed by me, as well as make XP.ISO.
winnt.sif is working, but OemPreinstall must be set to “NO”
The contents of the $OEM$ folder will not be copied to the hard disk, maybe using FiraDisk driver.

For VGA and Lan, I use VGA Card and Lan Card.
Because can not find any Intel modded VGA and LAN driver for XP.

However I still have some problem installing drivers, until now can not solve by me.
Hope, I may have tips and advise from this forum to solve my problem.

The problem are :

1. Installing Intel USB 3.0 driver (VEN_8086&DEV_A12F)
Corrupted Code 39 with Yellow Question mark.

2. Installing Intel (ME) driver (Management Engine Interface)
VEN_8086&DEV_A13A
Corrupted Code 10 with Yellow Question mark.

3. PCI-to-PCI Bridge driver
VEN_8086&DEV_A167
Exclamation mark

Thank you for all of you to kindest help.

@XPUser :
Welcome at Win-RAID Forum!

I am not sure, whether it is possible at all to find/get Windows XP x64 compatible drivers, which do support all modern on-board devices of your Intel Z170 Chipset mainboard.
Question:
Which drivers did you try to install for the devices DEV_A12F (Intel USB 3.0 Controiller), DEV_A13A (Intel MEI) and DEV_A167 (Intel PCI-to-PCI Bridge)?

Regards
Dieter (alias Fernando)

Dear Fernando,

I am using Windows XP 32 bit instead of 64 bit.

All driver try to install download from Win-Raid website.
I already try install as following:

1. Intel USB 3.0 driver
VEN_8086&DEV_A12F

Driver tested to install
------------------------
32bit Intel USB 3.0 Drivers v1.0.10.255 mod+signed by Fernando
32bit Intel USB 3.0 Drivers v4.0.5.55 mod+signed by Fernando
32bit Intel USB 3.0 Drivers v4.0.6.60 mod+signed by Fernando

General : Windows cannot load the device driver for this Hardware.
The driver may be corrupted or missing (Code 39)
Resource : This device isn’t using any Resource, because it has a problem

2. Intel (MEI) driver (Management Engine Interface)
VEN_8086&DEV_A13A

Driver tested to install
------------------------
Intel MEI Driver v11.0.6.1194
Intel MEI Driver v11.6.0.1026
Intel MEI Driver v11.5.0.1019

General : This device cannot star (Code 10)
Resource : This device isn’t using any Resource, because it has a problem

3. Intel(R) 100 Series/C230 Series Chipset
PCI Root Port #17 - A167 (DEV_A167)

Driver test to install
----------------------
Latest “pure” Intel Chipset Device INF Files v10.1.x.xx WHQL
sunrisepoint-hSystem.inf

General : This device cannot find enough free Resource that it can use (Code 12)

Resource: This device cannot find enought free Resource that it can use
If you want to use this Device, you will need to Disable one
of the other Device on this system

4. Intel(R) 100 Series/C230 Series Chipset
Family PCI Express Root Port #9 - A118 (DEV_A118)

Driver test to install
----------------------
Latest “pure” Intel Chipset Device INF Files v10.1.x.xx WHQL
sunrisepoint-hSystem.inf

General : This device cannot find enough free Resource that it can use (Code 12)

Resource: This device cannot find enought free Resource that it can use
If you want to use this Device, you will need to Disable one
of the other Device on this system

Please help, what should I do.

Regards,
Gazali

@XPUser :
Thanks for the requested answers.
I am rather unsure, if I will be able to help you regarding the USB 3.0 drivers, but maybe I can offer some modded drivers for the Intel Management Engine and later on some modded INF files for the Intel Chipset devices you have mentioned.
As first step you may try to manually install the attached mod+signed Intel MEI drivers v11.0.0.1157. Please report, whether you succeeded or not.

Intel MEI Drivers v11.0.0.1157 mod+signed by Fernando.rar (3.18 MB)

Dear Fernando,

Thank you for your help.

Intel (MEI) driver (Management Engine Interface)
VEN_8086&DEV_A13A

Intel MEI Drivers v11.0.0.1157 mod+signed by Fernando.rar
Still can not solve the problem.

Regards,
Gazali

DEVMGR.JPG

What does that mean?
Were you able to get the driver installed? Did you force the installation by using the “Have Disk” option?
Did you get an error message? If yes, which one?

By the way: Why do you want to run an absolutely outdated OS on a brandnew hardware system? You will spend a lot of time and will be disappointed nevertheless.
The Windows XP hardware detection doesn’t know anything about your hardware and vice versa the big majority of your hardware features will not work with Windows XP.

Dear Fernando,

I do Have Disk Method to install MEI driver.
As you can look at foto attach, "Yellow Exclamation Mark".

If the expert give up, so I must say Sayonara to XP.
I plan move to W7 or W8.1

Rgds,
Gazali

The reason behind running xp in modern hardware is simple . There are many things which modern oses simply cannot do.

with win7 x64 you can use xp-mode :] [win8 do not have it ]
you need to install two files : virtual pc
https://www.microsoft.com/en-us/download…ls.aspx?id=3702
the xp pre-installed
https://www.microsoft.com/en-us/download…ls.aspx?id=8002

read that kb about cpu and virtualization support :
https://support.microsoft.com/en-us/kb/977206