Installing Win2k on Samsung NC-10 Netbook

Hey Guys,
I have a problem.
I try 2 install Windows 2000 on my Samsung NC-10 Netbook but its not possible.

First I changed in BIOS the AHCI Mode to compatible.
Then I started Win2k Setup and it doesn’t start. I don’t come to the point where I can choose which Harddisk I want to use.

In addition I downloaded from the Intel Page the Storage Drivers, and bounded the txtsetup.oem with Nlite into my Windows2000 Setup and it doesn’t work.

Everest says about my system:

Motherboard Name: Samsung N150P/N210P/N220P
Motherboard Chipset: Intel Tiger Point NM10, Intel Pineview-M

IDE Controller: Intel N10/ICH7 Family Serial ATA Storage Controller - 27C0


Please I hope you can help me, it is very important to put Win2k on this Netbook.

@ esfahani:
Welcome at Win-RAID Forum!

What exactly happens?
Does the boot procedure start at all? Do you get any message? If yes, which one?

If you are running your netbook in IDE mode, there is no need to load or integrate any storage driver.

Regards
Dieter (alias Fernando)

When I changed it to Compatible Mode and afterwards started Setup, it goes on and on until where the Text comes: Setup is starting Windows 2000 .
After that I waited 15 min and nothing changed.


Also you have misunderstood me.
I didn’t start Windows Setup with the compatible IDE Mode and bounded txtsetup.oem.

After i changed in BIOS to compatible , I started a normal Setup, without drivers.


Both of them didn’t work.

When i bound the txtsetup.oem into my Setup, i get the Error iastor.sys is corrupt.


What I ask myself is, that why Win2k Setup doesn’t work in compatible mode, but XP works ??
And I read that you, Fernando, are able to mod the drivers.
Well is it possible, to change a driver that it will work with Windows 2000 ?



Ah my Device ID is: 27c0
Intel(R) N10/ICH7 Family Serial ATA Storage Controller
Vendor ID is: 8086

If you are not able to get the W2k Setup running by booting off an original W2k SP4 CD while your system is running in IDE mode, I cannot help you, because there are no textmode driver required in this case.
Question: Which W2k-Version ddid you use? It should be the latest W2k with integrated SP4.

This should work. Maybe there is a hardware problem (RAM, PSU etc)?

This indicates, that you had integrated a wrong (64bit?) driver into the OS image.

The Intel RST drivers may not work with Windows 2000, but the MSM ones do.
So if you want to get W2k installed in AHCI mode, I recommend to integrate the “Universal 32bit Intel MSM textmode driver v8.9.8.1005 mod+signed by Fernando”, which you can find >here<.

So you’ve mentioned that I might have a hardware problem.
For me, the question arises, why this should be so. The XP installation works flawlessly when I set the AHCI mode to Compatible in BIOS.
So why does it not 2000?

I install on a netbook and do it accordingly with a USB stick, which can be a reason possibly?
Have now used three different Windows 2000 sources, even two versions in English and have also tried to integrate several controller driver, including the Universal 32bit Intel MSM textmode driver v8.9.8.1005 that you have recommended to me, unfortunately without success.

What’s the weirdest thing for me is why the Compatible AHCI mode is running in XP setup with no problems and fails in 2k?
I have now just also performed many different XP installation and Ubuntu it all works, but I can not get this stupid win2k on my mashine.
Is there really no way to do that
I despair slowly :frowning:

@ esfahani:

I repeat, what I have already written earlier:
As long as you are not even able to get an untouched W2k installed in IDE mode, I cannot help you at all.
Once you have managed to get W2k running on your netbook in IDE mode and want to get it running in AHCI mode, you may ask me again.
Important:
What you need is
a) a properly working USB drive formatted with FAT32 and
b) an original (untouched) Windows 2000 image with integrated SP4.

@ esfahani:

Which Bios version are you using? You say WinXP is running with AHCI compatible mode?
I think it is not possible to run AHCI mode on Samsung NC10.

I have upgrade my NC10 with 2GB RAM + 120GB SSD Kingston Hyper and Windows 10 Pro x86 is running just ok but only in IDE mode.
With earlier Bios versions there was an hidden option for AHCI but not working - ends up in BSOD and in newer Bios versions Samsung has removed this. Do you mean this option?

There are many german foren about this topic and no1 is able to run AHCI. I found this one in english.



Hello :slight_smile:

I took some pictures for you, to answer your questions.
I hope they help you.

20151117_120449.jpg

20151117_120552.jpg

20151117_120609.jpg

20151117_120622.jpg

Thanks for the pictures.
Can you please add a screenshot from the XP Device Manager running in AHCI mode?
Important: The “IDE ATA/ATAPI Controllers” section has to be expanded.

Thanks for the pictures.
Can you please add a screenshot from the XP Device Manager running in AHCI mode?
Important: The “IDE ATA/ATAPI Controllers” section has to be expanded.





Yes of course, no problem .
Here you go



If it is relevant, I used this driver:

http://org.downloadcenter.samsung.com/do…_9.1.1.1023.zip

20151117_125139.jpg

20151117_125153.jpg

20151117_125200.jpg

20151117_125218.jpg

20151117_125228.jpg

@ esfahani:

Thanks for the added pictures (it would have been easier for you and better readable for us, if you would have taken a direct screenshot by using ALT+PRINT and pasting it into MS paint).
Now to your Windows XP running in “AHCI” mode:
Your recent pictures verify, that your XP is currently running in IDE mode (and not in AHCI mode)
By the way: The v9.1.1.1023 package you had installed doesn’t contain any AHCI driver. It is an INF Update Utility package with a lot of information files (*.INF), but no real driver (=.SYS file).