Installing windows 7 on Kingston KC1000 NVMe

Hello !
I try for days and days to find a way to install Windows 7 on my Kingston KC1000 NVMe drive.
Recently i installed windows 10 on it and i booted it through the clover boot loader.
As you know windows 7 installation can’t recognize NVMe drives.
Is there any working driver for the Kingston KC1000 NVMe ?

My motherboard is Asus P8H61-M LE R2.0

Thanks in advance !

The only possible way I see this working is with modified windows installer (because you need a generic Microsoft NVMe driver for this to work, and I doubt a modified Win 8.x Kingston driver will work on Win 7).
You can try using this program to update Win 7 image file (bit of warning : it works only on non-modified Win 7 x64 ISOs) : LINK
Check “Integrate updated installer” option.

However it will take A LOT of time to update all things using it (SSDs for OS and source/destination files are highly recommended).

Here’s a thread on Polish forum about this program : LINK

Good luck.

Thanks for this, i will give it a try.
I tried so far to rebuilt w7 iso with the nvme hotfix but didn’t help (as i expected), now i will take a look at your links.

@nickxab :
Welcome to the Win-RAID Forum!

Your specific pre-conditions for the usage of a Kingston KC1000 NVMe SSD as Win7 system drive are rather bad, because
a) your H61 chipset mainboard natively doesn’t support booting off an NVMe SSD,
b) Win7 has no generic in-box NVMe driver (contrary to Win10) and
c) the SSD manufacturer Kingston doesn’t offer any specific NVMe driver for their NVMe SSDs.

That is why I recommend to use Win10 as Operating System.

Good luck!
Dieter (alias Fernando)

@agentx007 :
Ok so i tried the program many times, it successfully finished but there isn’t any created iso at the end…

Nick Image 1.png

I tried both ISO and folder ways…

@Fernando :
I fixed the boot problem using Clover, i installed Win 10 on it but there is a huge problem…my tools are not working, i have problem with AVR, usb 2 ttl converters and all these things…even my bluetooth doesn’t work…win10 are literally useless for me…
So as i can understand i paid 170Euros for nothing
Btw i installed again Win7 on my velociraptor disk and from there i installed the KB2990941-v3-x64 hotfix, the disk works perfectly.

Nick Image 2.png

Nick Image 3.png

Any way to use these drivers ?

EDIT by Fernando: Fully quoted posts replaced by directly addressing to the author and inserted pictures attached and resized (to save space). The pictures can be enlarged by clicking onto them.

Folder option is for source file, it needs a location of unpacked installer folders (think a Virtual DVD drive with loaded ISO file).
ISO is for using ISO directly.
Q : Did you unmount source ISO file before using this program (it needs access to file, and if it’s used in another program it may create problems) ?

Yes i did. :slight_smile:
According to the program it finish successfully but there isn’t any iso created at the output destination. :frowning:
I can’t understand what’s going on :confused:

Edit: on his thread there is a torrent with untouched w7 iso, i download this and i will give it a try again. Let’s see. :slight_smile:

Ok so i have the same problem even with the recommended iso…i don’t understand why…

Have you tried changing destination to partition on another hard drive ?

Yes, sadly i have the same problem.

Untick "download missing updates".

I did it as well…i let it build also only with the drivers but nothing happened…i will try in another pc and i will tell you. :slight_smile:

please let us know how you you made out. i too am attempting to create a bootable nvme aware win 7 installer.

Lol, MO, creating Windows 7 installer in the year 2017??? Windows 7 doesn’t work any more, all the hardware and developers is moving on to more modern operating systems. I would rather run Windows 10 modified by me or KDE neon with Xanmod kernel and the latest mesa/vulkan drivers which is the fastest most pleasurable OS I have ever experienced.

I hope you guys figure it out, but when something expires it usually means it has gone rancid :wink: … j/k P.S. where is everyone these days?

Kinda silly question at this point, but… have you tried "run as Admin" ?