Installing Windows 8.1 on Intel 10th Gen Comet Lake platform (LGA1200, B460)

Greetings, Win-Raid!

Recently I assembled a system based on Intel Core i3-10100F (10th Gen, Comet Lake) + ASRock B460M Pro4 (LGA1200) and, since I have absolutely no desire to install Windows 10, I tried to install one of the previous versions of Windows.

With Windows 7 SP1, it was not possible to move beyond the first couple of installation screens, despite attempts to integrate the missing drivers (using various utilities such as MSI Smart Tool) and connecting a PS2 keyboard.

However with Windows 8.1 there were no such problems — the installation of the system itself went fine without any issues. But at the stage of installing the drivers, difficulties began.

It was not possible to install native drivers for the motherboard from the Asrock website, but (to my surprise) the drivers for the chipset from the Intel website were installed without any problems. More specifically, these drivers (can’t post links, so in text):

The Realtek HD drivers from the official website could not be installed either, but the newer ones (Realtek High Definition Audio Drivers 6.0.9071.1 WHQL) worked fine.
Here are the links:

In fact, all that remains is to install the drivers for the Intel I219-V integrated Ethernet controller. But, unfortunately, that’s where I got stuck.

What I have already tried but failed to install:
native Ethernet drivers from the motherboard website;
the following drivers from the Intel website
drivers from Lenovo

drivers from I218 and other similar devices, through manual installation in the Device Manager;

As a result, the installation process was interrupted by this message:
“Cannot install drivers. No Intel(R) Adapters are present in this computer” (or similar messages): (screenshot).

So, finally, my main question: is it possible to somehow make this Ethernet controller work on Windows 8.1 or it’s not (without purchasing an external one) and am I doomed to install Windows 10? And if it is still possible, then how exactly?

The device itself has the following Hardware ID:

Thanks in advance!

It is a newer version of I219-V with different ID. Official Windows 7/8/8.1 drivers are not compatible with the ID. Extract the windows 8.1 driver \PRO1000\Winx64\NDIS64 and open e1d64x64.inf file. Find and replace the id:

PCI\VEN_8086&DEV_1570 to PCI\VEN_8086&DEV_0D55

Try to install it through device manager.

It’s not working.

Good afternoon!

I have an Asrock Z490, i5-10400 processor. I am having a problem installing Intel MEI. Please tell me, have you encountered such a problem and how did you manage to solve it?


The driver installs but does not start with v25.0 (Latest) and I219-V “PCI\VEN_8086&DEV_0D4F&SUBSYS_20818086&REV_00” NUC10 Comet Lake.

@shaider1.1 as the same ethernet driver with the Intel NUC i5 10210U, perhaps he can tell us if it works for him and since which modication.

tell me where can I download a reliable build of Windows 8?

Damm hard to find…indeed, besides MS theres really a bunch of them out there untouched…

Here u go:

I am going to try to install 8.1 on a B560 today/tomorrow/wednesday with an i3 10105F + GT710. Will report my findings here. @wellwe if you really dont want to use w10 give 8.1 + usb/ethernet a go at least, they are fairly cheap.

Edit - Windows 8.1 known working on ASRock B560M-ITX/ac, i3 10105F, 8GB Ballistix 2666mhz, 250GB Crucial P2 NVME SSD, GT710. No additional drivers needed for setup, just a clean iso.