InsydeH2O BIOS Modding Problems

I’ve been working on this for weeks now, trying to do this myself. But everything I have tried I run into road blocks. First, just getting the .fd out of the Alienware BIOS Update .exe was a struggle. Then trying to get into the .fd without some kind of file corruption message was the next challenge. I’ve tried everything inc. CBRom, both MMTools and Phoenixtool. To date, the phoenixtool seems like the one that will work but I don’t really know how to navigate the tool and make necessary mods while not bricking my laptop.

I will attach the bios (AW17A14.exe) and the FD file that I was able to extract (AW17A14.fd). The BIOS utility is InsydeH2O. And I think this is why this process is being so difficult…Insyde BIOS.

If someone could help me along I would appreciate it. I’ve done a LOT of reading here and trying different things. If we can figure this out, we would have the process posted here for others that are seeking to do the same thing with their Alienware laptop.

Link to fresh Dell Alienware 17 System BIOS vA14: >BIOS< (4.55 MB) (3.45 MB)

@ Kanati:

Welcome at Win-RAID Forum!
As you already have realized, it is not easy to get Insyde BIOSes modified. None of the official BIOS modding tools will work.
Why do you want to update the RAID ROM module?
Have you set the SATA Controller of your Dell system to RAID?


Because I’d like to have the most recent update available. I know, if it ain’t broke, don’t fix it. I still would like to know how to do it and then make it happen so I have the most up to date drivers, ROMs, etc.

Yes, I purchased the system setup in a RAID configuration. One of the main reasons why I bought this laptop. The current RAID ROM v12.0.0.1783. I want to update to v13.5.0.1056.

Here is more info from Speccy:

- WDC WDC WD7500BPKX- SCSI Disk Device
Manufacturer Western Digital
Interface/Connector ATA/100 with 40-pin IDE connector
Interface RAID
Capacity 698 GB
Real size 750,151,831,040 bytes
RAID Type Software RAID

Manufacturer Intel
Interface RAID
Capacity 10.5 GB
Real size 11,306,795,008 bytes
RAID Type Software RAID

- Motherboard
Manufacturer Alienware
Model 068R5X (U3E1)
Version A14
Chipset Vendor Intel
Chipset Model Haswell
Chipset Revision 06
Southbridge Vendor Intel
Southbridge Model ID8C4B
Southbridge Revision 05
Brand Alienware
Version A14
Date 9/24/2014

@ Kanati:
Thanks for the answers and the details of your Dell system.
Unfortunately I haven’t found any information about the chipset of the mainboard. Is it HM87?

Zitat von Kanati im Beitrag #3

Because I’d like to have the most recent update available. I know, if it ain’t broke, don’t fix it. I still would like to know how to do it and then make it happen so I have the most up to date drivers, ROMs, etc.

Although I can unstand your wish to get/keep your system up-to-date, I would like to warn you: Any BIOS modding experiments with mobile systems are very risky. You always should remember, that you may have a bricked notebook at the end.
FYI: The newest drivers/BIOS modules are not always the best. This is especially valid for mobile systems like your notebook.

Zitat von Kanati

Yes, I purchased the system setup in a RAID configuration. One of the main reasons why I bought this laptop. The current RAID ROM v12.0.0.1783. I want to update to v13.5.0.1056.

I doubt, that you will benefit from an update of the Intel RAID ROM module.

Now to your request: Since I don’t have any own experience with Insyde BIOSes, I am not able to help you myself.
If you are lucky, someone else will give you support.

Thanks for your time. Nice website BTW.

Hello fellow forumers,

Currently I have Acer Aspire E5-573G (i5 5200U & Nvidia 940M 2GB variant) and as you probably know Acer provides BIOSes for their laptops from Insyde.
Recently I’ve been thinking to update my BIOS, more specifically the CPU microcode only since other modules are not so important in my case (I use AHCI, and the GOP is not really needed and it is risky to update it too as I’ve read somewhere in the forum).

From MyDigitalLife forum I found link to the official Insyde H2OEZE tool for updating the BIOS modules/microcode/logo and etc… (don’t know if it’s the latest one) and with the help of CodeRush’s InsydeBIOS Extractor I extracted the BIOS from the latest update provided from Acer. I did this since the ZRT.fd file that usually comes when you extract the BIOS update .exe cannot be opened with H2OEZE.

My question, has anyone tried this tool and succeeded with it, I know that sometimes it takes risk from someone to report a result from something like this, but If I had a programmer with me I’d rather take the risk to report a results and share with similar users.

Best Regards.

Link to the Insdye H2OEZE → Link

I don’t have Insyde experience but it looks fairly easy to replace the current 1F microcode with the latest 24 using H2OEZE. I would suggest you used the BIOS region dump of your system to avoid losing board sensitive data (unless these can be transferred with H2OEZE but I have no idea). I have attached the latest MC I have for CPUID 306D4, platform C0.

cpu000306D4_platC0_ver00000024_date29-04-2016.rar (17.2 KB)

I dumped the BIOS region with Flash Programming Tool, the size of the BIOS is the same with the one which I extracted from the Acer BIOS update.

H2OEZE accepted the dumped BIOS as .bin (I’ve set it to choose all file types) and the CPU microcode can be updated, so I replaced whole 1F Microcode with the 24 one.

BIOS saved without any errors as .fd (I’ve also attached picture of the tool showing updated microcode)

But now I’m confused with how to flash the BIOS, Insyde Flash tool or Intel Flash Programming tool once again ?

Screenshot (5).jpg

I would use FPT again, careful to add -bios parameter as well to flash BIOS region only (but I think you already know that).

You can restore with a programmer in case of trouble, right? I have never used that tool in the past even though it looks way better than AMI’s MMTool.

I got error while trying. Attached screenshot.

But I think I have solution. If I enable advanced hidden options in BIOS (with Tab + Fn, that’s actually the hotkey, no need to use modded BIOS anymore :P) there’s a option in Chipset Section where it says BIOS Lock or something, forgot the exact thing.

Soo, If I enable that would it work ?

EDIT: And no I don’t have programmer :/, maybe this error gave me last chance…

Screenshot (6).png

It’s not my area of “expertise” but it looks like that’s what you need to do. The BIOS is probably write protected by default. If you don’t have a programmer, be careful. Inexperience with such platforms can be tricky at the beginning. Hopefully everything works out perfectly.

Also, make sure that microcode is the correct one you need. Run HWInfo and check the current version you are using (1F) to be certain.

Well ok, thanks for your huge help so far. But I will wait a little bit more if someone else with more knowledge about Insyde BIOSes will reply here for help and tips.

Other thing to mention, the size of the microcode header in the BIOS is 256K and either way even with 1F or 24 revision, the header is not filled to the end (attached picture of that). So that clears my confusion why the size of the BIOS is still the same.
Any help from other members would be glad, once again thank you plutomaniac

EDIT: Also attached information about CPUID with AIDA64

Screenshot (7).png

Screenshot (8).png

I don’t really understand what you mean by the microcode header size being “256K” at the BIOS. The MC is correct though as seen by AIDA64. The “microcode details” shown at H2OEZE is just the first bytes of the detected/replaced MC, I suppose for a quick visual verification. Also, I noticed that H2OEZE seems to show and keep only the relevant microcode. The original image has some extra (unused mc) but after modification only the first one is left.



On load of the BIOS in H2OEZE there’s always a message showing some sizes of the BIOS, including the microcode size which says 256K (picture attached).

Also that’s strange, you used replace as I did on mine, or just deleted the current microcode (1F) and added the 24 one. Probably those maybe are from different variants for the laptop since I think there are with different CPU, though having that much is bit strange.

Well If I don’t have luck with someone else who has knowledge of modding Insyde BIOSes, either with the tool or not posting here, I guess I leave it not flashed. Though If this ever turns out to be correct and working way it would really help the others with newer computers that have Insyde BIOSes and want to edit them.

Though there’s also to mention that in the release notes of the tool, it says that every new version has some kernel versions that it supports, but the tool never reports the kernel version or even if the BIOS file has higher than it supports.

Screenshot (9).png

You can flash the bios with the implemented recovery method, I did that myself on a Aspire E5-572G.
Here’s a link that shows you how to prepare a usb stick for bios recovery and here I uploaded two files you can try (renamed original bios 1.37).
I formatted the usb stick with FAT16, but you can also try with FAT32.
After you have followed all the steps from the link above (you don’t need step 4 of the preparation), the fans should spin up. If the filename is right, the power led should blink shortly after that.
The process will take around 1 to 2 minutes to complete.

After you’ve got that working, we can go on to creating a mod bios.

I used “replace” as I initially tried “add” which causes a weird output with an extra microcode shown in a broken way followed by a crash from the tool. Maybe it’s not fully compatible? The Kernel version is found at the BIOS. Your own is “05.04.45”. Just search for the string “$BVDT$” and you will see it after 0x3A bytes with a size of 0x9.


So as I understand your post, this a method of restoring to the generic (1.37) BIOS if anything goes wrong or just a method to flash a BIOS.
And I have to disconnect the battery inside since this laptop doesn’t have removable battery like it’s shown in the pictures ?


Well I confirm it too, I found the same kernel version number as you said in HxD, so assuming that in the release notes it says (“Kernel version required: 03.62.10, 03.72.10, 05.02.10 and later”), the tool should be applicable on this BIOS. Thanks again for the great find there.
And about that bug, I tried two BIOSes with the add option :

1. Using the add option in the edited BIOS with 24 Microcode (I used replace firstly on the FPT dumped BIOS) doesn’t give that weird output.
2. I confirm the bug same as yours here If I try to mod the (1.37 or dumped BIOS) with add option I get that weird output but here the tool doesn’t crash and the BIOS still can be saved.

The strange thing is that parsing the “bugged” BIOS in MC_Extractor shows that the BIOS is added next to the first one, but still there are 10 Microcodes in the BIOS.
Also even there’s a some BIOS in the tool that came with it (S675P008.fd), that has originally 7 Microcodes in there (reported by MC Extractor), and adding our Microcode there dosen’t produce the bug, so probably 10 Microcodes are the limit in Insyde BIOSes ??
And the tool actually reads the current Microcode in your PC and If it detects the same one in the BIOS then it shows only that one.

Bugged MCU.jpg





Sorry, didn’t notice that your laptop doesn’t have a removable battery.
Normally the recovery flash is the safest way to flash original and modded bioses, but in this case using the Windows flash utility might be better.
Here are the Windows flasher and the modded bios (added microcode using the same method you used). I also added the headers that the Insyde extractor removed, because those are necessary for the Windows flasher.
You can just extract the file and run “H2OFFT-W.exe”, then it should directly flash the bios.

With the official bios this method was already used successfully.
However, I never flashed a modded bios this way/used H2OEZE before, so you need to keep the risk in mind.

Thank you very much for this, but I will wait a little bit more though I have feeling that it will work, but when you don’t have programmer you still get that bag of risk there yeah…

Actually, the changes I made before might not be enough, so here’s one where I also removed some firmware checks.
In case you want to give it a try, this should (hopefully) be flashable.