InsydeH2O Change Logo HELP?

i want to change splash screen. Not windows splash screen, change manufacturer logo.
Where to start or anyone can help?
I couldn’t find the bios file for this. I don’t know how to take a backup or work on it.
Bios Version:
INSYDE Corp. 301.3.03 2023
SMBios version: 3.3
Decenta S22-TGLU-OPSC22
Bios Mode: UEFİ

Edit by Fernando: Thread title typo corrected

have you tried with H2OEZE?

I don’t have the original bios. First of all, I need to make a backup. Will I take the backup with h20Eze? I would appreciate it if you could help me on how I should do it.

Hi, no h20Eze is used to modify the bios, not to do the dump.
To dump your bios there are other tools to use.
you can try using flashrom or chipsec if you can’t find specific tools for your motherboard.
Once you have obtained the dump I advise you to first check in the FD section (they are the first 4096 bytes of the file) you must check if the region of your BIOS is writable.
You also need to check that there are no active CNTL/BWE BIOS protections.
This information is fundamental to understand how you then have to rewrite the BIOS (via software or via HW programmer)
At this point, use H2OEZE to make the changes you need.
I hope I was helpful

Definitely. It helped as a first step, I will try it tomorrow and write the result here. I will try Linux live usb with flashrom.

Hi dear, if you want to dump with flashrom you can use the following commands:

# Get SPI information and check write protection status
sudo flashrom -p internal --wp-status
# Dump all the flash into the SPI.bin file
sudo flashrom -p internal -r SPI.bin
# Check if the dumped file matches the contents of the flash
sudo flashrom -p internal -v SPI.bin

With chipsec instead you can execute these commands:

# Get SPI flash information and save it inside the SPInfo file -nb -v spi info > SPInfo
# Dump the flash -nb -v spi dump SPI.bin

In any case, always perform multiple readings of your flash on different files and make sure that they are always the same as each other for example:

# Compare the two files
cmp SPI_1.bin SPI_2.bin
# Compare the two files and show the differences
cmp -l SPI_1.bin SPI_2.bin | blackberries
# Compare CRC of files
if [[ $(crc32 SPI_1.bin) != $(crc32 SPI_2.bin) ]]; then echo “DIFFERENT FILE CRC”; else echo “GOOD”; fi

You should now have the basic information to start working.

@Gray_Fox_420 I did what you said, it worked.
I left the results below in zip form. Now I want you to guide me again.

Commands I applied:
# Get SPI flash information and save it inside the SPInfo file -nb -v spi info > SPInfo
# Dump the flash -nb -v spi dump SPI.bin (6.1 MB) (1.1 KB)

This is the structure of your bios

Flash Region             | FREGx Reg | Base     | Limit     
0 Flash Descriptor       | 00000000  | 00000000 | 00000FFF 
1 BIOS                   | 0FFF0400  | 00400000 | 00FFFFFF 
2 Intel ME               | 03FF0001  | 00001000 | 003FFFFF 
3 GBe                    | 00007FFF  | 07FFF000 | 00000FFF 
4 Platform Data          | 00007FFF  | 07FFF000 | 00000FFF 
5 Flash Region 5         | 00007FFF  | 07FFF000 | 00000FFF 
6 Flash Region 6         | 00007FFF  | 00FFF000 | 00000FFF 
7 Flash Region 7         | 00000000  | 00000000 | 00000000 
8 Embedded Controller    | 00000000  | 00000000 | 00000000 
9 Flash Region 9         | 00000000  | 00000000 | 00000000 
10 Flash Region 10        | 00000000  | 00000000 | 00000000 
11 Flash Region 11        | 00000000  | 00000000 | 00000000 


Your FD is type 2
0x80 => FF FF FF FF FF FF FF FF FF FF FF FF 00 00 00 00

The BIOS Region Write Protection also seems ok, but I need to delve deeper into the last two items.

BIOS Region Write Protection
[*] BC = 0x10000888 << BIOS Control (b:d.f 00:31.5 + 0xDC)
    [00] BIOSWE           = 0 << BIOS Write Enable 
    [01] BLE              = 0 << BIOS Lock Enable 
    [02] SRC              = 2 << SPI Read Configuration 
    [04] TSS              = 0 << Top Swap Status 
    [05] SMM_BWP          = 0 << SMM BIOS Write Protection 
    [06] BBS              = 0 << Boot BIOS Strap 
    [07] BILD             = 1 << BIOS Interface Lock Down 
    [11] ASE_BWP          = 1 << Async SMI Enable for BIOS Write Protection

It appears your BIOS has bootguard configured which prevents you from loading unsigned firmware.
If you try to open your dump with UEFITool NE you will notice it immediately, however you should check the status of the FPFs with MEInfo or intelmetool

Do you think we can change the logo of this? What if we keep trying?

Check MEInfo first

1 Like

I couldn’t use MEInfo. I couldn’t find how to do this. I tried to use Intelmetool. I ran Kali Linux with live USB, but it gave an error and said “Hardware is not supported”. , I didn’t even know where to access it. @Gray_Fox_420 Can you tell me how to do what is necessary? I’m sorry for making you tired, I wish I could make it

Intel ME tools only for Intel platforms, according to the chipset used/cpu generation.
No information was provided in any of your posts what kind/model machine this is.

EDIT: Confirmation needed S22-TGLU-OPSC22, if so Intel 11th Gen
ME tools 14 or 15.

thank you @MeatWar. I’ve zipped the MEInfo64 output here, can you take a look @MeatWar @Gray_Fox_420 ? (2.6 KB)

Your bios is still in manufacturing mode and FPF seems disabled, you should be able to modify the unsigned sections, better to wait for the opinion of someone more experienced.
in any case it would be better to have a programmer or check if your motherboard has SPI header.
For the logo I tried to open your bios with h2oeze but it doesn’t seem to be able to manage it, I don’t know if it could depend on the version I have. You could try searching with UEFITool for the HEX patterns of image files (jpg, bmp, etc.) and understand where they are implemented.

As far as I understand, even if I do it, it would require intervention at the hardware level. I think there is a high probability that it will fail software-wise. So there’s nothing you can do in this situation.