Integration storage drivers to Win7 Rescue Disk

Hello to all,

this forum seems to be exactly what I have searched for. I have very strange and almost inexplicable problem. In brand name Dell Precision workstation HDD failed. I have replaced the HDD with the one same capacity and perform Acronis Image restore. After that there is an infinite restart loop caused by BSOD. When I chose to diable automatic restart I see there is a famous stop error 0x0000007B ( with other paramater 0x…34) which is strong indication that my AHCI/RAID drivers are missing or corrupted.
That is very strange because I just replaced HDD and used Acronis Image restore. Universal restore also didn’t solve the problem, it has error pnp0c14 which by Acronis support forum can be safely ignored. I cannot explained myself why restoring image on new HDD caused BSOD when there was no change in HW. Stop error like 0x0000007B is typical when HDD is moved on another computer (new motherboard, chipset…).

The OS is win 7 64 bit with SP1. Installation disk cannot repair the startup problem so as the Rescue CD. I have tried to rebuild BCD but no success.
The machine has two HDDs and by default in BIOS option Raid on (this I didn’t change) but the drives were no configured as RAID. During POST I can see both as Non member disk. (That is why computer crashed when one HDD failed).

On way is to use nLite and to slip stream drivers for Intel RST (during POST I see it is Intel Rapid Storage ROM).
Can you please be kind enough to answer me these questions. This could save me a lot of time. I tried to do a clean install of win 7 64 bit on new HDD and it is OK, Windows works, but that is not a solution because normally on this computer there is dozens of other software which must run and which I don’t know to configure and don’t have installations disks, It has also a lot of very important files. So restoring image and repairing would save a lot of time. Working clean installation of win 7 was just to test whether my other HW is OK-
I have another station with identical HW and bought together. I tried to clone disk form this station, and just rename Computer name and IP addresses, but when I placed cloned disk I again had BSOD.

1. Is it possible to make Rescue CD with AHCI/RAID drivers integrated and then to try to use repair startup option?
2. Since I have another workstation that works OK and has the same HW, how can I obtain driver information for my storage controllers in order to download proper ones form Internet? On the web site of manufacturer I have only setup and cab files, but I need *.inf and *.sys files to add “offline”.
3. Is it adding drivers to installation making new install CD and the use of it for “Repair Computer” even worth a try? I mean is it theoretically possible that repair procedure will place correct driver?

Thank you very much and looking forward to your answers.

@Askic :
Welcome at Wn-RAID Forum!
I suspect, that your system has a degraded RAID array. As first step you have to find out, whether there has ever been created a RAID array (combination of 2 HDDs for better performance). You can do it either by hitting CTRL+I while booting or by running the Intel Rapid Storage Technology Console.

Yes, but this will probably not solve our problem.

Run the Device Manager, expand the section "Storage Controllers", do a right click onto the listed Intel RAID Controller and choose the options "Properties" > "Driver". For further informations (name of the real driver = *.sys file) hit the "Driver Details" button.

I don’t think, that you will succeed this way.

Happy New Year!
Dieter (alias Fernando)

Hello Fernando and thank you for your reply.
In this computer in which HDD failed RAID was not set up. Default BIOS option is Raid on and during POST I saw (before the HDDs failed): Non member Disk for both HDDs. On other station on which Raid 1 was set up in the list were listed something like: Memb Disk (0) and Member Disk (1).

I’m really trying to find some understandable explanation. I have machine with two HDD and BIOS option “Raid on” but the disks were not set up in RAID. Therefore second HDD is just plugged in but uninitialized.
Then one day I notice very bad performance of this computer and Windows start to make complaints like: Windows detected a failing disk. During restart next to disk 0 I see “Smart Event with yellow color” and next to Disk 1 No member with green.

I have removed the failing drive (identified by identified number) and placed new uninitialized HDD. System of course cannot boot since there is no OS. I use Acronis restore (complete disk) and immediately when windows start I received BSOD 0x0000007B (0xFFFFF880009A9928, 0xFFFFFFFFC0000034, 0x0000000000000000, …).
In the Internet I found that most likely cause is missing storage driver and that this error can be caused by migrating system to dissimilar HW. Here this is not the case.
I tried older backup but it is the same. I even tried backup old 3 years (I suspected bad backups due to failing disk) but BSOD is still there and it is not possible to boot safe mode.

In Acronis forum I have read somewhere that it is possible that Acronis built in some general purpose driver, but I doubt this is the case here.

Then I used clonzilla software on 100 % working machine. I disconnected one drive, connected empty drive booted from clonezilla live cd and used clone drive option. I thought to place this cloned disk to my “failed” computer, disconnect all network cables, boot up, change Computer Name, IPs and some specific details for some programs and that would be that. Unfortunately, cloned disk caused the same BSOD.

Like I said before, I inspected whether there is some kind of other HW error by making clean install of Windows 7 64 bit pro and it worked OK.

Late this night I came home, used same acronis boot cd, make image of my laptop’s hdd, formatted HDD and successfully restored HDD from image. It its working without problems.

So the problem is specific to Dell Workstation T5500.

I also doubt I can solve the problem with Rescue CD because I already tried to create Win PE disk with AOMEI PE Builder in which I added a lot of drivers already downloaded from the Internet and that didn’t help.

Honestly, I don’t think I’d be able to solve this and the computer will be send to some repair service, but I cannot understand why this is happening.
How to explain this phenomena:

Restore image of whole drive from saved image and experience BSOD when no other HDD is changed. There was a small difference. New HDD is WD, while old was Seagate. Then I formatted WD same capacity and used other drive Seagate ( that was originally SATA1) as SATA 0 and WD as SATA 1, repeated whole process and no success.

Tomorrow I’ll inform my chef that I’m not able to solve this and that we need external support, but I’d like to understand at least in theory why this is happening. It is really very low probability that Acronis restore process would alter storage driver. Also I tried clone disk from other station that works and boots without problem and end result is BSOD.

When we ordered Dell Precision stations there years ago I thought they would be very easy for maintenance especially in the case HDD drive failure, but I was wrong.

Thank you once again, any explanation is welcome.

@Askic :
If you want help, you should read the reply to your questions and try what has been suggested to do.
This was your question and my answer:

Zitat von Fernando im Beitrag #2

Run the Device Manager, expand the section “Storage Controllers”, do a right click onto the listed Intel RAID Controller and choose the options “Properties” > “Driver”. For further informations (name of the real driver = *.sys file) hit the “Driver Details” button.



Since I haven’t seen any reaction to this point from your side, I would rather like to know
a) whether you have done what I suggested and
b) the result.
Which driver version is currently managing your on-board Intel SATA RAID Controller?

Hello Fernando,

sorry about that. I have followed your advice and obtained the info on the working computer in Device manager. Since computers are bought together with same specs, I assume they’re using the same driver. Intel Rapid Storage that shows up during POST (ROM) has version 10.8.0.1303.
Attached you can see info about drivers, but I couldn’t figure out the version. I can download from Dell web site using my Service tag Intel Matrix Storage Manager setup file from which I cannot extract inf and sys files. I simply cannot open cab files that are packed in this setup. So this wasn’t really helpful.
Attached, you can find the pic from device manager.
http://www.pic-upload.de/view-32381353/Drivers.jpg.html


With my level of knowledge, I’m not able to solve this problem and we’re going to hire a local IT company. Nevertheless I’d at least like to find out what was the cause of this.
Just to lay out the facts one more:
1. I have Dell Precision T5500 workstation with two HDDs and BIOS option “Raid ON”, but the RAID array was not configured. During POST, next to HDDs were “Non member disk”. So one disk has system and data, other disk was uninitialized. Both HDDs were Seagate Bararcuda ST500DM002, SATA
2. I have been making regular backups of whole drive at least once a year and making regular backups of the data every week.
3. HDD with OS and data failed, and computer couldn’t start.
4. I put new HDD WD 500GB SATA and restored Acronis image and computer started an infinite loop with BSOD. BSOD was 0x0000007B stop error which is according to MS: “Inaccessible Boot Device”.
5. I tried few older backups but always end up with BSOD. I tried then backup image from the otehr computer but still the same BSOD
6. I tried to rebuild BCD, fixmbr, fixboot etc, change registry with Rescue disk (Load Hive) but no success.
7 I just swap SATA cables in order Seagate to become SATA 0 and WD SATA 1 and then restored image on Seagate, but still the same.
8. Tried clean install windows 7 64 bit pro and it was successful, but that didn’t solved my problem because I don’t know to install dozens applications that are need to computer to perform its function. So the only solution is to somehow repair boot or successfully restore OS together with its programs. With clean install I ruled out possibility that storage controller or any other HW is faulty.
9. In despair, I took out one HDD from other computer in RAID, put into my problematic computer and windows started. Then I clone this drive with clonezilla. When computer tried to start with cloned drive it ended with the same BSOD. When returned HDD back to RAID 1 computer, the IRST reported other RAID drive (which I didn’t touch at all) as offline member.
10. Instead of shooting myself, I gave up trying and we hired professionals. They will take care. The computer with RAID1 can boot from either of disks, but when they are connectedtogether one is reported as offline member.

On one forum, I was suggested to replace failed HDD with the same Seagate 500 GB drive, but I don’t have a spare one. I have few WDs, I don’t think that’s the reason because computer was not in RAID, other disk was uninitialized anyway.

That is the version of the Option ROM (Firmware) module, which is within the BIOS, but not the version of the driver, which is needed by the OS to manage your SATA drives running in RAID mode.

It is not hard to find it in the right picture. It is v10.1.0.1008.
If you want to get the “pure” Intel RAID driver v10.1.0.1008 WHQL (with already extracted iaStor.inf, iaStor.sys and iaStor.cat files), you can find it >here<.

I doubt, that there never had been a RAID array within your system.
As I told you already at the beginning, I suspect, that one of the RAID1 array members failed at any time with the consequence, that the RAID array had been degraded. Such degraded former RAID1 members are shown as “Non member disks”.
The problems increased, because you didn’t repair resp. recreate the formerly existing array and the related RAID array boot sector, but tried to work with the HDDs as “normal” HDDs running in RAID mode. That doesn’t work. If you want to use formerly RAID array members as “normal” HDDs/SSDs outside any RAID array, you have either to break the RAID array by using the Intel RAID Utility (precondition: the RAID array had been previously restored by the Intel RAID Console Software) or to completely low format or secure erase both former RAID array members. Otherwise the RAID array boot sector with the related partition table, which is stored within the absolutely hidden track 0 of the array, will stay alive and all problems continue.

Thank you Fernando.
So the file version of the file is actually what I need. I saw this but doubt because version is 10.1.0.1008. It seemed that version of IRST ROM is higher version, and since the computer was delivered at the end of 2012, I didn’t believe it use driver from 2010. Thank you for this clarification.

I’m pretty sure Raid was never configured on this system because when one drive fails or gets disconnected then during startup phase (POST) one can clearey see message written with yellow letters “xxxx Degraded”. This wasn’t show on this machine. Only green messages Non disk member.

Anyway, I’ll let you know when I know more. I hope the IT guys will tell me what was the problem.

It is indeed not the best combination, when the version of the Intel RAID ROM is higher than the version of the in-use Intel RAID driver (when the driver version is higher, it is less problematic).
So it would be a good idea to update the Intel RST driver and the related Software to v11.2.0.1006 by running the Setup.exe of the “Intel RST AHCI/RAID Drivers & Software Set v11.1.0.1006 WHQL”, which you can find >here< within the chapter I. A.