Intel Atom x5-z8350 no AHCI mode?

Hello everyone, I’m from Italy and I bought this Mediacom notebook:
As you can see, there is a m.2 SSD slot (weird, I didn’t know that atom z8350 supports SSD), so I bought a KingSpec m.2 2242 128GB SSD to increase space and speed. But I noticed that the speed is half than the onboard eMMC! (eMMC=90MB/s SSD=40MB/s). So I noticed that the SSD is recognized as “NT128 USB device”. There’s no option for enable AHCI in bios, I tried to install modded drivers from this forum but with no luck, I’ve also tried to edit keys in regedit, but without success. Any help appreciated!

@luca_madd :
Welcome to the Win-RAID Forum!

Please post the in-use driver and the HardwareIDs of the Controllers, which are listed within the “IDE ATA/ATAPI Controllers” and “Storage Controllers” section of the Device Manager.
You will get the HardwareIDs by doing a right-click onto the Controller and choosing the options “Properties” > “Details” > “Property” > “HardwareIDs”.
Once I got the required information, I will try to help you.

Dieter (alias Fernando)

Hi Fernando, ad you can see from the attachments, there’s no “IDE ATA/ATAPI Controllers” section in device manager. But here is Hardware IDs from Storage Controller section.




@luca_madd :
Thanks for the screenshots.
What has let you think, that the KingSpec m.2 2242 128GB SSD, which seems to have a SATA interface, is supported by your notebook?
For me it seems, that your Mediacom notebook doesn’t have an on-board SATA Controller.

Yeah, apparently it doesn’t have it, even if there’s a m.2 slot on the back.Seems that I will have to use the SSD as secondary storage. Anyway thanks for your answers.