Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

Thx for reply. Just to be sure, i can do a firmware upgrade from linux, say for example a Debian live USB? I’m sorry for asking, and i will read the OP with care, but i just need to know if i can forget about taking the time to acquire and install a temporary windows just for this? If i can do what is needed from linux then that is great, and would be a big burden off my shoulders.

Edit really sorry for being such a chump… i just wanna be caressed like a baby in you ppl’s strong and caring arms…

What seems to be the problem…? Did you read the the 1rst post like lfb6 pointed you? All is linked, the tools work in DOS EFI LINUX WIN… so get going with it, this is user task only and no one can guarantee you the best platform for each piece of hardware model and fw on it, that exists around.

Will do. i needed to know if i’m gonna have to install windows 7 (shrug) - or not. I’m a 45 year old semi-alcoholic, and instead of actually reading the op i decided to bother you fine people even if i didn’t need to, for this egregious and selfish act i genuinely apologize, and thank you for your kind help. While typing this i listened to 1999 - Dark Tranquillity - Projector FULL ALBUM

Thank you for sharing your problems… as we all have in life, all the best.
But what kind of illogical question are you making?
If youre going to use windows 7 then you should use the WIN version of the tools…ring a bell? But no one told you that you need windows 7 installed, didnt i just told you that several versions of the tools can work in multiple platforms… as you can check yourself by reading the damm post and getting a copy of the linked tools…simple as that and over_n_out.

1 Like

yes sorry, but the first step in the OP was to determine the version you are running, using hwinfo or whatever. and i got hwinfo and booted my mobo with freedos, and ran hwinfo, and got no info on ME.

The fact that i can use linux tools to update my ME firmware helps me alot because now i can start planning the installation of bullseye on my mdadm striped DC P3700’s, instead of worrying about microshaft.

9 posts were split to a new topic: Asus Q470 & Q570 WiFi issues after CSME update

Hello! I want to express my gratitude for the material.
With it, I was able to update the IME on my GIGABYTE Z370 ULTRA GAMING WIFI board.

Of course it was scary. But it worked.
In my case, I updated from

The only BUT, there is a version discrepancy in the IME section in HWINFO. But I don’t think it’s bad.

FITC is the program version the config was programmed with, won’t get updated unless you configure a compete me-region with another FITc version and overwrite the existing ME region.

1 Like

Thanks. How update fitc?
And does it make sense?

Not neccessary, doesn’t make any sense.


Thanks! (5.9 MB)
MEInfoWin64 (6.1 MB)


Maybe that’s why someone couldn’t update it. (1.8 MB)


You’re very hard to understand.

If an image doesn’t work for you: Build your own firmware update image according to the instructions given in the first post of this thread.

1 Like

Hey buddy… we dont understand you because whatever your using to translate is not doing the job as it should or you cant explain yourself correctly. I also read the post yesterday…
The guide worked for thousands of users and still does, if doesnt suit you, dont use it or search a solution elsewhere.

EDIT: Better start by tell us what motherboard model, what you did that cause your ME problem, and what your trying to achieve by using the information on this thread…then maybe we can understand a little better the issue.

Worked perfectly fine with ME 14 corporate H for me, at least.

Maybe the thought that there’s something hidden the silent herd doesn’t report is more attractive thant to think that one made en error or didn’t understand a guide correctly…

But anyway, there isn’t enough information to understand your problem and what you did to solve it, Sorry.

I don’t really understand the difference between S-H and LD firmware, apparently it has something to do with the chipset?

I have the ASUS PRIME Z590-A, a few days ago I updated to the firmware version, everything works without problems. Now the same firmware came as LD version and I wonder if I should rather use this?

Should I stay with

  • “Intel Management Engine (ME) Firmware Version (S-H)(1.5Mo)”
    or install
  • “Intel Management Engine (ME/AMT) Firmware Version (LP)(1.5&5Mo)”?

The MEA tool is provided on this thread…ring a bell? Try it…
Your bios uses SKU: Consumer H
LP is low power usually for laptops/small machines


FWUpdLcl64 & MEInfoWin64 (425.7 KB)

1 Like

hello, I have an asrock b85 pro4 mono with very limited function ME builded in BIOS. If I upgrade the newer ME version, do I get the full function such as remote power on, sol, kvm?
Thanks in advance.