Intel DX79TO + Samsung 950Pro

Hello everybody!
I Didn’t find a similar thread on the forum, so I’m making a new one.
Got an Intel DX79TO board with i7-3970X installed and Micron 1100 256Gb SATA3 SSD as a system drive. I’ve read on this forum that Samsung 950 Pro has onboard OpRom which makes this drive bootable on older systems. So I bought one, model MZ-VKV512 and PCI-e to M.2 adapter.

The problem is that I cannot make them work together.

At first, I installed the drive and powered on my system without changing any BIOS setting, the mobo got stuck on “64” postcode and OpRom LED blinking (there is a bunch of diagnostic LEDs on the motherboard).

There is no info on postcode 64 at the Intel website or MoBo manual, on other websites I found that this code is indeed related to OpRom loading. And I couldn’t do anything except resetting the system.
So I removed the NVMe drive, entered the BIOS, checked that the SATA controller is set to work in AHCI mode. BIOS here is kinda simple, so the only menu item related to UEFI/CSM boot is placed under boot submenu and is called “UEFI boot” with enable/disable parameter (no Secure boot or other similar items). When I set it to “disable” nothing changed, the MoBo kept sticking on 64 postcode.
Then I changed the SATA controller mode to “IDE” and at last MoBo saw the drive and even listed it among the boot drives.

So I made the USB stick with Win10 installer and MBR + CSM/Bios mode via Rufus, installed it in the system and tried to install the OS. It didn’t work, Windows installer didn’t list the drive even if I load Samsung NVMe drivers (took them from this forum).
I changed UEFI boot to “enable” - nothing changed. When I switch the SATA controller back to AHCI in with UEFI enabled or disabled - the system fails to load and again displays postcode 64.

At that moment I thought that there might be some problems with the drive, so I put it to the ASUS P5B board, the board found the drive, I’ve successfully installed Windows 10 and made some tests though the PCIe bus is 1.0 here.

Then I put the drive with Win10 back into my system with IDE + UEFI disable mode, entered the bios to make sure the drive is available (it was). I saved the bios and tried to boot.
The MoBo showed an alert “there were unsuccessful loading attempts, do you wish to enter bios or try to boot?” I chose to boot and it worked!
The windows loaded and I even made some speed tests on the drive (strange thing - the drive works on PCIe 3.0 bus, though the CPU is Sandy Bridge family and doesn’t support it. My GTX 1070Ti works on 2.0).

But after the restart, I got “no bootable drive” error and didn’t manage to run windows from 950pro anymore on this MoBo with any possible BIOS settings again.

Seems like it’s a problem with Intel bios here, but I may be wrong.
Any help will be appreciated.
The BIOS version is the last available from Intel website.

@breakneck :
Welcome to the Win-RAID Forum!

Although I have no own experience with an Intel mainboard, I will try to help you.
My first advice is to boot off the USB Flash drive again and to choose the "Repair" option.
If you should not succeed this way, I recommend to
1. remove or unplug the 2TB sized Western Digital HDD,
2. enter the BIOS and disable the SATA Controller and
3. restart the OS installation from scratch.

Good luck!
Dieter (alias Fernando)

Seems like the HDD was attached all the time.
Thank you, I’ll try and post the result.

It doesn’t matter what you put in BIOS/UEFI.
Samsung has it’s own controller (NVMe) that works regardless of those settings.
The only common point with MB and NVMe drive is PCI-e slot you are using.

If you installed Windows in MBR/Legacy mode, you need to check if CSM module is enabled and Legacy OpRoms are being used.
Don’t leave those settings on Auto.

@Fernando : no luck. The drive is just not visible to windows installer for recovery or install even with WD drive detached

@agentx007 : there is no option to select UEFI or CSM in bios. Only what I wrote earlier: UEFI boot enabled/disabled.
And the most strange thing - when the SATA controller is set to AHCI mode and NVMe drive installed - the mobo fails to post with OpRom led blinking and 64 stuck on postcode screen. When I set it to IDE - the drive is visible as boot drive in bios, but the system fails to boot from it.

UEFI enable = UEFI
UEFI disable = Legacy
It’s broken because it can’t use Legacy as boot, and doesn’t work because you didn’t install it in GPT/UEFI mode, at same time if you try to do it you can’t boot from it because there is no UEFI ROM on Samsung drive that will take care of BIOS not seeing it in since it’s NVMe drive ?

Well, if that’s the case, I suggest creating EFI partition on MBR style drive, and copying system files from GPT installation to it.
Of course some modifications may be needed for it to work… but MAYBE windows installer tools will be able to take care of BCD edition :slight_smile:

Seems like i resolved this issue, at least at the moment.


SATA in IDE mode + UEFI boot disabled + diconnected all drives except 950Pro + Fastboot Enabled + BIOS Downgraded to previous version and voila.
Strange thing happens when I try to revert settings and try to boot with my old sata (in ACHI/UEFI mode and GPT) - I start to receive BSODs in Windows literally after every boot (memory fails. IRQL_less_or_not_equal etc). Also all the heavy games I have installed on my PC doesn’t work properly - they just shut down without warning. Maybe this BIOS version doesn’t like memory overclocking or I corrupted some system files while tossing the disks, who knows.
Will work on the NVMe for some time and see what happens.

Also the Windows fails to boot with NVMe and WD 2Tb drive (it has GPT on it). Maybe MBR + GPT conflicts, or the MoBo doesn’t recognise the drive in IDE mode (there is a warning in BIOS that the drives <2Tb only work in IDE mode). I think I should try to connect my 256Gb Micron SATA SSD and see if PC boots correctly…

anyway I am not fully expert, but the maximum of RAM frequency in 3970X is 1600


That’s not Fastboot it’s the EFI Intel Hyperboot renamed to.
It cause power state issue on newer OS due early adaption on standards by other manufacturer and unimplemented stuff by the currently avaiable OS.
Intel never removed or updated their board bios by implementing the cut-down Hyperboot feature know as “fastboot”.
Also, you don’t want to know what IDE stand for.
Disable it and and change for AHCI or the hardware implementation if available. Don’t look back on anything manufacturer by 2009+.
If the hybrid AHCI\NVME cause issue make a clean install of the OS with the UEFI option enabled begin sure to delete any unwanted stuff by the initial device sector.

When I set the AHCI mode, the drive fails to initialize, mobo sticks at postcode 64 and I can do nothing (no image on the monitor, Bios isn’t accessible).
Seems like this guy had the same problem…ter?language=ru
Maybe I should try to wipe the drive on another machine and start all over again.

Also now I have frequent BSODs with different errors on them. I disabled all overclocking, but no luck. Seems like drive or compatibility issues.

If you used Rufus on the WINDOWS installation media you must run the DISKPART clean parameter to restore the USB device capability.

• 1) Open the Windows Command Prompt with “Run as Administrator” option ( ie. Run “cmd” as Administrator ).

• 2) Type “diskpart” ( without quotes ). Enter.

• 3) Type “list vol” seek your USB disk: compare the size, the type and the letter before proceeding.

• 4) Type "sel vol “USB_DRIVE_LETTER:” (without quotes) - ie: “K:” is an example drive letter.
Be sure to select the USB Drive the next command will wipe the DISK. Enter.

• 5) Type “clean” (without quotes). Enter.

• 6) Type “convert mbr” (without quotes). Enter.

• 7) Type “create partition primary offset=1024” (without quotes). Enter.

• 8) Type “format fs=fat32 quick” (without quotes). Enter.

• 9) Type “exit” (without quotes). Enter.

Download the windows 10 media creation tool and make the WIN10 ESD-USB directly from the media creation tool.

Do as follow:
Remove a RAM stick and change the “BIOS_CFG” jumper to the other position.
Boot the board to the maintenance manager and clear the setting, save and exit.
Restore the RAM stick and change back the “BIOS_CFG” to the normal position.

Boot to normal bios set your config and these settings:


BOOT > Boot Menu Type “Advanced” > “950” (if not available to select leave it empty)
Boot to Optical Devices > "DISABLE"
Boot to Removable Devices > "ENABLE"
Boot to Network > "DISABLE"
USB boot > "ENABLE
Boot USB Device First > "ENABLE"
BIOS Setup Auto-Entry > "DISABLE"

Save and EXIT

Attach the WIN10 ESD-USB made directly from the media creation tool and install WINDOWS

Does the DX79 POST with the 950 and reach the the windows installer now? if so:

With only the 950 inserted.
• Instead of “Install now” select “Repair your computer” > Troubleshoot > Command Prompt
• In the “Command Prompt” type;


SELECT DISK <DISKNUMBER> (should be 0 without <> if no other DISK are connected )

Restart the installation.


If still nothing see this post
Either the bootable DUET or non-bootable REFIND mode (depending by the UEFI switch ) should work on your board, if it still stuck or error the 950 or the adpater could be faulty.

I’ve already tried another adapter, no luck.
Ok, thank you, I’ll try to do a clean install

Also, I remember that I really downloaded an ISO via the media creation tool and then wrote it into a USB stick via Rufus. Will try to make a bootable USB from the tool directly.

Going to the maintenance manager may be not necessary, but restoring the bootsector since Rufus write it’s own bootloader on the installation USB media is.
The 950 should have it’s own legacy option rom making it bootable in either legacy or in EFI.
I don’t have one to try but anyway, if you follow what I previously wrote it should work nonetheless.
Main strict point are:
DISKPART clean parameter on the USB media you are using for the install.
Leave only the NVME connected in AHCI without selecting anything if not available within the bios boot option menu.

Leaving the boot option menu empty will force the BIOS to lookup for NVRAM bootable entries made in UEFI, so, other setting might be necessary either way to get it working, report back.

To issue the CLEAN command on the USB you can also choose to use the CLEAN function of the USBSetup application within the thread I linked on the previous post.
Notice that it doesn’t allow to do the same on the NVME itself, for that use the recovery environment option (shouldn’t even be necessary if you didn’t mess with).

Eventually if the board allow to write and you have the equipment to dump your binary bios, I can see if I can add directly the nvme dxe on the firmware partition.

I’ve checked an 950 option rom (on the 960) and it seems to support only native IDE and AHCI with native command queuing (NCQ).
Setting the IDE on legacy “IDE” (NO NCQ etc etc) made the X58 ICH board stuck but would probably crash the device if the rom was embedded like in the 950 case.
It also disallowed the GPT style and required the MBR type with that legacy bios system without an NVRAM for the OS installation to begin.

So, dunno, probably you shouldn’t change the option from IDE to AHCI once the OS is installed? this would cause boot issue.

Setting to AHCI shouldn’t crash the device if the X79 PCH support the NCQ. RAID software or other secondary controller boot rom could disable the 950 legacy boot capability.
I did a sloppy test on the DX58SO2 and the 950 rom would NOT enable the detection within the bios menu of another 960, the system was already supporting NVME via UEFI driver.

Final point is: I have no idea.

Hello, stranger Please Do you have a copy of your bios update for your Dx79tO, I can see from your screenshots that you have a 2014 version.
My pc just turned black while I was rendering something on 3ds max now when I boot up it says media test failure.
My hard drive seems okay and I even tried a different hard drive but my motherboard can’t seem to read it and I also tried different SATA cables and my motherboard can’t detect the HDD.

Now I want to try flash updating the motherboard but intel has deleted all discontinued self-support resources. Please if you have a copy of any .BIOS update file please reach out to me as soon as you can. Stay safe.

Is this any good to you?