Intel DZ68DB ME update from 7 to 8

thanks in advance for who reply

i have a problem with the motherboard in title.

i try to update the bios (initial was 0014) to 0032 0040 and 0048, but, even if the ME firmware update,
it NOT update to the 8.x version, for support of 3rd gen CPUs.

regarding me8, is written in the release notes of the latest bios:…eleaseNotes.pdf

i have try to flash with ch341 an image modded with me 8 version, but in bios, says that is installed version,
and if i try to update the bios version, it not try to update ME.

if i use fwupdlcl for me7, work for this motherboard, but if i try to flash a ME 8.0 version, not work.
if i use fwupdlcl for me8, not work.

what can i do?


U better flash again the 032 and repeat the bios 040 transition update. U shouldn’t have done that spi programming of the 048… not like that.
Report when system is operational with the 032 and ME active.
All this operations MUST be done with a 2nd Gen CPU Sandy Bridge, not a 3rd Gen IvyBridge.

6series_update_flowchart10.pdf (165 KB)

Thank you for reply

I can only downgrade to 0040, and now, the ME is
the cpu used, is an i3-2100

Like that (040 and ME7) u wont be able to upgrade the ME… but u can do a kick test now, insert a 3rd gen cpu and go check ME in bios if it stays v7.

EDIT:If ME still v7, then perform a bios recovery (Jumper OFF) with *.bio 032 or earlier version in USB, NOT using F7 option.
After that performs regular updates, NEVER in OS environment, use F7 ou USB iFlash…s-and-kits.html

Good luck.

thank you for reply

i try with a Celeron g1610 (ivy bridge), and it started regularly, with me

i try that, but under the 0040 not downgrade (structural changes…).
for try, need a complete image of a working board with older bios.

the only image found, start with 0040, and me (if i flash that image, at me firmware version say

With bios version 0032.BIO with jumper block off and USB recovery?

EDIT: Yes i know that… wots strange is that being blocked in a recovery procedure (low level…but ok its Intel).
Program an earlier bios 0027/0014 (of course a full dump) etc…, even if ME fails, then do the Recovery again now with the same programmed and then the 0032.

yes, not downgrade.

in fact, the release note say:
Due to structural changes in this BIOS version, once a board has been
converted to this version or later (0040), it will no longer be possible to
downgrade the BIOS to version 0032 or earlier. Attempting a BIOS
downgrade to a previous version may fail – the board BIOS will remain
at its current version.

i try all that you suggest.

Unfortunately, intel BIOSes cannot be used for create images for programmers like CH341.
or simply I’m not able to extract the image from .bio files from intel.

if i found a dump of a board with the 0014 or very close, under the 0032, the problem is solved,
reading guides like THIS ,I learned and repaired some board

U repaired in the past or did u managed to repair this one now? Solved or not?
Share the dumps u found on the web, the 0014 and the 0040 with ME8 if u plz.

i’m trying THIS link, if can be useful

Dump found, with ME8, and bios version 0040:

in past, i repaired 3-4 notebook Asus, apparently dead (power on, no screen, or freeze on boot logo),
but doing a dump, i found some important data for create a working image. now these pc working perfectly.