Intel HM67 Mobile Express Chipset (6-Series) Need help!

Hello there. This forum is a really nice place!

As I’m having a 6 series chipset, I don’t have the ability for TRIM in RAID 0.

I have a Medion Laptop, being MSI Megabook GT780/GX780 (MS-1761). (latest unlocked bios, modded)
I updated OROM file to the latest (NO TRIM) // tried as well modded for P67-Z68 (still NO TRIM)
I have 282A, 1C05.
I have latest 12.8 beta RSTe drivers.

I’ve seen some info, on how to change the table with flag numbers, but I’m not sure what Fernando you are doing, maybe different method, efficient or something.
And I haven’t found anything here regarding HM67 chipset. And, I didn’t tried rebuilding my setup after I updated the OROM file.

I can attach my bios file with latest official orom file in it. It is Ami Uefi bios.

I’m bot the best hexeditor user, but a method of unlocking trim in raid0 for my chipset, would be great. But if someone just edit my bios for it, I would be really thankful.

Thank you guys, and if nothing works for me, I would sell my one ssd, as no use for it, as the plan was for a raid 0 only.

EDIT by Fernando: The attachment has been deleted at 02/16/2017.

@ OneholD:
Welcome at Win-RAID Forum!

The Intel RAID ROM modules, which I have modded for P67 and Z68 chipsets to get TRIM in RAID0, only work with Desktop PCs and not with mobile chipsets (HM67).
The Flag to enable TRIM in RAID0 within the ROM module is “7” and the related “Alternate DeviceID” of Intel HM67 SATA RAID Controllers is 1C05, but there are 2 different 6-Series Mobile SATA RAID Controllers with that DeviceID. For details you may look into >this< post.
I just have modified the actual Intel RAID ROM v12.7.0.1936 regarding TRIM in RAID0 for HM67 chipset mainboards, but you probably are the first user, who will test, if it really works. You can download this modded RAID ROM from >here<.

Good luck!

EDIT: I have changed the link and the name of the modded file, but not the content.

I’ve used the first one, modded bios and flashed. As you say - just the name change.

Changes: trimcheck program v.04 - shows NO TRIM.
Windows 8 now let’s me optimize partitions (trimming). Before this - nothing to do with partitions.

I’ll try the manual test with files just now.

It appears to be not running. As tested with the manual test.

Fernando - which subgroup did you changed? 1C4B should be HM67, as stated in that link.

And I do have some laggs and freezes (for couple of minutes) after I try to do the Optimize task, or use that AnvilBenchmark trim command (it show: all drives do not respond to trim).

That is a pity. Which sort of SSDs (vendor and name) are within your RAID0 array?

I have modded both subgroups (1C4B and 1C4F) of the Alternate DeviceID 1C05.

I just dome some trim command tasks and even ran winset. And that check program showed - TRIM running. But just once.

I have Corsair Force 3 120gb x2. Latest Firmware 5.05a (no release notes), updated couple of weeks ago.

That firmware might be the bug. Well, and I will try my original medion bios (instead of msi bios) with your rom to see how it goes.

Yes, that would be fine.
As you may already know, it is sometimes not easy to verify, if TRIM is active within the RAID0 or not (depends on the SSD, the SSD Controller, the Intel RAID ROM and the RAID Driver), because the TRIM activity is not always high enough to get it detected at once and without forcing TRIM activity.
On the other hand: If you have verified TRIM activity once, it means, that the TRIM command passes through the Intel SATA RAID Controller and is working every day (when needed).

If once spotted - than it is there, ok I’ll stick for this. But really, after some mess on my raid, speeds dropped - not in tests (but in tests as well), but in everyday work.
I flashed the bios, same stuff, not showing if trim is running (auto test)
I will go back to win 7 without raid (I planed to do windows reinstall anyway) in ahci mode, flash back the firmware to 5.03 (stated the trim problems fixed) and check if the trim is working in ahci mode at all. than raid 0 + win 8 probably.

I’ll reply, when this is done. Thanks for help and info Fernando!

Also found a new Corsair SSD Toolbox v1.0 and a mystical firmware v 5.07, that might be available for my ssd’s through this new tool. Some have updated theirs through it, some have bought with new firmware. That Corsair is bugging me now.

Flashed firmware to 5.07 (available only through that new tool). Trim appears to work OK in windows 7 (that program can send trim commands, only in ahci, and only in win7, in win8 doesnt work.)
With disk C (filled to half) - trim check always says that trim is running (with no rst drivers). On D (empty) - never yet said that trim is used.
In raid I had available about 83% of fee space, so trim might not be in efficient mode.

After I try Raid 0, I will edit this post.


Windows 8.1 Pro x64 Preview.
Original Medion bios + your modded rom Drivers beta. SSD Firmware 5.07.

Used trimcheck program v0.4. Optimized the drives through windows optimizer. No laggs, freezes spotted. Everything works fine!

But actually - it showed only once, but actually - I don’t have huge disk activity now for trim to be active.

That is very good news! I am glad, that it worked.

The main point is, that TRIM passes through the Intel SATA RAID Controller of your HM67 system at all.
What did the TRIMCheck Tool say? Have you tried the manual TRIM test by using a Hex Editor as well?

First time I used trimcheck (had used winset to spot ssd as ssd), and it said - yes, TRIM WORKS. On second run - said no it’s not.

No, I don’t have time at this moment to try manual test. Maybe later.

If the TRIMCheck Tool gives the message once, that TRIM seems to be working, you can be sure, that TRIM is active within your RAID0 as long as it will exist and you do not flash another BIOS without an especially HM67 modded Intel RAID ROM module.

Yes, I got it. Thanks for your help! I will use this mod for future.

Am, but by the way - if make every chipset mentioned in the firmware, to be able to have trim support - it would make some problems? Like all-in-one, one mod for all chipsets?

We have already tested it. It doesn’t work, if you enable TRIM in RAID0 for all Intel chipsets.

This was done some time ago, mainly to provide trim in RAID0 for earlier chipsets using ICH10R, ICH9R (X58 / X48), but unfortunately I could not find anybody interested in testing it so nothing came of it. The only reason it was recently confirmed to work with EP45 UD3R using ICH10R was due to getting hold of the hardware myself.

It should have hopefully been generic for all chipsets using RAID controller ID 2822/282a, 4-series to 8-series, although not much point of using on the later ones, but I guess we’ll never know. There were other unanswered questions regarding if SRT support could be added (disabled in this OROM) and whether there was a dependence on CPU being core / xeon for the much older systems.

I suppose given the problems with some of the older BIOS not being able to support the larger OROMs and not so many people running those systems with specific need for RAID 0 trim the lack of interest is understandable.

Now it’s a clear situation for me. Haven’t seen this information on the forums, but actually pages 20-30 is a quite large amount of data to read.

But actually - having raid 0 in laptop, specially ssd disks in raid 0 - is quite awesome (with sata 3 speeds).

But really - I bought my laptop (new model, introduced some time before I bought it) and after couple of months - for the same price - new model. With 7 chipset series and unlocked processor integrated video card (i7 proc. 2 or 3 gen.).

Being my setup very good, I still feel disappointed about Intel’s and other hardware (MSI) vendors.

But really - if windows could do software raid (like linux and mac os x) - we wouldn’t have any problems, because drives would be in ahci mode. I’ve checked this info about mac os x and linux - trim is working in both.

And, actually - I thought my bios is quite old (being UEFI, I always seen legacy boot menu and options), with Intel MEI v.7.0 and old v10 intel raid orom, I thought it would never happen to have proper raid 0 working with trim.

Thanks to you guys, who found this info and manage this portal. Igor

It is possible to create a Software RAID with Windows (look >here<), but you will not get the performance of a “Hardware RAID” by using the Intel SATA RAID Contoller.