Intel Management Engine (ME) not detected by the motherboard

I have a few motherboard (different brand and chipset, Z77/Z87/X99) with a similar issue where the ME in detected as “N/A” in the bios, preventing overclocking and sometime clock reading.

This is what I did :

  • Downloaded and verified that the bios from the manufacturer have an ME engine present (using MEAnalyzer).
  • Tried the built-in bios flashing tool of the motherboard → no ME detected.
  • Flashed the bios file using Colibri and a CH341A → still no ME detected.
  • Unlocked the flash descriptor, backupped the bios using fptw64.exe and verified the ME was present and readable by the board (and of course it was present). Here is the screenshot of one of the board I messed up with (Asrock X99M Extreme4)
    X99M EX4 ME

So the motherboard isn’t using the ME parts present in the bios chip… So I made a few guesses to explain what’s going on :

  • The chipset is partly dead.
  • The chipset have internal memory and was manually updated by the previous owner to newer ME, making it not working with older ME.
  • The “ME” part of the chipset isn’t powered by the same power plane as the PCH and is currently not powered.
  • I need to “clean” the ME/bios file before flashing (then why it’s not working with the built-in flashing tool ?)

Can anyone help me, please ?

This is a very old and common issue, im surprised with your lack of info having so many motherboards with same issue and never found nothing about this… or maybe you did…

Start working: