Intel ME FW 9.1.0.1015

If anyone wants to experiment, Fdrsoft just posted ME Region file 9.1.0.1015 from Z97 BIOS, i have without errors built an image in FITC 9.0 for Z87, but i am not home right now so can’t test it.
Also he has posted Z97 GopDriver, it is version 5.0.1036, so same version i extracted from Z87 BIOS, so alot of things from Z97 BIOSes should work for Z87.


http://www.station-drivers.com/index.php…irmware-z97-h97

Dumb question possibly, did you just run it through the tool and left the values as-is and then build it?

D:\ME_9.0.30.1482\FWUpdate\Local-Win64>FWUpdLcl64.exe /FWVER outimage.bin

Intel (R) Firmware Update Utility Version: 9.0.10.1352
Copyright (C) 2007 - 2013, Intel Corporation. All rights reserved.

FW Version: 9.1.0.1015

D:\ME_9.0.30.1482\FWUpdate\Local-Win64>

First i just built it with default values to see if it would give FITC would give errors, then i changed the config to match the one I have, but I got “SKU mismatch” error when I tried flashing it, have to look into it more, shame if it couldn’t work.

error.jpg

Well i managed to flash 9.1.0.1015 to my Maximus VI Gene, using an external programmer, but tomorrow i will test some other ways.
Have not noticed any problems so far anyway :slight_smile:

ME_9.1.jpg

On this post here

http://forums.tweaktown.com/gigabyte/548…html#post473597

You advised how using fd44cpr removes the header which then allows you to view the ASUS BIOS in the FITC. This does work as you say, however do you know if this BIOS can still be flashed using USB flashback? The reason I ask is because I’ve sat on this 9.1 ME update for few days now because if something goes wrong, I do not believe flashing again using older ME will fix that problem on our boards. I’ll be stuck with a broken board as something went wrong with 9.1 ME - worst case scenario.

So I did few tests, both FITC and ME can see the ME file I’ve created correctly. I’ve inserted and extracted it from my BIOS back to FITC and it can see it - but, when I try and flash it using USB flashback, it fails. So I’m curious if you’ve tried flashing ASUS BIOS which has ran through this fd44cpr to remove it’s header via USB flashback and if it worked?

As far as i know UBF only works with cap files, and it does not flash the ME region, so you would not be able to update the FW, or recover to an older that way.
What i have tried regarding UBF was to remove the cap header on one file, open it in FITC, then open Another instance of FITC, load the 9.1 FW there.
Then change 9.1 values to match stock bios with 9.0 FW, then build 9.1, open the 9.1 FW and the BIOS cap file with 9.0 in Hxd, and use virtualfreds method of replacing the FW in Hxd,
Of course the byte Offset is different in a cap file than his instructions, then flash the cap file with UBF, it works but like i said doesn’t touch the ME region.

I assume, but don’t know for sure that the rom you made could be flashed with “Flashrom” or “afudos”, i saw that “afudos /GAN” can flash modded BIOS.

But, at this Point i wouldn’t recommend flashing just yet, unless you have an external programmer, like you said if something goes wrong the board is garbage.
Someone with a Gigabyte board could try, Q-flash will flash modded BIOS and rewrite the ME region, so should be safe.



Thanks, just to clarify the above though. Once you’ve modified and then build the 9.1 FW, are you inserting it to the “modified” CAP file (the one you removed the header off so you could open it in FITC) or to a fresh/stock CAP file (one that would not work with FITC as-is)? I’m wondering if that was my problem, I inserted it into the modified CAP file (where the header was removed so FITC can read it).

Yes, I inserted the 9.1 FW in the stock 9.0 cap file, But i also made one rom file with 9.1 that way, so i could use with my programmer.

With Gigabyte BIOS, Gbe region is also locked so Qflash/@BIOS don’t overwrite it, but FPT allows it… but i suppose you tried this way too…



Sadly i don’t have my Gigabyte board anymore, just noticed when i had my Z87X-OC that if i flashed a “stock” BIOS after updateing ME, it reverted to older.
I am not sure if Asus EZflash downgrades ME, it has been awhile since i used it, i will have to try it.

FPT way didn’t work Before re-programming the BIOS with 9.1, might work now, but haven’t tried, now that i have 9.1 FW i can use Fwupdlcl to re-flash 9.1 without any problems, so i should be able to easily update when newer 9.1.x FW shows up.

I tried this again.

I already knew that if I used “FD44Cpr” to remove the BIOS CAP file header so it can be read in FITC, this BIOS cannot be flashed anymore using USB Flash Back. It will simply stops early in the process, no harm though.

This time I updated the ME file and put it into a stock BIOS CAP file, I could confirm that “FD44Editor” could see the new ME version in there. I could also extract the ME region alone and confirm it’s the new version. However, after flashing this modded BIOS with the new ME, it is not on the board. It retained the current/existing version. There were no errors shown but nothing changed so it remained: 9.0.30.1482.

This is on Z87-Pro using 1707 BIOS.

At Station-Drivers there are new Intel ME Firmware versions for Intel 8-Series chipsets available.
It is the Firmware v9.0.31.1487 for 1.5MB systems (look >here<) and v9.5.22.1760 (look under “News”).
I will add direct download links to the start post of this thread as soon as possible.

@Pacman
Hellp!
FW MEI 9.1.0.1035 From ASRock Z97… :wink:

EDIT by Fernando: formatting corrected

MEI_9_1_0_1035.rar (1.02 MB)

@SoniX
Cool :slight_smile:
Is this 5MB or 1.5MB?
I ask because i only have my phone and won’t be home for a couple of hours.
I was given 5MB a while back, but don’t have that kind of mainboard.

EDIT: See now Z97, will try it :slight_smile:


1.5M

Edit: Already checked (Z87-Hero), works, picture here

It was flashed with fwupdlcl?


Did not try. Made through the FITC.

Anybody has FITC 9.1.x.xxxx or FWUpdLcl64 v.9.1.x.xxxx?

On Z97 system v.9.0.xx.xxxx didn’t works.
Thanks.

Edit:
FPTw 9.1.x.xxxx I have.

I flashed MEI firmware of HM86 computer to v9.1.2.1120. That was in those days I was not aware that it was not supposed to be for HM86.

I tried to downgrade by doing fwupdlcl (with and also without -allowsv ) but the downgrade "not initiated due to a SKU mismatch".

Is there any remedy? I cannot remove BIOS chip. Can only try to flash with advanced method, if this is possible.

@ bronxamigo:
Welcome at WinRAID Forum!

Since I am not sure about the best/safest way to solve your problem, I hope, that someone else is able to help you.

Regards
Fernando