Intel ME FW: N/A After BIOS reprogramming

Sorry if my English is not the best. I’m using Google Translate.

Months ago my MSI CX41 laptop crashed while updating the BIOS and got corrupted. I had to pay to have the chip reprogrammed, and the laptop works fine.

The detail is that since that reprogramming I could never install the Intel MEI drivers. Which always seemed strange to me.

Yesterday I entered the BIOS and I noticed that the ME FW parameter appears N / A.

It seemed strange to me and I tried to flash the BIOS with AFUWIN by checking “Program All Blocks” and in the ME Firmware Block section the “Entire” box and an error message appears. (It is attached to the post)

Following a tutorial from this same forum I tried to update using utilities like Intel MS FW Update Tool and got the error “Error 8743: Unknown or Unsupported Platform” (It is also attached to the post)

And yes, the equipment originally supports Intel MEI, but after that reprogramming I can no longer install it, nor can I install the Firmware manually. Is there any solution?

Captura de pantalla 2020-11-17 111428.png

Captura de pantalla 2020-11-17 111543.png

What BIOS & EC versions are currently installed? The BIOS menu usually shows such things.

Hi "plutomaniac"
Latest versions of both. BIOS/UEFI 50J Version and EC 5.02 Version
You can see in the screenshot of the MSI HelpDesk the more detailed information

Captura de pantalla 2020-11-17 115615.png

Alright, we’ll need to repair the ME firmware.

1. Download BIOS 402 and extract it
2. Download Intel ME System Tools v8 and extract it
3. Download 50J_ME attachment and extract it
4. Create a bootable USB flash drive with DOS and copy file “OPEN.COM” from E1485IMS402
5. Boot into DOS via the flash drive and run OPEN.COM
6. Power down the system via the power button
7. Boot into Windows and run Flash Programming Tool via "fptw64.exe -me -f 50J_ME.bin"
8. If it completes successfully, run "fptw64.exe -greset"
9. The system will reboot and ME should be operational
10. Validate via MEInfoWin64.exe -verbose and MEManufWin64.exe -verbose

50J_ME.rar (968 KB)

Hi plutomaniac. Thanks for your answer!!.
My Windows 10 is UEFI, DOS is obviously Legacy. I will have to enter the BIOS to change from UEFI to Legacy to run the OPEN.COM. And after turning off with the power button I will have to change from Legacy to UEFI to enter Windows. Will this not affect in any way?

OMG! It worked!

Thanks SOOOOOOO much!!

Greetings from Venezuela :'3


Perfect, enjoy your repaired system! :slight_smile: