Intel ME missing, corrupted? HP Probook 4540s Discrete GPU (Radeon HD 7650M) 30-minute kill

Hello from Greece,
what a great forums here guys!! Pluto-Lost-Fernando and the others, you guys are great!

I could categorize myself as semi-advanced user, so to be clear I don’t understand everything here easily :slight_smile:

I’m reading like 20 days in here, looking mostly for threads about ME related problems. I’ve read similar problems to mine but haven’t found exactly my laptop’s symptoms in any thread, so I decided to jump in and start this one, asking some help from the “ME experts” here!

Story is, everything was working fine, but most probably after the last Bios update (99% sure) 6 months ago machine started to shut down after 30 minutes. (not 29’ neither 31’)
It’s a very nice laptop, bit outdated, I currently use it mostly to get emails print documents etc, I mean jobs that last less than 30 minutes, so it took me a while to conclude that something ME related goes wrong. When it started shut down (in fact “turn off” like when pressing the power button for 3-4’’) I thought that was a charging/adapter’s fault since otherwise laptop was working excellent.

The main problem is that computer shuts down after 30 minutes, even when in Bios. Laptop boots normally (Native UEFI) with no delay at all.
Second symptom is that ME is totally missing from Device Manager, no yellow warnings, no signs of faulty drivers, all devices look OK.
Third symptom is that can’t wake from “sleep mode” anymore, it can only wake up with power button, but instead of the immediate wake up, it just restarts, with a 10sec. black screen Bios delay, so I’ve switched to “hibernate mode” that works OK. That way it also bypasses the 30min turn-off margin.
Another maybe side-symptom is that it does not accept standard Ram Memory upgrade according to HP. I tried recently to upgrade from 4GB to 8GB but after many tests looks like it can accept 6GB max (4GB+2GB) It also works with 4GB (1x4GB or 2x2GB) also with 2GB single module, but should accept up to 16GB (2x8GB) which I also tested without success. In combinations (2x4GB or 2x8GB) it powers on to black screen, caps lock LED ON, CPU fan @ full speed forever.

I tried to install 2-3 versions of the Intel ME driver from HP without success of course …since ME does not exist in Device Manager, Result is “This computer does not meet the minimum requirements for installing the software”.
Also I installed some HM76 compatible CPUs (Celelon, Pentium, i3, i5) but no difference at all. Hell was 30 minutes away again!

Some more info here

HP Probook 4540s
Motherboard HP 17F6
BIOS 68IRR ver. F68 - 04/11/2019
Chipset Intel HM76
CPU Intel i7-3630QM
Switchable Graphics - Intel HD4000/AMD Radeon HD7650M 1GB
Windows 10 Pro x64 20H2
Patriot Burst 240GB SSD

I haven’t started any mods yet because I don’t like at all the idea that I may lose the Laptop’s Factory Info like, Model, SN#, SKU#, System ID, Mac Address, Board ID, Board CT, Microcodes, etc if I do something the wrong way with ME.

I have the LP241 USB programmer (without the Clip) saved some bios chips already!
Edit: CH341A Black USB mini programmer
I believe I could also do the 1+5 pin bridge in Audio chip.

I wonder where to start from :slight_smile:
Sorry for my bad English, I’m just trying!
Thank you!

Make at least 2 or 3 complete backups of the original bios (read with programmer), and compare them. They should be a 100% identical. Then follow:

[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Hi Ifb6 and thanks for your reply!

Will do, will have to de-solder the Bios chip since I don’t have the clip needed to do the job when on board and there is no way to find one these days…

Do I have to restore Bios defaults before I proceed with this, or doesn’t matter? Asking because I have AntiTheft, DriveLock, SecureBoot disabled in Bios settings. I have removed the Cmos Battery because when started look for solution I read somewhere that may help with the ME restoration after corruption. Do I have to put it back at a specific step, later in the process of the ME fix, cmos battery has to be installed? or not?

Something I forgot to mention is that in Device Manager / System Devices there are 2 entries that can’t recall if they was there before.
"Xeon(R) processor E3-1200v2/3rd Gen Core Processor DRAM controller-0154
"Xeon(R) processor E3-1200v2/3rd Gen Core Processor PCI Express Root Port - 0151

I uninstalled them but they are both installing back at next reboot or by checking hardware changes in Device Manager.
Maybe it’s something related to the CPU family, or a ME fault I suppose.

Also, like 1 month ago I tried to put to sleep mode/wake it up and worked as it should several times, but that happened just once, never worked again after reboot.

Pardon me about all these details provided, but maybe someone will find something useful in them.

There are lots of SOIC8 clips?

For example…r/dp/B07BRSVRXV

Post the bios dump if you like.

Thank you lfb6! I finally desoldered the chip

Here is my dump

Pre production firmware is not part of the repository. Which firmware did you use to fix this?


Hi Ifb6,

that one is in the faulty bios dump.

I don’t know what pre-production means, I assume that was a Beta version F/W that somehow didn’t installed/updated correctly and caused all that mess.

Here is my new fixed dump and the new MEinfo result. Do you think it’s OK? or further fixes needed?
Computer now works excellent, ME reappeared in device manager, no 30 min turn off anymore! is what I’ve installed



Pre production firmware works normally only with engineering sample hardware. Obviously this notebook isn’t an engineering sample since it’s working fine now with a production firmware- so this means someone tampered with the firmware before.

Otherwise if everything is working as it should no need to do other tests, just enjoy your working notebook

Don’t know how that firmware was installed, I tried some drivers found at HP - Intel and other places, all without success, maybe one of them left some traces, or half-installed. I’m very sure that Meinfo was showing in Windows “ME version: Unknown”. That forced me to start searching how the disappeared ME could be repaired-restored.

Finally charging adapter is also faulty, throws a “smart charger is not functioning” message in Windows, I have to unplug/re-plug 3-4 times for it to start charging, checked voltage and found OK, I suspect it’s adapter’s internal circuit fault on the signal line that causes this malfunction but this is not a problem after all…

Thank you so much Ifb6!