Intel MEI driver & firmware installation issue / HP spectre x2 12-a008nr

Using a008nr laptop manufactured from HP.

I updated bios as latest version(F.28), and device worked properly.

Months ago, I installed android-x86 system with GRUB2 and it was fine.

Then recently, to test another android-x86 system I removed former android.

During uninstall , I deleted many files in EFI partion of laptop to clean GRUB2.

After those process, device can’t shutdown normally.

When I click system shutdown button at windows OS, screen becomes black.

But device is still on.

I suspected this problem as windows one, so I re installed windows.

And it didn’t work. After OS installation, I downloaded drivers from HP.

Other drivers are fine, but intel MEI driver and firmware can not be installed.

Also, at windows device manager I can’t find intel MEI.

Now, I suspect this problem as firmware’s one.

I tried many trouble shootiong guide from HP to re-flash bios.

But can not flash at all.

Can’t someone hlep me? I really have no idea.

I attached log of intel MEI driver install software, and result of MEInfoWin64.exe

My laptop info.

Equipped with an Intel Core m3-6Y30 processor (1866-MHz FSB, 4.0-MB L2 cache, dual core, 4.5-W),

4.0-GB of system memory

Parts number of mainboard is 830318-601

OS system is windows 10 pro 64bit

log.txt (26 KB)



Same problem with MSI GT62VR 6RD , msi released same tool (from intel i think) for my laptop , after applying that patch my laptop is unable to shutdown and reboot properly (need to keep power button pressed to shutdown), also booting takes a while (stays around 1/2 mins on msi logo , trying to load bios i suppose). Tried everything for now , also reflashing same (latest) bios version , reflashing EC fw , reflashing ME fw but intel tool returns errors…


My laptop starts really slow too. Your issue seems almost same as mine.

Now, I am trying to dump my bios image… but it also prints error message :confused:

The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.

I know , in fact i reflashed bios using afuwin which was unable to erase/write ME FW sectors , bios blocks only :confused:

Probably the patch didn’t apply correctly and broke ME sectors , intel’s fwupdlcl doesn’t flash anymore , returning:


Error 8743: Unknown or Unsupported Platform
Cannot locate hardware platform identification
This program cannot be run on the current platform.

And MEInfo return same errors as yours

I am trying to flash ME binary file via FPT, but it also prints same error.

It seems ME or BIOS region is not allowed to access.

From fptw-i command, all master region’s access is disabled.

Luckily, HP is planning to update bios as newer version(patch for spectre and meltdown vulnerability).

But I don’t know it also includes ME update too. :confused:


I tried FPT too but nothing… BIOS region is accessible but ME region is locked…

As i said i can flash BIOS using AFUWIN , just BIOS region , nothing to do with ME FW.

The problem is that also if MSI (in my case) releases a new bios update i can’t flash FROM BIOS (from bios should flash ME region also) because when i select my BIOS ROM from usb , then laptop needs to reboot to flash and here’s the problem because my laptop actually can’t reboot/shutdown himself…

If i keep pressed power button to turn it off and then i turn it on , BIOS returns an error saying something like there was an error and BIOS can’t be updated

We need @plutomaniac help with his ME fw experience , if there’s something we can do

@ Rovitz

My device luckily can reboot himself in some situation. To flash bios firmware at HP laptop, need to reboot as diagnostic mode.

In diagnostic tool, there is option for firmware updates. But, to me it dosen’t work with errors.

I think our devices are totally doomed…

To get access ME region, I tried another way.

I dumped my bios with FPT -d bios.bin -bios command, then extract setuputilty module with Phoenix bios mod tool.

Extracted module as decompressed, and again extracted to .txt with Universal IFR Extractor.

Finally I acquired settings of ME State / ME FW Re-Flash variables.

I booted to UEFI shell, and typed command setup_var.

And this is result :slight_smile:

can’t set variable using efi (error: 0x0000000000000001a)

I guess HP blocked any of paths to modify their bios and firmware settings.

Hahaha… now there are only two options for me. Wait for new BIOS (if I success to flash it) or buy new maindboard. (3.82 MB) (155 KB)



You’ve already tried setup_var which modification is not strange to be locked out by the OEM for security reasons. Have you tried the audio chip pin shorting for temporary allowing CSME firmware region read/write access? For Realtek audio chips, the instructions can be found here (example picture). For HP, there might be some hidden hotkeys that they use at the factory to quickly unlock the CSME firmware region for servicing. Try holding Right Arrow & Left Arrow and press the Power Button when the system is fully shutdown (S5 state). Maybe it’ll work, otherwise you may be able to find something else by looking online.

@ plutomaniac

Thanks for good tips!

I tried several key commands as you said, but none of them work.

Addtionally, this device uses Conexant CX7501 audio chipset, and it seems very smaller than I thought.

I decided to buy new motherboard for replacement.