Intel MEI flash - lost network card function

Hi, I just found your site through google.

I have a Intel 3930K system with Asus P9X79-WS motherboard. I flashed an update to Intel MEI and somehow after rebooting no network cards get an IP address.

I got 4 network cards, two intel onboard ones and a dual broadcom pci-e card.

I checked the operating system and drivers, even tried to reinstall the system and also I reflashed bios using bios flashback to several versions without a solution.

I don’t have a MEI backup unfortunately.

Can anyone help me with this issue ?

What exact firmware did you flash and what tool did you use? Download ME System Tools v8 and run Flash Programming Tool with command fptw -greset which will reset the system immediately. Does that solve the problem? If not, run MEInfo and MEManuf tools and show what they report. Also, run Flash Programming Tool with command fptw -d spi.bin , does it complete successfully or do you see Error 26?

I think that your post just solved my problem. Thanks a lot for the help plutomaniac.

I flashed latest MEI available (for this board I think), using:

FWUpdLcl64.exe -f

When I first ran fptw -greset it stop with a yellow message saying that the firmware store was on state “fwupdate”. Even after several shutdowns. I did one more shutdown sequence including a power drain using the psu button and so on.

After that network cards were under the same error, but magically it started working after 30 secs or so.

Also, MEinfo shows the usual information:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version: 4802
MEBx Version: Not available
Gbe Version: 1.0
VendorID: 8086
PCH Version: 5
FW Version:
UNS Version: Not Available
LMS Version:
MEI Driver Version:
Wireless Hardware Version: Not Available
Wireless Driver Version: Not Available

FW Capabilities: 0x00110440

Intel(R) Capability Licensing Service - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

Cryptography Support: Disabled
Last ME reset reason: Global system reset
Local FWUpdate: Enabled
BIOS Config Lock: Disabled
GbE Config Lock: Disabled
Host Read Access to ME: Enabled
Host Write Access to ME: Enabled
SPI Flash ID #1: EF4017
SPI Flash ID VSCC #1: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Capability Licensing Service: Enabled
OEM Tag: 0x00000000
Localized Language: Unknown
Independent Firmware Recovery: Disabled

MEManuf passed the test ok.

Also, fptw -d spi.bin exported the file ok. No errors whatsoever.

I’ve been away from modding and overclocking for some years now (39 years old now) but now that I got my head in place :), I just noticed that Fernando is the same guy who used to mod DFI Nforce bioses yeaaars ago. I had a pretty nice DFI motherboard watercooled using one of his modded files.

It’s amazing to receive help and fix a problem. I’m definitely donating to the forum.

Thanks a lot again, you just saved my work and a lot of money.

Ah yes, that’s why I mentioned -greset first. The ME was stuck so it needed a reset to initialize again. It can happen sometimes after using FWUpdate. The other steps were not needed as long as that worked which it did and I’m glad.

Thank you for your willingness to donate Crisao23, it means a lot to the community.