Intel NUC DCCP847DYE Results

I just updated my Intel NUC DCCP847DYE, It has DCP847SKE board… I began by dumping the SPI flash using my FlashcatUSB programmer

Updated all the modules using UBU v1.70.rc20.1, here is the before and after

I ran into a couple minor issues:

1- I extracted VBIOS v2158 and updated v2171, UBU could not integrate the vbiossib.dat so I had to do manually it using MMTool v5.0.0.7

2- It already has the latest CPU MCode, but it does also contain a couple out of date ones so I ran the MC update

I notice when I did this it broke CPU Display Info in the Bios (so I skipped this step as it was really not necessary)

I have attached the Full SPI dump, VBIOS and RST bins I used in case anybody wants to replicate or troubleshoot.

DCCP847DYE_Files.rar (4.57 MB)

@ricktendo - I can look and see if I know the source of the CPU Display info issue caused by microcode update, does the above file also contain the BIOS before you modified it? I need to compare stock dump to your final mod BIOS that did contain your microcode update (Is that one included too?)

If neither of the files I mentioned are included, attach them by themselves as a second attachment.

Hello thanks,

Yes the file attach in my previous post is my virgin SPI dump before it was processed with UBU, it also contains the RST and VBIOS so you can use all these with UBU+MMTool v5.0.0.7 to process and compare the BINs

Issue #1: UBU cannot integrate vbiossib.dat
Issue #2: CPU Micro Code breaks CPU Info in BIOS
Issue #3: “PE32 image with invalid DOS signature” when integrating EFI IRST

@ricktendo - I initially posted about CPU display info and microcode updates, I can help with that. RST I can’t help with choosing etc, but if you have some issue inserting, I can do that. vBIOS I can edit and insert etc, so if you need any help with that I can help too.
Is your final BIOS mod, that has the CPU display issue with updated microcodes included above or not? If not, please repackage with all in one zip, then I can look to see if I know the cause of the issue you mentioned, then I can explain to you how to avoid or how to fix etc.

Looking at your list now, #1 this may be due to how you extracted the vBIOS, how you edited it, how it’s being inserted, does it have a header or not etc. many things can be the cause of this.
#2 I need your final mod BIOS with this issue (Is it included above?), and stock dump which you mentioned is above. I have limited bandwidth, so only download once I’m sure it has all the files I need to check, so I’m not downloading multiple packages for no reason.
#3 see #1, same applies. Also, what happened? Looked like you did RST correctly already in post one?

Is there a reason you are using MMTool v5.0.0.7 instead of 5.02

I can do all this for you manually (Without UBU, will use UEFITool/hex instead), properly, so if you need that done instead of troubleshooting let me know.

Thanks again,

Its very easy to reproduce… just run the latest UBU on the virgin bios, integrate cpu microcodes and compare

I have uploaded a before (virgin) bin and after (ubu integrated mcodes) bin, I have also included the VBIOS and RST files (but I have not integrated them)!a9hzxQJS!jxt9HH-PP-Ro3…fMCZZMu7L0YLO9U

@ricktendo - I know I could do the same edits you did with UBU, but maybe not same outcome, that is why I asked for your specific edited files since you had issue I wanted to check the exact files you were using.
That’s more ideal package, thanks!

I suspected this issue, or another one related, here’s the issue with the microcode updates (it’s a failed BIOS mod)


Do you want a mod BIOS, with properly updated microcdes? And the RST/vBIOS inserted too? if yes, is that vBIOS edited, all done etc, ready to be inserted?

If you could only update the "before" BIN it with the MCode and VBIOS this would be great, or if you can tell me how to do it properly even better.

The VBIOS is edited correctly, and its been tested and working

I will use UBU then to update the rest of the components

@ricktendo -
Yes, that would be the file I would edit. Have you tested BIOS edited with UBU for “Rest of the components” edited and it’s OK? Wondering if maybe this specific BIOS and certain versions of the files included with UBU may always make similar bad rebuild.
Sometimes that happens if entire BIOS is rebuilt each time you edit with UBU, and when/if it does you’d need to use older UBU or edit everything manually with other tools.

Thanks for confirming vBIOS tested and working. Microcodes and vBIOS I would insert with UEFITool, either latest version or 25.0 if padding issue happens still with latest version.
Update of microcodes would be done by extracting microcode body with UEFITool, edit in hex or build a new one from scratch in hex (ideal, to keep offsets at proper multiples of 800h), then replace body with UEFITool,
Microcode edit specifically you need to watch for that padding issue, if it occurs with version 26 then use 25.0 instead (Did not, 26 OK, used version 26 for both edits)


Yes, if I update everything except the uCodes the bios works fine.

I tried your updated bios but this does not boot for some reason

@ricktendo - Really!?? Sorry! Maybe 26.0 is not good one to use for this BIOS? Or, vBIOS does not go into CMSCore? Doubtful on that. I did not update GOP, only the vBIOS you included. I do see in above image first post, you also updated Ivy GOP, maybe this is why it failed, I didn’t update that since you did not include.
Let me redo with just the microcodes, two ways, then you can test both, if both OK then we know vBIOS insertion location or method (UEFITool 26) didn’t work, need to use 25 or MMTool… Or GOP also needs updated at same time like you did before.
Here is microcodes only via UEFITool 25 and 26. Please test 26 first, since that will test immediately if UEFITool version is the issue, or vBIOS only without GOP is the issue. If it fails, then try 25, if that works then we know UEFITool version is the issue.

No need to worry or be sorry as I have a FlashcatUSB SPI flasher and my original bios backup, I am immune from bricking!!!

I did not further update the bios you sent, I flashed this as is and it did not boot. Thanks for the update of just the uCodes, I compared both 25/26 and they are identical byte for byte so there is no need for testing one vs the other.

Will test the bin later today after I get off work, if it works I will use UBU to update the rest

Update: flashed the uCode only and same result, does not boot.

I knew you had programmer, always good to have! Hmm, didn’t realize 25/26 would be same, usually they edit differently. SO I guess that’s a good sign for UEFITool, not the problem, my edits of the actual code is, I’ll look it over now and let you know if I can see the issue.
Sorry for saying I could fix the problem, and now making it worse! Let me see if I can figure that out! Something in the process, can’t be the ucode itself, since I even put yours first, so even if others were misaligned which they are not, yours would load no matter what being first.
* Pre-post edit - I can’t find any visible issue with the microcode updates

Lets ask @MiesMosel if he’ll check over my edit to see if I got the offsets correct. I’m pretty sure I did, all opens in MMTool and BCP correctly, but obviously there is some issue here.
Miesmosel, I used 800h multiples, which seemed like the original was using as well. Without that, like we’ve seen before, doesn’t show up properly in MMTool or AMIBCP.
It’s Aptio 4 BIOS, but not all ucodes show in original BIOS there in MMTool 4.x, only in MMTool 5 you can see all (or MCE, AMIBCP 4.55). Watch out for the padding file right above microcodes, UBU drops it on edit, needs to remain in place.

Anyway, thank you for looking for me, maybe I’m missing something you will see? Hope so!
Original BIOS “Before” in post #5, my original edit in #8 and subsequent edits using UEFITool 25/26 (Same) in post #10 - you can check any, microcode file is same in all (BIOS at post #8 has vBIOS update also, #10 does not)


I’m going with you @Lost_N_BIOS … MMTool 4.50 don’t show all MCs.
Too proof I need the original BIOS file without editing.

Best regards & GN8,

You can find the original untouched/virgin dump on the 1st post, thanks.

Sorry, I found it same time you answer me, but I can’t watch anymore it’s too late.
I’ll do it tomorrow.

@MiesMosel - post #5 also has unedited BIOS dump via programmer ("Before" BIOS) - thanks for stopping in to help check this out with me!


which BIOS is the base of these dumps?
If you had flashed BIOS v66, then you have a big problem … the BIOS is then write-protected.
So then thoughts are: “If you just buy & trust Intel, it’s your own guilty.” You can’t go back to v65.
Maybe by flashing via programmer - I don’t know. Write-protection could mean a problem … or not.

How to find out, which bios-version is working on your board, look here.

If the base BIOS is v65 or below, then editing could be possible, but how I don’t know.
The editing by Lost_N_BIOS looks good, but I couldn’t compare it with original BIOS because of .bio-format.
.bio seems not the be the raw-file like (from other BIOSes) biosname.123 or something like that.
It’s length is 9,35MB, not 8MB (raw).

So if somebody know how to extract the .bio into a .bin (or whatever) …


I explained all in the first post I tagged you @MiesMosel - I’ve never seen BIOS V66, sorry. I only downloaded the BIOS I mentioned in my post.
I edited his original dump, as mentioned. Intel BIOS you always have to edit dump only, edited .BIO files can be made many ways, but cannot be flashed or programmed etc. Download files from post #5

Thanks again, sorry for not making the above more clear to you in my original post. Please download only BIOS in post #5, then check his original dump "Before" - that is BIOS I edited, then posted in posts #8 and #10

sorry, that I didn’t understoud immediately what exactly to test …

but v65/v66 could be very important to know. @ricktendo please have a look @ BIOS-version number while booting the NUC. Other you could proof, that you use “SPI NOR” interface. And I think it should be 3.3V - do you use that? (sorry for questions, but it is for proofing)

The flashcat seems to be powerful (5V, 3.3V, 1.8V). Which version do you own (classic, pro, mach1)?

I take a look in the night into the BIOS-files, when I’m back …