Intel Raid - P6T Deluxe V2 - Win 10 installer doesn't recognize drives, needs driver, no driver out there is compatible according to installer.

So, I had this problem once before and frankly I can’t remember how I fixed it. Windows 10 installer says can’t find drives to install on and to install drivers. I’ve tried every single Intel RST driver out there and none “work” the installer keeps saying no compatible drivers found.

I have 2x SSD (raid0) and 2x HDD (raid1) and when I’m “browsing” for the drivers to install the installer sees and lists any directories on those two arrays so I’m really unsure if it’s saying it can’t find drive(r)s to install to or if it’s trying to tell me there’s something else that it wants drivers for. I’ve tried all the tricks, USB install, DVD install, USB install switching to a different port when the installer loads, clicking the install text and when it asks for drivers cancel out back to the install screen and clicking it again, if you can find ANYTHING about the Win 8/10 installer not finding drives to install to I’ve tried it all with no luck.

I had a thread awhile ago with this same exact program that Fernando was talking to me in and I suspected (still do) that it’s related to the BIOS or OROM since I was flopping back and forth between them when it suddenly started “working” last time but I’m at my wits end at this point. :-/

For good measure I also did a “load defaults” in the BIOS with no dice either.

@ pugtor:

You don’t need a driver, but just the correct BIOS setting.
As long as you haven’t set the Intel SATA Controller to “RAID” within the BIOS, your RAID arrays will neither be detected by the BIOS nor by any Operating System.



I never change the setting from RAID to anything else. Otherwise how can I install 7 even. I wish it would actually tell me what driver was missing because TBCH, I’m unsure if it’s really the drives that it’s not detecting considering when I’m “browsing” for the drivers I can see both arrays. It’s very strange considering when I am “browsing” for those I see both arrays (and their contents), but it’s like it doesn’t consider them valid install destinations, it just keeps asking for drivers.

I suppose the only real “peripherals” I have attached are an internal smartcard reader, an internal 2 port USB card, and a printer so maybe it’s not finding drivers for one of those 3 things and it won’t let me even attempt the install without the drivers for those. I never had to disconnect those things though. Everything works great with the Windows 7 installer. :-/

Really?
Within your previous post you had written the following:

The “DEFAULT” setting regarding the IDE mode of the Intel SATA Controller usually is “IDE” or “AHCI”, but never “RAID”.

Now to your “driver problem”:
There is no need to load any special driver to get Windows 10 installed onto your X58 Chipset RAID system. All Windows Operating Systems from Vista up have generic in-box drivers, which are able to support the Intel SATA RAID Controller of your mainboard’s ICH10R Southbridge.
Provided, that your Intel SATA Controller has been set within the BIOS to “RAID” and the Intel RAID Utility (accessible via CTRL+I) shows a “Healthy” and “Bootable” RAID array, I recommend to unplug all drives, which are not absolutely required for the OS installation, before you start a new try to get Win10 TP installed.
Questions:
1. Which disk drive of your current configuration is the system drive with the boot sector on it?
2. How do you want to get Win10 installed (as clean install or upgrade)?
3. Which boot device (USB Flash Drive or DVD) are you using)?
4. Where is the boot drive connected?

heh, I figured this was an enthusiast forum, so it was implied after I loaded defaults I was smart enough to put it back to raid in bios.

as for the questions,

current disk drive? meaning what exactly? sata 1 and 2 is raid0 ssds. sata 3 and 4 is raid1 hdds. the raid0 is what always gets windows, it doesn’t matter if i leave a boot sector and partition on the array or if the array has no partitions. the installer instantly and always says missing drivers.

clean install, always. funnily enough in testing if i upgrade install from 7 to 10 it worked without problems.

I typically use usb thumbdrives for all my win 7, 8 and 10 install media, using the windows usb/dvd tool to create them. I have tried with dvd due to the “oddities” people report with the win 10 installer on usb though, no luck.

as per above, boot drive is sata 1 and 2. the marvel rom is disabled altogether in bios.

Im going to try unplugging the raid1 array and then see what happens, but its not exactly drivers it needs to see the disk drives considering the installer can see and read all the drives when searching for the missing media drivers it keeps wanting.

My favorite tool for such purposes is Rufus (>LINK<).