Intel Rapid Storage problem

Hi there !

I have one question , if anyone had similar problems.
I have installed RST 12.9.0.1001 version.
Application is working, but service doesn’t want to start, error 1068 or 1053, also i can’t uninstall application, fatal error !
I have clean install of Windows 8.1 64bit and i have already used RST before, just this time i have such a behaviour.
And i installed RST at the end of 8.1 installation, not before upgrading 8 to 8.1.

Is there any information on that.
I tried already a lot of different suggestions and so, but nothing.
Interesting is that, application is working normally, just service can’t start or un-installation of application no.

Best,
Matej

@ schmety:
Welcome at Win-RAID Forum!

For a proper function of the Intel RST software is the presence of .NET Framework v2 or v3 required. Both are included, when you install .NET Framework v3.5.
This is what I recommend to do:

  1. Install .NET Framework v3.5 and reboot.
  2. Reinstall the complete Intel RST Drivers & Software Set v12.9.0.1001 and reboot.
  3. Start the RST Service again.

Good luck!
Fernando

Thanks for your reply !

If i go to "turn windows application on or off" i see there, that i have already checked .net framework 3.5 (included 2 and 3).
Maybe if i try to re-install .net framework again ?!

It is not needed to reinstall .NET Framework v3.5, if you had checked this feature previously.
Just re-install the Intel RST Drivers & Software Set.
I suspect, that you had installed the .NET Framework after the RST Software. It should have been done vice versa.

Normally i install first Windows, install all updates and then i install all drivers,
for motherboad, RST and graphic driver !
Few months ago i already have the same configuration and everything worked normall.
So ,i’m thinking what was this time different.
And yes, i can’t un-install RST software, cause it writes me fatal error while un-installing or installing.


Also try to build a 8.1 installation disc. You can activate Windows with your 8 key after installation. For the install procedure you nee a “dummy key” you can find here (the key is just for installation, you activate with your Win 8 key). Download the win 8 and 8.1 installer from microsoft. Start the win 8 installer and download with your original key. After one minute stop and cancel the download, exit installer. Then start the installer for win 8.1. The download should start without the need of a key. When finished use the option “build install media” (or what it’s called in english). With the USB stick or iso file you got you can make a clean install of win 8.1. Use the dummy key during setup and your win 8 key to activate windows after installation. The you got a really clean install…

If you don’t want to re-install the Intel RST(e) Drivers & Software Set v12.9.0.1001, I recommend to install the Set v12.9.2.1000 WHQL on top of the older Set.

Thanks Hanson !
Yes, i know for this procedure to install :wink:

Fernando ;
Problem is that , no matter which version i want to install, i also tried with that one you mentioned, but simply i can’t .
I get fatal error message , if i try to un-install older version or just run newer one on top of older.
I must be something missing here, but still i’m figuring out. :wink:

@ schmety:
I don’t believe, that your issue has been caused by a special Intel RST(e) Drivers & Software Set (e.g. v12.9.0.1001). So your problem may reappear, when you try to install any other complete Intel RST(e) Set.
Question:
Why did you install the Intel RST(e) Software at all? If you should run the on-board Intel SATA Controller in AHCI mode, you will not really need it.
My suggestions:

  1. Do a fresh install of the OS.
  2. Don’t install the Intel RST(e) Software unless you are running your system drive in RAID mode.

Thanks Fernando !

I noticed , when i installed RST drivers , performance - Random Read (IOPS) for my Samsung SSD drive is much better than without RST.

I will think about fresh install of OS, but i just did that, few weeks ago, so i’ll think once again about that :slight_smile:

My suggestion was to obstain from the RST software, but not from the RST driver.

You now have the opportunity to use the brandnew Win8.1 "Spring Update" image as source.

@Fernando

Do you know where to get the updated iso? (means included spring update)

You can get them >here< directly from Microsoft, if you are an MSDN Subscriber, but some of these ISO files are already floating around (look >here<).

Hey !

I have formatted, re-install everything, fresh install of Windows 8.1.
Everything works normal now !

But, i figured something and i also had the same issue before, with my previous install of Windows 8.1.

If i go to Windows Explorer and browse folders/files, works fast and nice.
Then… i updated Windows with this update KB2919355, which installed normal.
So, after this update, if i go to Windows Explorer and browse folders/files, everyhing stops for about 10seconds, like searching on something, then
work normal again.
That just happend after i log-on to windows, i mean , once and then is ok.
But it’s annoying, every time after i log-on and i use Windows Explorer a lot.
I have uninstall that update and Windows Explorer works like before, no stops, fast …

Like i said, i have the same issue before and i didn’t know that time, that this update causes that.

Best,
Matej

The KB2919355 is a cumulative update to the "Spring Update Edition", but maybe it needs one or more additional hotfixes to work properly.
Please run Windows Update again and check, if it offers that additional hotfix.

No, it offers nothing after that update. It writes no other updates available.

I can wait for this now and maybe update some other time then.