Intel RST accelerate on Windows 10

First off, I’d like to find out if anyone is using the Accelerate option on Intel RST on Windows 10

I have had no luck in trying to get it to work.
I’ve searched a bunch of forums, all with conflicting solutions that work and don’t work for different people. A couple of Intel communities threads even say RST is not supported in Win10(as of sep18)

I bought a used Asus G750JW with windows 8.1 installed, I upgraded to windows10.
I safe mode booted in order to change my SATA controller to RAID.

I plugged in my SSD, installed Intel RST 14.6.0.1029
Couldn’t see the accelerate button.
Immediately went a googling and found countless options/setups to try.

so now I’m here

I followed Fernado’s post about upgrading my SATA controller driver to the latest 14.6.1.1030, but that still leaves the actual RST program at 14.6.0.1029

Let me know what screen shots you’d like to see, and hopefully you can help me get this resolved.

@ mrgoldy:
Welcome at Win-RAID Forum!

Before you are going to install any other Intel RST Driver or Drivers & Software Set, you have to uninstall the previously used Intel RST Software from within the Control Panel (“Add/Remove Programs”) and to reboot.

Regards
Dieter (alias Fernando)

Uninstalled RST
rebooted
Controller driver still at 14.6.1.1030

downloaded new SetupRST.exe from Intel download center, latest listed is still 14.6.0.1029

start the install and get|addpics|1qd-1-ec2a.jpg|/addpics|

@ mrgoldy:

Why are you trying to install the Intel RST(e) Drivers & Software Set v13.6.0.1029 again?
You should run the installer of the Intel RST(e) Drivers & Software Set v14.6.1.1030 WHQL.
After the reboot you will have both Intel RST components (the Intel RST(e) driver and Software) with the identical version v14.6.1.1030.

where do I get v14.6.1.1030 .exe?
the link I grabbed from your other thread only has these files, no setup files|addpics|1qd-2-0f85.jpg|/addpics|

>Here<.
It is named “Intel RST(e) AHCI/RAID Drivers & Software Set v14.6.1.1030 WHQL”.

thank you for that, not sure how I missed the RST .exe the first time

so everything is now at 14.6.1.1030

I’m still not seeing the accelerate button.
Any other thoughts?|addpics|1qd-3-97fd.png,1qd-4-661f.jpg,1qd-5-08cd.jpg|/addpics|

Not sure if this is an issue

my UEFI has a section for Intel(R) Rapid Storage Technology

When I go into it, it has an Advanced tab Intel(R) RST 12.7.0.1936 SATA Driver

>Create RAID Volume (which I can press enter and then select the 2 drives), but if I do it whenever I come back into the UEFI, it acts like I have to select it again, so I’m wondering if it’s not working properly

20151026_122349.jpg

20151026_122356.jpg

@ mrgoldy:
The Intel Rapid Storage Technology (IRST) and a normal IRST data storage RAID0 is something else than the Intel Smart Response Terchnology (ISRT) and its RAID array, where the much smaller SSD is only used for data caching.
So don’t try to create a RAID0 array from within the Intel Rapid Storage Technology tab of the UEFI BIOS. You have to use the “Accelerate” button of the Intel RST Console.

Now to your problem, that you cannot use the “Accelerate” button. AFAIK there is a need for a certain unallocated space on one of the 2 disks (HDD and SSD), which should be used for the ISRT. Please do a Google search for informations about where and how to do it.

That’s where I’m stuck.

there are so many forums with different advice on how to setup the drives.

HDD is GPT, can’t change that
SSD is MBR

I just low level formatted the SSD to make sure everything is wiped.

I’ve tried with Unallocated, Healthy partiion, hibernation partition, combinations
with drive letter assigned, without drive letter.
shrink volume, extend volume, both on HDD and SSD
gone thru diskpart to clean the SSD after each try.
I’ve tried so many combinations, and I’m not sure what to do next.

I’d really love to hear if anyone has gotten SSD caching with the accelerate option to work in windows 10. it seems all the forums are examples of Win7 or Win8.1


|addpics|1qd-6-503a.png|/addpics|

@ mrgoldy:
Since I don’t have any own experience with the Intel Smart Response Technology, I am unable to give you any advice.

That seems to be reason for your problem.
AFAIK both disks should have the same sort of partition table. Otherwise it will be impossible to combine them to a RAID0 array.

Both are now GPT, which I read on overclock.net http://www.overclock.net/t/1562625/intel…t#post_24113860

still not working.

I’m at a loss, working on multiple forums. I will update here if I find a solution.

Hi, You must have two disk in RAID0 and SSD unallocated. After installing Intel RST start intel rapid storage utility from program menu and cklick accelerate RAID0 disk. Or One disk and configured SATA as RAID. Disk can have MBR or GPT.

intel_smart_response_technology_user_guide.pdf (180 KB)



No! The manual clearly states “Single Hard Disk Drive (HDD) or multiple HDD’s in a single RAID volume”, which does NOT mean only RAID is supported. Single drives are supported, too.
Don’t confuse other users with misleading information, but thanks for posting the manual.

EDIT: please have a look here. Intel Smart Response Technology is not supported on Windows 10, the developers are working on it.
20 minutes of research on Google…

“RAID mode” and a RAID array are different things. You can set the SATA mode to “RAID” without creatinmg any RAID array.
AFAIK the Intel Smart Response Technoilogy only will work, if the Intel SATA Controller has been set within the BIOS to “RAID”.

Lets read this again: "Hi, You must have two disk in RAID0 and SSD unallocated. …" (posted by thomasxx)
2 disks in RAID0 are not requiered for Intel SRT. I never said that RAID mode itself is not requiered.

Who said, that it is required before starting the “Accelerate” button?

Who said, that it is required before starting the "Accelerate" button?



He wrote that 2 drives in RAID0 + 1 unallocated SSD are the requierements. Since the SSD is unallocated, it is not part of SRT (it would have at least a 20GB cache partition).
Pretty sure I did not understand him wrong, since the manual describes the process with a RAID0 of 2 HDDs and an additional SSD…

sorry for my english , i wrote uncleary. You can have 1 disk and SSD. In BIOS set SATA in RAID mode or can by accelerate RAID arrey too. RAID arrey must by configured in RAID0, strip size. Original PDF guide from intel included in my previouse post.

RAID0SSD.JPG