Intel RST not working

Hello I’ve gotten intel RST to work twice in the past but after I reinstalled windows it just doesn’t work. I even tried reinstalling it again and trying windows 10 still no luck. I’ve tried different version of it and have Intel OROM 10.2 installed but keep getting the same error and have no idea on how to fix it.
Motherboard: ASUS P8Z68-Z

@ celago:
Welcome at Win-RAID Forum!

1. Are you running your Intel SATA Controller in AHCI or RAID mode?
2. Which Intel RAID ROM version is within your mainboard BIOS (v10.2 doesn’t exist)?
3. Which Intel RST driver version are you running?
4. How did you install the Intel RST driver?
5. When you tried different Intel RST drivers, how did update/downgrade the currently running version?

Dieter (alias Fernando)

Thanks for the welcome Fernando.

1.Raid (Yes the HDD are also in raid)
4.I downloaded it from here then installed as "iata_cd.exe"
5.Uninstalled and reinstalled. Also for the version I am currently using it was installed after just reinstalling windows

I’ve tried a few versions now can’t remember exactly, the newest one and a few before that. Right now I’m running on a fresh windows with only one version that has been installed (